NextFEM Designer Manuale Utente

NextFEM

Designer

Manuale Utente

Version 2.3

© NextFEM 2015-2024

Indice

1. Introduzione. 9

1.1. Versioni di NextFEM Designer 9

1.2. Installazione di NextFEM Designer 9

1.3. Attivazione licenza. 10

1.4. Manuale e supporto. 10

1.5. Interfaccia utente. 10

2. Modellazione mediante NextFEM Designer 12

2.1. Controlli utente. 12

Uso del mouse. 12

Scorciatoie da tastiera. 12

Opzioni da riga di comando. 14

2.2. Convenzioni per assi locali 15

Travi e aste. 15

Sezioni di elementi monodimensionali 15

Elementi piani 15

Elementi solidi 16

Section cut 16

2.3. Menu File. 16

Nuovo. 16

open32 Apri 16

save32 Salva. 16

save32 Salva come: 16

Chiudi 17

import32 Importa. 17

import32 Unisci 17

import32 Importa risultati OpenSees. 17

import32 Importa dataset aggiuntivi 17

export32 Esporta. 18

Esci 18

2.4. Menu Modifica. 18

material Materiale. 18

sect Sezioni 20

Sezioni composte. 23

Calcolo resistenza. 24

LC Casi di carico. 27

sisma Funzioni 28

draw48 Imposta unità. 29

check32 Controlla connettività. 30

check32 Controlla sovrapposizione elem... 30

check32 Controlla nodi liberi 30

check32 Controlla proprietà elementi 30

numbering Rinumerazione. 30

check32 Controlla mesh linee. 30

mergeNodes Strumenti per nodi 30

mergeNodes Unisci nodi sovrapposti 30

move nodes Sposta nodi 30

rotation Ruota nodi 31

scaleNodes Scala nodi 31

mirror Specchia nodi 32

quad16 Strumenti mesh. 32

tria16 Mesh area. 32

quad16 Aggiungi parete. 33

quad16 Auto-mesh parete. 33

Mesh travi a sezione variabile. 33

Aggiungi cinturazione. 34

divide Dividi e unisci 34

Da parete a telaio. 34

Estrudi sezione. 34

changeType Cambia tipo elemento. 34

estrudiElem Estrudi elementi 35

cut Taglia. 35

copy Copia. 35

paste Incolla. 35

iconmonstr-undo-4-32 Annulla. 36

Ripeti 36

2.5. Menu Visualizza. 36

select32 Seleziona tutto: 36

Inverti selezione. 36

unselect32 Pulisci selezione: 36

close32 Elimina selezionati 36

gruppi Selezione per gruppi 36

Seleziona per nome. 37

prop Seleziona per proprietà. 37

Mostra tutto. 37

Mostra solo selezione. 37

Nascondi selezione. 37

box-rotate16 Ruota ingombro. 37

Sposta: 37

select32 Zoom rettangolo. 37

Viste. 37

viewNodes16 Mostra nodi 38

extrude16 Estrudi 38

arrow-16-DOWN Mostra carichi 38

Controlli vista. 38

recent Dati nel modello. 39

modelTree Vista ad albero. 40

2.6. Menu Disegna. 40

node Nodo. 40

node Nodo da coordinate. 40

Asta. 40

Trave. 41

Trave3. 41

tria16 Triangolo. 41

tria16 Triangolo6. 41

quad16 Quad. 41

quad16 Quad8. 41

tetra16 Tetra. 41

tetra16 Tetra10. 41

wedge16 Wedge. 41

wedge16 Wedge15. 41

solid16 Cubo. 41

solid16 Cubo16. 41

solid16 Cubo20. 41

spring16 Molla. 41

Gestore griglie. 42

Immagine che contiene Rettangolo, schermata, Policromia, Blu elettrico Descrizione generata automaticamente Controllo viste. 42

2.7. constraint Menu Assegna. 42

arrow-16-DOWN Carichi 42

autoLoad Carichi automatici: Assegna. 42

concentrato Carico puntuale. 43

temperature Temperatura. 44

edge Carico su lato. 45

floor Carico di piano. 46

surfaceLoad Pressione. 47

volumeLoad Carico di volume. 47

loadsGenerica Spostamento imposto. 47

iniTemperature Temperatura iniziale. 48

prestress Precarico: 48

masse Massa puntuale. 48

Masse da carichi 48

material Materiale. 49

sect Sezione. 49

rotation Rotazione assi locali 49

vinc Vincoli 49

constraint Vincoli interni 51

gruppi Gruppi 51

endRelease End release. 51

endOffset Tratti rigidi 52

elemProps Proprietà elemento. 52

hinges Cerniere. 53

member Membratura. 55

rebar Armature. 55

spring16 Proprietà molle. 56

LCB Genera combinazioni 65

LC Impostazioni analisi 66

2.8. Menu Strumenti 68

arrow-16 Lancia. 68

Lancia selezionati 68

cloud2 Login nel cloud. 68

query2 Query. 69

screen16 Screenshot 69

wizard Impostazione guidata modello. 69

frameGen Generatore di telai 69

sectFromModel Sezione da modello. 70

Aggiungi plinto. 70

options32 Opzioni 70

2.9. plugin Plugins. 72

2.10. Menu Risultati e Verifiche. 72

view32 Mostra risultati 72

Animazione. 73

extrData Estrai dati 73

report Stampa report 73

Imposta limiti del contour 74

delete Cancella risultati salvati 74

delete Cancella le verifiche salvate. 74

Somma carichi e masse. 74

Computo metrico. 74

Più stazioni di output 75

verifiche16 Verifiche. 75

smartCheck Verifiche intelligenti 75

fire16 Verifica al fuoco. 76

Verifica ribaltamento. 77

* Analisi cinematica muratura. 77

IDEA CheckBot 78

2.11. Menu Aiuto (?) 78

help16 Aiuto. 78

updates Controlla aggiornamenti 78

language Lingua. 78

Licenza. 78

esclamativo Informazioni su. 79

3. Funzionalità di import/export 80

3.1. Importazione. 80

OpenSees. 80

Midas GEN®. 81

SAP2000®. 82

OOFEM.. 83

ADAPTIC and Zeus-NL. 84

ABAQUS® e CalculiX. 84

Dxf 85

Straus7®. 85

File BIM – IFC e IFCxml 85

Modelli SAF (Structural Analysis Format) 85

3.2. Export 87

ABAQUS®. 87

OpenSees. 87

Midas GEN®. 87

SAP2000®. 88

OOFEM.. 88

Dxf 89

File BIM – IFC e IFCxml 89

Open Model per IDEA StatiCa. 89

Modelli SAF (Structural Analysis Format) 89

4. Personalizzazione. 91

4.1. Librerie dei materiali 91

4.2. Librerie di sezioni 91

4.3. Librerie di sezioni per punti 92

4.4. Verifiche personalizzate. 93

5. Validazione ed esempi 99

5.1. Tutorial Uno. 99

5.2. Tutorial Due. 107

5.3. Tutorial Tre. 112

5.4. Tutorial Quattro. 115

5.5. Tutorial Cinque. 119

5.6. Tutorial Sei 122

5.7. Tutorial Sette. 123

6. Termini di licenza. 128


1. Introduzione

NextFEM Designer è un programma intuitivo per l’analisi a elementi finiti, che può essere usato da solo o come pre- o post- processore per i più diffusi programmi FEM (ad es. OOFEM, SAP2000, Midas GEN, OpenSees, ABAQUS/CalculiX, Zeus-NL, e altri…).

Le caratteristiche più importanti sono:

-    avanzate capacità di pre-processing: viste 3D e 2D, colori personalizzabili, accelerazione grafica mediante tecnologia DirectX;

-    capacità di modellazione con tutti i più diffusi elementi finiti, quali travi, shell e elementi solidi;

-    importazione del modello da file di disegno DXF, script di OpenSees, Midas GEN e Civil, SAP2000, ABAQUS, OOFEM, Zeus-NL, Sismicad, Nolian, CMP;

-    importazione dei risultati da SAP2000, OOFEM, OpenSees, CalculiX, Midas GEN e Civil, Sismicad, Nolian, CMP;

-    esportazione del modello nei formati SAP2000, ABAQUS, Midas GEN e Civil, OpenSees, OOFEM;

-    capacità di post-processing con visualizzazione della deformata con gradiente di colore, diagrammi di travi e aste, gradiente di colore per stress e deformazione.


1.1. Versioni di NextFEM Designer

NextFEM Designer è disponibile nelle versioni seguenti:

    versione convenzionale, scaricabile dal sito nextfem.it, avente tutte le caratteristiche descritte nel presente manuale;

    versione Lite, disponibile solamente in Windows Store® e per Windows 10®. Tale versione non accetta alcun codice di licenza e non sono presenti le seguenti caratteristiche:

o    calcolo in cloud;

o    manualistica sui moduli dedicati.

Per questa versione non è possibile quindi accedere a tutte le funzionalità descritte nel presente manuale.


1.2. Installazione di NextFEM Designer

NextFEM Designer è progettato per Windows 7 SP1 o superiori ed è disponibile per le versioni di Windows a 64 bit.
I prerequisiti sono:

-    .NET Framework 4.7.1;

-    VC++ 2019 redistributable package.

Per associare i file NXF con Designer basta avviarlo almeno una volta come amministratore (click destro/Esegui come amministratore…).


1.3. Attivazione licenza

Per poter utilizzare il programma è necessario essere connessi ad Internet la prima volta che viene avviato. Per le modalità di installazione della licenza, selezionare comando da menu ?/Licenza.


1.4. Manuale e supporto

Assieme a NextFEM Designer viene fornito il presente manuale d’uso, che descrive i comandi principali e le procedure per iniziare a lavorare con il programma. In aggiunta, è disponibile anche il supporto online. E’ possibile chiedere aiuto o qualsiasi tipo di supporto attraverso il forum online (solo in lingua inglese), raggiungibile all’indirizzo www.nextfem.it/it/nextfem-designer-support-forum/.


1.5. Interfaccia utente

La finestra principale del programma è mostrata in figura seguente. È possibile mostrare il modello (estruso e non), i numeri di nodi e di elementi, i carichi applicati, gli assi globali e altre proprietà del modello aperto. All’angolo inferiore sinistro vengono mostrati il numero di nodi e di elementi correnti.

L’interfaccia utente di NextFEM Designer presenta una barra dei menu sopra il viewport, che contiene tutti i comandi implementati. In aggiunta, sono disponibili altre barre dei comandi, ancorabili ai quattro bordi del viewport.

Ciascuna barra dei comandi può essere visualizzata o rimossa agendo nel menu a tendina visualizzato al click destro del mouse, come in figura seguente.

Possono essere visualizzate le seguenti barre degli strumenti:

-    File

-    Modifica

-    Visualizza

-    Disegna

-    Assegna

-    Strumenti (da v2.0)

-    Plugins (da v2.0)

-    Risultati (da 2. 1)


2. Modellazione mediante NextFEM Designer

2.


2.1. Controlli utente


Uso del mouse

-    1 Il tasto 1 permette di selezionare oggetti attraverso:

o    Selezione singolo oggetto: click sul nodo o sull’elemento;

o    Finestra di selezione: selezione per trascinamento tenendo premuto il tasto. Trascinando il mouse da sinistra a destra, solo gli oggetti che ricadono completamente nella finestra saranno selezionati. Trascinando il mouse da destra verso sinistra, tutti gli oggetti che ricadono anche parzialmente all’interno della finestra saranno selezionati.

-    2 Tasto 2 (rotellina) ha una duplice funzione: tenendola premuta e trascinando, il modello si sposta; girandola si modifica lo zoom corrente.

-    3 Tenendo premuto il tasto 3 e muovendo il mouse, il modello ruota.


Scorciatoie da tastiera

Esc | pulisce la selezione corrente
Canc | cancella i nodi e gli elementi selezionati
Alt+A | salva screenshot
Alt+B | controlla la mesh di elementi lineari
Alt+C | assegna colori casuali alle sezioni e colora il modello
Alt+E | chiudi il programma
Alt+F4 | chiudi il programma
Alt+G | apre la finestra Gruppi
Alt+H | mostra maschera Selezione per nome / numero
Alt+I | inverti selezione
Alt+J | mostra maschera Seleziona per proprietà
Alt+M | mostra/nasconde barra dei menu
Alt+R | Lancia il modello
Alt+Shift+R | Seleziona analisi da lanciare e lancia
Alt+Shift+L | Mostra/nasconde assi locali
Alt+Shift+K | accetta modifiche al modello senza cancellare i risultati
Alt+Shift+M | Importa i modelli e i risultati da un programma Midas via API
Alt+Shift+S | divide la trave selezionata per i nodi selezionati
Alt+Shift+U | unisce travi e relativi risultati importati
Alt+S | screenshot del viewport
Alt+V | apre gestore viste
Alt+0 | imposta vista in 3D
Alt+1 | imposta vista nel piano XY
Alt+2 | imposta vista nel piano XZ
Alt+3 | imposta vista nel piano YZ
Ctrl+0 | Apre la maschera Verifiche intelligenti
Ctrl+1 | Verifiche per l’acciaio secondo NTC2018 e Eurocodice 3
Ctrl+2 | Verifiche per l’acciaio da ponteggi secondo UNI EN 12811-1
Ctrl+3 | Verifiche per l’alluminio secondo Eurocodice 9
Ctrl+4 | Verifiche per l’alluminio da ponteggi secondo UNI EN 12811-1
Ctrl+5 | Verifiche per il legno secondo NTC2018 e Eurocodice 5
Ctrl+6 | Verifiche per il calcestruzzo armato secondo NTC2018 e Eurocodice 2
Ctrl+7 | Verifiche per la muratura secondo NTC2018
Ctrl+A | seleziona l’intero modello
Ctrl+C | copia gli oggetti selezionati
Ctrl+D | deseleziona tutti i nodi
Ctrl+F2 | nasconde la selezione corrente
Ctrl+E | esporta
Ctrl+F | verifiche al fuoco
Ctrl+G | apre la maschera Verifiche
Ctrl+I | importa
Ctrl+K | mostra carichi
Ctrl+L | imposta limiti contour
Ctrl+N | nuovo modello
Ctrl+O | apre un modello
Ctrl+Q | apre la maschera Interroga
Ctrl+R | mostra risultati
Ctrl+S | salva il modello
Ctrl+Shift+S | salva il modello con nome
Ctrl+U | aggiorna il programma (compresi agg. Facoltativi)
Ctrl+V | incolla gli oggetti selezionati
Ctrl+W | integra section cut selezionata (solo in vista risultati)
Ctrl+X | taglia gli oggetti selezionati
Ctrl+Y | ripeti operazione sul modello
Ctrl+Z | annulla operazione sul modello
Ctrl+"+" | auto-dimensionamento armature
Shift+MouseR | apre menu contestuale
F1 | apre il manuale utente
F2 | mostra solo oggetti selezionati
F3 | apre i controlli vista
F4 | mostra l’intero modello
F5 | mostra/nasconde i nodi
F6 | attiva/disattiva vista estrusa
F7 | mostra i numeri dei nodi
F8 | mostra i numeri degli elementi
F9 | mostra le masse nodali
F10 | mostra i valori nei diagrammi delle travi
F11 | mostra i valori dei carichi visualizzati
F12 | mostra i vincoli interni al modello


Opzioni da riga di comando

Sono disponibili le seguenti operazioni da riga di comando:

-    (-i filename.ext) permette di importare il modello specificato in filename;

-    (-c nodes) verifica la presenza di nodi liberi nel modello caricato;

-    (-c elems) controlla la corretta connettività antioraria degli elementi nel modello caricato;

-    (-e filename.ext) permette di esportare il modello specificato in filename, secondo il formato specificato nella sua estensione ext.
I formati supportati sono:

o    “.s2K”: SAP2000® text file;

o    “.mgt”: Midas GEN® text file;

o    “.dxf”: DXF drawing file;

o    “.tcl”: OpenSees TCL script;

o    “.inp”: ABAQUS®/CalculiX input deck;

o    “.in”: OOFEM input deck;

o    “.dat”: ADAPTIC / Zeus NL input deck;

o    “.txt”: Straus7 versioni superiori a 2.2;

o    “.ifc” e “.ifcxml”: formato IFC4 per il BIM;

o    “.xml” da SeismoStruct e WinStrand.

-    (-d lc data item dir) estrai i risultati dal file caricato e salva quelli selezionati in formato CSV. I seguenti indicatori sono supportati:

o    lc: nome del caso di carico;

o    data: tipo di dato da estrarre: “react”, “disp” o “solls” per reazioni, spostamenti o sollecitazioni travi;

o    item: numero di nodo o elementi, oppure "all" per la somma di tutti i nodi/elementi selezionati. Opzionale, di default assume tutti;

o    dir: direzione 1 2 3 4 5 6 secondo le convenzioni globali (nodi) o locali (elementi). Opzionale.

-    (-r) lancia il modello caricato o importato;

-    (-s [filename.ext] ) salva il modello caricato o importato;

-    (-p) stampa il report in PDF;

-    (-x) chiude il programma dopo le operazioni impartite dai comandi precedenti. Il flag “-d” non necessita di questa opzione poiché esce in ogni caso dal programma.


2.2. Convenzioni per assi locali

Le seguenti convenzioni sono state adottate per gli elementi. Si ricordi che tutti gli output come forze/stress/deformazioni nei diagrammi delle aste o negli elementi shell seguono le convenzioni locali indicate.


Travi e aste

Il secondo asse (“y”) è sempre verticale e parallelo all’asse globale Z.


Sezioni di elementi monodimensionali


Elementi piani


Elementi solidi


Section cut


2.3. Menu File

Nuovo: Apre un modello vuoto

open32 Apri: Apre un modello esistente

save32 Salva: Salva il modello aperto

save32 Salva come: Salva il modello aperto nei formati *.nxf o *.xml.

-    *.nxf è un format binario proprietario;

-    *.xml è un file di testo piano in format XML.

Chiudi: Chiude il modello aperto

import32 Importa: Importa un modello da altri formati. I formati supportati per l’input sono specificati nel capitolo 3.

import32 Unisci: Importa un modello da altri formati unendolo con quello in uso.

import32 Importa risultati OpenSees: Importa risultati dai recorder di OpenSees

Nel riquadro Seleziona risultati per l’importazione è possibile importare i file generati dall’utilizzo delle funzioni in procedure007.tcl incluso nel programma. I file con i risultati (estensione .out) devono trovarsi nella stessa cartella del modello TCL già importato.

Dal riquadro Recorder generico è possibile importare un risultato generico specificandone il tipo. Se nel recorder utilizzato per il risultato è stato utilizzato il flag “-time”, selezionare la casella appropriata. Il recorder importato deve essere congruente con il modello TCL già importato.

import32 Importa dataset aggiuntivi: Importa set di dati aggiuntivi definiti dall’utente. Il comando è particolarmente adatto all’importazione di dati elaborati all’esterno del programma (es. recorder personalizzati di OpenSees). Dal menu a tendina è possibile importare:

-   Dati utente: il formato di questo dati è il seguente:
node (serie dei numeri dei nodi, separati da spazi, tabulazioni o punto e virgola)
tempo (serie dei valori associati ai nodi, nell’ordine della serie di numeri dei nodi in prima riga)

oppure

element (serie dei numeri degli elementi, separati da spazi, tabulazioni o punto e virgola)
tempo (serie dei valori associati agli elementi, nell’ordine della serie di numeri degli elementi in prima riga)

Questi dati saranno importati in un nuovo caso di carico denominato con il nome del file caricato, oppure con un nome temporaneo se i dati sono stati incollati nella casella di testo. Tutti i dati caricati possono essere salvati nel file NXF e sono visualizzati all’interno dei risultati, menu Dati Nodi o Dati Elementi.

-   Risultati Midas GEN: permette l’importazione delle tabelle dei risultati elaborate in Midas GEN® (comando Results/Result tables in GEN). Le tabelle possono essere incollate direttamente nella casella di testo della finestra. Le tabelle supportate sono: Beam Forces, Wall Forces, Node Displacements.

export32 Esporta: Esporta il modello nei diversi formati specificati all’inizio di questo capitolo.

Esci: Chiude il programma


2.4. Menu Modifica

material Materiale: Per definire le proprietà del materiale:

Immagine che contiene testo, schermata, schermo, software Descrizione generata automaticamente

-    Per aggiungere un nuovo materiale predefinito, selezionarlo da quelli disponibili nel riquadro di scelta in basso Libreria materiali. Selezionare un materiale e premere Scegli;

-    Per aggiungere un materiale personalizzato, cliccare su Aggiungi materiale… .

Inserire le seguenti informazioni:

    Nome del materiale

    (opzionale) norma di riferimento

    modulo di Young E

    coefficiente di Poisson n

    modulo di taglio G

    resistenza caratteristica fk (per comportamento lineare del materiale)

    coefficiente di dilatazione termica alphaT

    peso specifico Wd

    densità di massa Md (può essere calcolata automaticamente cliccando su Densità di massa da peso specifico)

Immagine che contiene testo, schermata, numero, Carattere Descrizione generata automaticamente

Cliccare su Assegna a elementi selezionati per assegnare il materiale scelto agli elementi selezionati.

Premere il bottone Annulla per uscire.

Selezionato il menù a tendina Strumenti è possibile operare una scelta tra i seguenti comandi:

-    Con il comando Modulo di taglio isotropo da E e n è possibile ottenere automaticamente il modulo di taglio G in tabella, calcolato dal programma attraverso la relazione:

-    Con il comando Densità di massa da peso specifico è possibile ottenere automaticamente la densità di massa in tabella, calcolato dividendo il peso specifico per l’accelerazione di gravità in unità di misura consistenti.

-    Con il comando Impostazioni analisi termica è possibile specificare le caratteristiche riguardanti le curve di analisi termica non lineare.

-    Con il comando Impostare rigidezza fessurata è possibile impostare il fattore di rigidezza da considerare per il materiale corrente.

Per aggiungere nuovi valori in tabella al fine delle verifiche sul materiale, è possibile utilizzare il comando Aggiungi dopo aver compilato le caselle Nuovo campo e Valore.

AVVISO: inserire sempre valori con le opportune unità di misura nella maschera “Aggiungi materiale” (vedi Modifica > Imposta unità).

sect Sezioni: aggiunge e modifica sezioni per elementi mono- e bi-dimensionali.

-    Per aggiungere una sezione per un elemento piano, specificare nome e spessore nella sezione Sezione piana e premere Aggiungi sezione piana;

-    Per aggiungere una sezione di una trave, selezionare il menu a tendina Sezione trave e scegliere tra i tipi disponibili. Seguire le richieste di valori per completare l’operazione.

Cliccare su Assegna agli elementi selezionati per assegnare la sezione scelta agli elementi selezionati.

Il flag “Come sezione finale” permette di specificare delle sezioni variabili negli elementi. Le sezioni iniziale e finale devono essere dello stesso tipo.

I tipi di sezione per travi disponibili sono:

Sono disponibili anche le sezioni a Omega e a C sagomate a freddo non sottili.

Altre librerie personalizzate possono essere presenti in questo elenco. In tal caso verrà visualizzata una lista come in figura seguente. Sono incluse nel programma numerose librerie per sezioni in acciaio.

Per visionare le proprietà geometriche della sezione selezionata, premere Modifica proprietà. La maschera permette anche l’importazione di sezioni da file DXF e definizione di sezioni per punti.

*    AVVISO: inserire sempre valori con le opportune unità di misura (vedi Modifica > Imposta unità).

Nelle maschere Aggiungi e Per punti è possibile editare le forme componenti la sezione (sia per vuoti che per pieni) o importare una sezione da DXF con il comando Importa DXF. I contorni di ogni figura devono essere delle polilinee, definite in senso orario per i pieni e in senso antiorario per i vuoti.

*    AVVISO: l’inserimento di figure in sezione non avviene in coordinate assolute, poiché viene ricalcolato il baricentro per ogni modifica.

Nella maschera Dati è possibile specificare le caratteristiche di progetto della sezione da utilizzare nelle verifiche. Le sezioni senza un tipo definito (es. sezioni per punti, Personalizzata), non viene assegnata automaticamente una classe alla sezione durante la verifica per il materiale acciaio o alluminio. Per questo, si richiede all’utente di specificare la classe della sezione mediante la tendina Aggiungi proprietà, che presenta le seguenti opzioni:

- Verifica acciaio aggiunge i seguenti dati per la verifica: SectClass (classe sezione), alphaLT (coeff. instabilità flesso-torsionale), alphay (coeff. instabilità attorno a y-y), alphaz (coeff. instabilità attorno a z-z), Jw (costante d’ingobbamento)

- Verifica alluminio aggiunge i seguenti dati per la verifica: SectClass (classe sezione), Jw (costante d’ingobbamento)

- Colonna composta aggiunge i seguenti dati per l’analisi: Ec_factor (fattore per il modulo elastico nel calcolo del coeff. di omogeneizzazione, di defaut a 0.5) e Reduction_factor (di default a 0.9, fattore di riduzione delle inerzie)

- Trave composta aggiunge i seguenti dati per l’analisi: Factor_Mpos (fattore per l’inerzia a momento positivo) e Factor_Mneg (fattore per l’inerzia a momento negativo)

- Sagomata a freddo aggiunge i seguenti dati per la verifica delle sezioni sottili, che in assenza di questi flag non viene svolta: CF_tw (spessore della sezione) e CF_rc (raggio di curvatura fra i tratti)

- Sezione a fibre aggiunge i seguenti dati per l’analisi in OpenSees: fibersX (numero di fibre in direzione z della sezione) e fibersY (numero di fibre in direzione y della sezione) per specificare la suddivisione in fibre per ogni direzione

- Salta verifica aggiunge il flag skip = 1 per saltare la verifica della sezione

- Da testo permette il caricamento di un insieme di flag definiti dall’utente, che sono riportati come variabili nelle verifiche. Il file deve contenere una variabile per riga nel formato nomeVar=valore. Si rivela particolarmente utile per la definizione di spessori diversi a tratti nelle sezioni sottili, ad esempio per un modello in mm e una sezione formata da 3 figure (che nel caso di una sezione sottile sono serie di segmenti):

CF_tw=2

CF_tw_1_6=3

CF_tw_1_8=2.5

CF_tw_1_9=2.5

CF_tw_1_10=2.2

CF_tw_1_11=2.2

CF_tw_1_12=2.2

CF_tw_1_13=2.2

CF_tw_1_14=2.2

CF_tw_1_15=2.5

CF_tw_2_1=8

CF_tw_2_2=2.5

CF_tw_2_3=2.5

CF_tw_2_4=2.5

CF_tw_2_5=2.5

CF_tw_3_1=3

CF_rc=2

CF_tw è lo spessore di default. Gli altri spessori sono definiti nella codifica CF_tw_indiceFigura_indiceTratto, in cui ogni indice è a base 1. Non è necessario specificare lo spessore dei tratti diversi dal default.

*    AVVISO: la modifica dei dati per una sezione comporta l’assegnazione obbligatoria al tipo Personalizzata.

Immagine che contiene testo, schermata, schermo, software Descrizione generata automaticamente Immagine che contiene testo, schermata, schermo, software Descrizione generata automaticamente

È possibile specificare manualmente le caratteristiche geometriche e inerziali della sezione considerata, oltre al settaggio della classe di sezione per sezioni personalizzate.

*    AVVISO: modificando le proprietà della sezione si definisce la sezione come “Personalizzata”. L’operazione non è reversibile.


Sezioni composte

Il supporto alle sezioni composte include:

-   travi con soletta come in figura (a) e

-   colonne con baricentri coincidenti (b).

La sezione viene riconosciuta automaticamente come composta quando:

- sono presenti due o più serie di figure piene, in cui almeno una sia associata ad un materiale acciaio e una ad un materiale calcestruzzo;

- sono state assegnate le proprietà di trave o colonna composta nella maschera “Dati” di Proprietà sezione.

AVVISO: La larghezza efficace Beff inserita per la porzione di calcestruzzo deve essere valutata dall’utente secondo le indicazione della normativa vigente.

Le rigidezze per elementi trave aventi sezione composta sono calcolate come segue. Con pedice s sono indicate le quantità riferite all’acciaio, con pedice c quelle relative alla porzione di calcestruzzo.

Per le travi, il momento d’inerzia per flessione positiva attorno all’asse neutro elastico na è:

Il momento d’inerzia della sezione per flessione negativa attorno all’asse neutro elastico è pari a quello del solo acciaio, considerando la porzione di calcestruzzo come fessurata.

Nel complesso la rigidezza flessionale complessiva viene calcolata secondo EC4 ed in funzione dei fattori Mpos e Mneg presenti nella maschera di input “Dati” nelle proprietà della sezione (figura a).

(a) [image] (b)

La rigidezza flessionale complessiva è quindi pari a:

Le restanti proprietà per la sezione di trave sono calcolate dividendo il contributo del cls per n.

Per le colonne composte, una volta specificati i fattori Ec e di riduzione R nella maschera “Dati” (figura b), le caratteristiche della sezione sono calcolate come segue:

Le restanti proprietà sono calcolate dividendo il contributo del cls per n.


Calcolo resistenza

Dal pulsante Calcolo resistenza è possibile definire le armature di una sezione in cemento armato e ottenere il calcolo resistente a tenso/pressoflessione elastico o agli stati limite.

In Definisci proprietà del materiale viene specificato il materiale associato alla sezione.

Nel riquadro Proprietà barre possono essere specificate le coordinate di ogni barra di armatura (eventualmente rettangolare spuntando l’opzione Barra rett. e specificando la base del piatto in Base barra rett.). L’immissione delle barre avviene per coordinate in base agli assi locali della sezione, specificando il diametro e il materiale (che può essere scelto cliccando sul pulsante “…”). I materiali disponibili possono essere personalizzati modificando o aggiungendo i file testuali con estensione *.nfm nella sottocartella data\design\ nella directory di installazione del programma.

Per inserire cavi e trefoli per il calcolo di sezioni in c.a. precompresso, è possibile inserire la tensione iniziale del cavo attivando l’opzione Cavo e introducendo la tensione in unità di misura consistenti con il modello.

Per ottenere i valori resistenti della sezione, specificare le sollecitazioni di progetto nel riquadro Sollecitazioni nelle unità di misura richieste. Spuntando l’opzione Elastico viene svolto un calcolo con materiali elastici, spuntato l’opzione Plastico viene svolto un calcolo agli stati limite in cui ogni materiale ha un legame elastico-perfettamente plastico. Nel box Risultati sono riportati i risultati del calcolo, accompagnati dai grafici soprastanti.

La maschera permette anche il calcolo di domini resistenti ridotti dall’azione termica. Attraverso l’impostazione delle leggi di riduzione di resistenza per le caratteristiche meccaniche e di resistenza del materiale base e di eventuali barre, il programma calcolerà la sezione all’istante di tempo e per il caso termico selezionati.

Le opzioni disponibili in questa maschera sono:

-   Legge non lineare cls permette di scegliere fra la legge parabola-rettangolo e quella bilineare per il comportamento del materiale calcestruzzo. Se viene utilizzata una sezione rettangolare semplice o circolare, viene visualizzata anche l’opzione Cls confinato in questo menu, che permette di considerare come calcestruzzo confinato la parte di sezione interna alle staffe. In questo caso, sono richiesti i dati nella tab Staffe. Le spirali non sono supportate.

-   Cls reagente a trazione attiva il contributo a trazione del calcestruzzo;

-   Rapporto di hardening permette di specificare il rapporto fra la pendenza del ramo plastico delle barre di armature e il loro modulo elastico. Nel caso di materiale base Acciaio o Alluminio, specifica il rapporto di hardening del materiale base.

-   Classe della sezione specifica la classe della sezione nel caso di materiale base Acciaio o Alluminio, cioè se la sezione può essere calcolata in campo plastico o meno.

-   Fattore n permette di modificare il fattore di omogeneizzazione (rapporto fra i moduli dell’acciaio e del calcestruzzo). Il valore di default è 15.

La maschera Staffe permette l’associazione delle caratteristiche di staffatura alla sezione, permettendo così il calcolo della resistenza a taglio.

La maschera Elementi trave permette di acquisire le barre da una sezione di trave, oltre che le sollecitazioni nei risultati, se presenti, per la stessa sezione.

Esporta risultati contiene le opzioni del programma per:

· plottare la tensione nelle barre di armatura,

· per eseguire il calcolo con una sezione a fibre triangolari

· per modificare l’accuratezza del calcolo (valore consigliato 15, da innalzare in caso di parti molto sottili)

· cancella la cache di calcolo, utile quando vengono modificati materiali di rinforzi o barre per evitare che il programma torni gli stessi risultati precedenti alla modifica di questi materiali di progetto

· esportare le immagini della sezione analizzata o i punti del dominio resistente

· esportare la sezione in DXF con l’armatura

· visualizzare il dominio in 3D.

Immagine che contiene testo, schermata, Carattere, schermo Descrizione generata automaticamente

Elementi trave permette l’importazione delle armature dai singoli elementi, sovrascrivendo temporaneamente quelle della sezione. Il pulsante Sollecitazioni permette di ricavare dal modello calcolato le sollecitazioni per l’ascissa desiderata.

Immagine che contiene testo, schermata, schermo, Carattere Descrizione generata automaticamente

LC Casi di carico: Inserisce i casi di carico statici lineari scrivendo il nome nella casella Nome e cliccando su Aggiungi.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

AVVISO: solo i casi statici lineari possono essere immessi da questa maschera.

Dalla tendina Tipo è possibile specificare il tipo di caso di carico di base. Questa impostazione assume importanza nella generazione automatica delle combinazioni di carico, per la quale si rimanda all’apposita descrizione del comando.

Il pulsante Aggiungi casi di carico comuni aggiunge automaticamente i casi di carico più utilizzati (peso proprio, permanenti, variabili, ecc.).

sisma Funzioni: Aggiunge funzioni di carico time-history (TH) o spettri di progetto, per punti o da file.

Immagine che contiene schermata, testo, software, Software multimediale Descrizione generata automaticamente

Dal menu a tendina del riquadro Strumenti è possibile ottenere varie funzioni TH, quali:

    Spettro Eurocodice 8: fornisce lo spettro di progetto in accelerazione secondo Eurocodice 8 – UNI ENV 1998-1-1

    Spettro NTC2008: fornisce lo spettro di progetto in accelerazione secondo le Norme Tecniche per le Costruzioni (norma italiana D.M. 14-01-2008). Il programma di avvale di una georeferenziazione automatica e permette di cercare tramite indirizzi postali il sito per lo spettro di progetto.

Immagine che contiene testo, mappa, schermata, numero Descrizione generata automaticamente

    Vento NTC2008: determina l’azione del vento in funzione della quota secondo le Norme Tecniche per le Costruzioni (norma italiana D.M. 14-01-2008)

    Neve NTC2008: determina l’azione della neve in funzione della quota del sito secondo le Norme Tecniche per le Costruzioni (norma italiana D.M. 14-01-2008)

    TH lineare: rampa di carico lineare

    TH sinusoidale: fornisce una funzione sinusoidale di caratteristiche scelte dall’utente

    Spettro calcolato: l’opzione è abilitata solo quando l’utente ha richiesto uno spettro di un accelerogramma tramite il comando Mostra spettro, che calcola lo spettro di un accelerogramma visualizzato

    Da file: permette il caricamento di file di testo a 2 colonne contenenti una serie di dati

    Carico costante: plateau di carico a moltiplicatore definito

    Forze sismiche EC8: definisce un set di forze statiche di piano equivalenti al sisma secondo Eurocodice 8/NTC2008 per analisi statica semplificata

    EC1 Wind Load: carico da vento secondo Eurocodice 1

    EC1 Snow Load: carico da neve secondo Eurocodice 1

    Curva incendio NTC: curva di incendio secondo NTC2008. Viene fornito il tempo in secondi nella serie ottenuta

    Curva incendio esterna NTC: curva di incendio esterna NTC2008. Viene fornito il tempo in secondi nella serie ottenuta

    Curva incendio idrocarburi NTC: curva di incendio per idrocarburi secondo NTC2008. Viene fornito il tempo in secondi nella serie ottenuta.

draw48 Imposta unità: Da qui possono venire selezionate le unità di misura desiderate nel modello. Le unità di default sono sempre m, kN e °C.

-    Lunghezze:

o    Metri [m] (default);

o    Centimetri [cm];

o    Millimetri [mm];

o    Chilometri [km];

o    Pollici [in];

o    Piedi [ft]

-    Forze:

o    Newton [N];

o    DecaNewton [daN];

o    ChiloNewton [kN] (default);

o    Chilolibbre-forza [kipf]

-    Temperature:

o    gradi Celsius [°C] (default).

Le seguenti unità di misura vengono calcolate dal programma in modo consistente:

-    Massa:

o    Megagrammi [Mg];

o    Chilogrammi [kg] (default);

o    Grammi [g];

o    Tonnellate [t];

o    Once [oz];

o    Libbre [lb].

-    Tensione:

o    MegaPascal [MPa];

o    KiloPascal [kPa];

o    Pascal [Pa] (default).

check32 Controlla connettività: Verifica la connettività antioraria degli elementi con più di 2 nodi.

check32 Controlla sovrapposizione elem: Controlla se sono presenti elementi sovrapposti ad altri.

check32 Controlla nodi liberi: Controlla se ogni nodo è connesso ad un elemento.

check32 Controlla proprietà elementi: Controlla se ogni elemento possiede un materiale e una sezione.

numbering Rinumerazione: Rinumera nodi e/o elementi secondo i criteri specificati.

check32 Controlla mesh linee: Controlla in tutte le travi (o aste) nel modello se ci sono travi (o aste) sconnesse fra loro. Il comando corregge la mesh dividendo le linee che presentano intersezioni solo apparenti (es. nodo appartenente ad altro elemento che sta sulla congiungente i nodi della trave considerata).

mergeNodes Strumenti per nodi

mergeNodes Unisci nodi sovrapposti: Unisce i nodi sovrapposti nell’intero modello.

AVVISO: il comando controlla anche la presenza di elementi sovrapposti e di nodi coincidenti, al fine di rimuovere eventuali doppioni risultanti dalla meshatura ulteriore degli elementi Trave.

move nodes Sposta nodi: Selezionando Spostamento relativo, Sposta i nodi selezionati della quantità specificata. Selezionando Spostamento assoluto, sposta i nodi nelle direzioni selezionate alle coordinate specificate.

Immagine che contiene testo, schermata, Carattere, numero Descrizione generata automaticamente

rotation Ruota nodi: Ruota i nodi selezionati rispetto ad un asse specificato.

Per definire un asse personalizzato, selezionare 2 nodi nel modello.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

scaleNodes Scala nodi: Scala i nodi selezionati (e opzionalmente gli elementi) rispetto ad un punto nello spazio 3D.

Immagine che contiene testo, schermata, schermo, Carattere Descrizione generata automaticamente

mirror Specchia nodi: Specchia i nodi selezionati (e opzionalmente gli elementi) rispetto ad un piano nello spazio 3D definito da 3 punti.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

quad16 Strumenti mesh

tria16 Mesh area: Per meshare automaticamente un’area in elementi triangolari, selezionare dalla maschera la massima area dell’elemento Tria da generare, i nodi di perimetro per le zone da meshare e i nodi di perimetro di eventuali buchi all’interno della mesh. Dopo aver selezionato i nodi, premere Acquisisci selezione per associare i nodi al gruppo Pieni. Per inserire un buco nella mesh, operare allo stesso modo per associare i nodi al gruppo Vuoti. Per procedere premere OK.

Immagine che contiene testo, schermata, Carattere, numero Descrizione generata automaticamente

Opzioni:

- “Usa elementi quad dove possibile” accorpa a coppie i triangoli generati dove possibile in elementi quad

- Quando l’opzione “Considera nodi interni” è selezionata, solo i gruppi di nodi che formano poligoni pieni vengono considerati, anche concavi

- L’opzione “Fascia esterna” permette di meshare solo superfici dal bordo convesso, estendendole verso l’esterno per la misura desiderata.

- L’opzione “No nuovi nodi di bordo” permette la creazione di una mesh senza l’aggiunta di nodi sul bordo della stessa (es. piano flessibile).

Strumenti mesh:

- Il pulsante “Agg. nodi interni” permette di associare i nodi selezionati alla figura piena selezionata, forzando i nodi di passaggio per la mesh (es. la base delle colonne in una platea).

- Il pulsante “Segui le travi di confine” permette di realizzare una mesh utilizzando un contorno concavo o convesso creato dalle travi selezionate.

- “Disegna bordo piano” permette di disegnare a schermo il contorno da considerare.

quad16 Aggiungi parete: Il comando permette di inserire e meshare pareti di dimensione e posizione arbitraria, composti da elementi piani Quad.

Per inserire una parete, immettere le coordinate di origine (lo 0 è assunto in basso a sinistra) nel riquadro Origine e specificare le sue dimensioni in Lunghezza e Larghezza.

Abilitando l’opzione Taglio / pendenza è possibile inserire una parete in pendenza specificando il tipo di geometria (Tipo parete) e l’angolo di inclinazione (Angolo [°]). Le seguenti geometrie sono disponibili in Tipo parete:

    x per angoli misurati lungo l’asse X globale;

    y per angoli misurati lungo l’asse Y globale;

    vertical per pareti verticali con bordo superiore in pendenza.

Le opzioni x e y possono essere utilizzando quando il Piano di giacitura è XY.

Tramite i Controlli disegno è possibile spostarsi nel piano di giacitura per disegnare pareti consecutive.

Abilitando l’opzione Aperture, è possibile aggiungere un’apertura di origine e dimensione personalizzata nella parete.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

quad16 Auto-mesh parete: Il comando permette di meshare automaticamente tutti gli elementi quad di un modello, usando come dimensione della mesh il valore specificato in Opzioni in Dimensione mesh IfcWall.

Mesh travi a sezione variabile: Il comando permette di meshare automaticamente tutti gli elementi line di un modello aventi sezione variabile, ovvero sezione iniziale e finale diversa.

Espandi macroelementi: Il comando permette di meshare automaticamente tutti i macroelementi di un modello, espandendoli come specificato dai sottomodelli nella cartella macro.

Aggiungi cinturazione: Il comando permette di meshare una cinturazione sia concava che convessa a partire ad esempio da una platea già esistente.

solid16 Mesh volume: Questo comando permette di meshare elementi solidi in elementi tetraedrici. L’opzione Dimensione max specifica la massima lunghezza caratteristica da attribuire a ciascuno; Dimensione min la dimensione minima e Gradiente mesh la variazione massima percentuale fra un elemento e un altro. Premere OK per procedere con gli elementi selezionati.
Seleziona STL se il volume è delimitato da facce triangolari; selezionare CSG se il volume è delimitato da altri elementi solidi.

Immagine che contiene testo, schermata, numero, Carattere Descrizione generata automaticamente

divide Dividi e unisci: Questo comando permette di dividere in parti gli elementi line a 2 nodi e quad a 4 nodi selezionati. Inoltre, è possibile unire in un solo elemento gli oggetti line selezionati, aventi lo stesso primo asse locale.
È possibile dividere anche elementi Hexa secondo le 3 direzioni locali dell’elemento.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

Da parete a telaio: Questo comando permette di generare un telaio equivalente a partire da pareti modellate a shell. Il comando è particolarmente utile per convertire elementi Wall importati da Midas GEN® oppure per applicare cerniere plastiche a pareti una volta convertite in travi o pilastri. L’asse y del Quad diventa l’asse x della beam.

Estrudi sezione: Questo comando permette di estrudere gli elementi trave selezionati a seconda della loro sezione in elementi shell o solidi. Il comando è utile per trasformare un modello a telaio in un modello a shell o solidi per analisi di dettaglio, come ad esempio l’instabilità locale.

changeType Cambia tipo elemento: Il comando permette di cambiare il tipo degli elementi selezionati. Selezionare dal menu a tendina una trasformazione e premere OK.

Immagine che contiene testo, schermata, Carattere, linea Descrizione generata automaticamente

Le trasformazioni possibili sono:

-    Asta->Trave: da asta a trave

-    Trave ->Asta: da trave ad asta

-    Trave -> Trave3: da trave a trave a 3 nodi

-    Trave3-> Trave: da trave a 3 nodi a trave

-    Spring-> Trave: da molla a trave a 2 nodi

-    Trave -> Spring: da trave a 2 nodi a molla

-    Quad->Tria: da quad a tria

-    Quad->Quad8: da quad a quad8

-    (planar)->PlaneStress: da elemento piano a plane stress

-    (planar)->Shell: da elemento piano a shell

-    (planar)->PlaneStrain: da elemento piano a plane strain

-    Tetra->Tetra10: da Tetra a Tetra a 10 nodi

-    Hexa->Hexa20: da Esaedro a Esaedro a 20 nodi

-    Elemento->Giunto: contrassegna un elemento come giunto

-    Rimuovi->Giunto: elimina il contrassegno di giunto agli elementi selezionati.

*    AVVISO: gli elementi PlaneStress e PlaneStrain possono essere utilizzati solo nel piano XY.

estrudiElem Estrudi elementi: Questo comando permette di estrudere elementi da nodi, tria o quad selezionati. In tutti i casi, l’utente deve specificare la Direzione di estrusione e la Lunghezza di estrusione.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

Se è selezionata l’opzione da Nodo a trave, i nodi selezionati verranno estrusi in elementi trave. Non dimenticare di assegnare un materiale e una sezione alle travi selezionate.

Se è selezionata l’opzione da Tria a wedge, i tria selezionati verranno estrusi in elementi prisma (wedge). Selezionando l’opzione Cancella elementi originali, i tria iniziali saranno cancellati dopo l’estrusione. Ai nuovi elementi wedge sarà assegnato il materiale degli elementi tria originali.

Se è selezionata l’opzione da Quad a hexa, i quad selezionati verranno estrusi in elementi cubo (hexa). Selezionando l’opzione Cancella elementi originali, i quad iniziali saranno cancellati dopo l’estrusione. Ai nuovi elementi hexa sarà assegnato il materiale degli elementi quad originali.

cut Taglia: Taglia gli elementi selezionati (CTRL+X).

copy Copia: Copia gli elementi selezionati (CTRL+C).

paste Incolla: Incolla gli elementi selezionati e mostra la maschera seguente in cui specificare l’eventuale shift nello spazio rispetto agli originali (CTRL+V).

Immagine che contiene testo, schermata, numero, Carattere Descrizione generata automaticamente

iconmonstr-undo-4-32 Annulla: Annulla l’ultima operazione.

Ripeti: Ripete l’ultima operazione.


Genera combinazioni

LCB Genera combinazioni

Il comando permette di settare i coefficienti parziali di sicurezza e di combinazione lato carichi ai fini della generazione automatica delle combinazioni di carico da parte del programma secondo Eurocodice/NTC2018.

Se la norma lo richiede (es. NTC1028) è possibile specificare un fattore di sicurezza differenziato per il peso proprio.

Immagine che contiene testo, schermata, numero, Carattere Descrizione generata automaticamente

È possibile generare combinazioni fondamentali (resistenza SLU / ULS), di servizio (SLE/SLS) o sismiche, comprese la combinazione direzione di 2 o 3 casi sismici specificati nel riquadro Combinazioni direzionali sismiche. È possibile scegliere il prefisso nel nome della combinazione, funzionalità particolarmente utile nella scrittura di combinazioni sismiche riferite a spettri diversi (es. SLV / LLS e SLD / DLS).

L’opzione Considera eccentricità del 5% permette di assegnare i momenti torcenti equivalenti alle forze di piano nei casi dedicati denominati *ecc5x e *ecc5y, generati e combinati automaticamente. Per un’analisi con spettro di risposta nelle direzioni X e Y e con le eccentricità attive, vengono quindi generate 32 combinazioni in luogo delle 8 senza l’opzione.

Le combinazioni calcolate possono essere editate dalla maschera Impostazioni analisi.

LC Impostazioni analisi:

Questa maschera definisce il tipo e la sequenza delle analisi. NextFEM Designer supporta la definizione di :

-    Analisi lineari (statiche, dinamiche, con spettro di risposta, di buckling, modali, termiche)

-    Analisi non lineari (statiche e dinamiche).

Per aggiungere un ‘analisi, selezionare Modalità di analisi, Tipo di analisi e Tipo di combinazione e premere su Aggiungi.

La tabella principale in questa maschera mostra tutti i casi di carico e le combinazioni di carico. E’ possibile definire le combinazioni di carico composte sommando o inviluppando i casi di carico statici lineari.

Il programma permette l’esecuzione dei seguenti tipi di analisi lineari e non lineari:

-    Statica

-    Dinamica

-    Dinamica con spettro di risposta (opzione Spettro di risposta deve essere attivato, poi selezionare uno spettro di progetto precedentemente creato in Modifica/Funzioni dal riquadro Carichi TH o spettro)

-    Modale, per l’estrazione di periodi strutturali e autovettori da un modello

-    Buckling, per estrazione dei modi di buckling (instabilità) da un modello

-    Termica, per l’analisi di modelli nel piano XY dai quali è possibile leggere una mappa termica (ad esempio di una sezione)

-    P-Delta, per l’analisi statica che include gli effetti geometrici del secondo ordine. Questo tipo di analisi viene svolto iterativamente ma in un solo step di carico, e i risultati possono essere inclusi in combinazioni. Per includere gli effetti geometrici non lineari nelle analisi con più step, utilizzare l’opzione “2° ordine”.

Nel riquadro Tipo di combinazione è possibile specificare il tipo del caso di carico:

-    Base per i casi statici lineari di base

-    Somma per le combinazioni che prevedano la somma dei singoli casi di base specificati nel riquadro Casi di carico lineari

-    Inviluppo per le combinazioni che prevedano l’inviluppo di singoli casi di base specificati nel riquadro Casi di carico lineari o di altre combinazioni

-    SRSS per le combinazioni che prevedano la radice quadrata della somma dei quadrati delle risposte dei singoli casi di base specificati nel riquadro Casi di carico lineari o di altre combinazioni.

Nel menu a tendina Tipo per verifiche è necessario specificare il tipo di verifica alla quale è soggetta la combinazione o il caso di carico selezionato in tabella. In caso contrario, le verifiche strutturali richieste potrebbero non essere svolte per il caso di carico o combinazione selezionata.

Dal pulsante Esporta combo in file CSV è possibile ottenere un file CSV contenente le combinazioni immesse e i relativi coefficienti di combinazione adottati.

Lo smorzamento nelle analisi dinamiche può essere introdotto mediante i coefficienti di Rayleigh. Per le analisi con spettro di risposta è richiesto il rapporto di smorzamento dello spettro utilizzato.

Infine, per applicare una storia di spostamento (per gli spostamenti imposti) in analisi non lineari, settare Fattore a 0.


2.5. Menu Visualizza

select32 Seleziona tutto: Seleziona tutti i nodi e gli elementi del modello.

Inverti selezione: Seleziona i nodi/elementi non selezionati e deseleziona i selezionati.

unselect32 Pulisci selezione: Deseleziona tutto.

close32 Elimina selezionati: Elimina gli elementi selezionati.

gruppi Selezione per gruppi: Questo comando permette di definire un gruppo e di assegnargli nodi e/o elementi. Permette anche di selezionare gruppi di nodi o elementi definiti in precedenza.

Per definire un gruppo, scrive il nome desiderato e premere Aggiungi. Il nome del gruppo comparirà nel pannello Gruppi attivi. Per assegnare nodi ed elementi al gruppo, selezionare gli oggetti e premere Aggiungi nodi (elementi) selezionati.

Per selezionare nodi o elementi precedentemente assegnati a gruppi esistenti, selezionare il gruppo dal pannello Gruppi attivi e premere Seleziona nodi (elementi).

Per creare un gruppo di elementi piani che possa ospitare armatura, utilizzare il riquadro Progettazione pareti. Seleziona gli elementi piani e premere Crea parete per verifica. Automaticamente verranno create 3 section cut orizzontali (estremità e mezzeria) ai fini della verifica per integrazione delle tensioni. Per avere le section cut verticali (es. fasce di piano), selezionare Ruota section cut. Per la verifica delle platee ed evitare la generazione delle section cut, attivare Tratta come piastra. L’opzione Non complanare permette di trascurare eventuali disallineamenti fra gli elementi area della parete nella creazione del gruppo.

Seleziona per nome: Questo comando permette di selezionare nodi e/o elementi filtrati per nome (ID). I nomi devono essere inseriti separati da uno spazio.

Immagine che contiene testo, schermata, Carattere, numero Descrizione generata automaticamente

prop Seleziona per proprietà: Questo comando permette di selezionare nodi e/o elementi per proprietà o tipo.

-    Per selezionare tutti gli elementi con la stessa sezione trasversale, scegliere una sezione da Elementi per sezione e premere Seleziona. Premere Desel. to deselezionarli, Nascondi per toglierli dalla vista corrente e Mostra per aggiungerli alla vista.

-    Per selezionare tutti gli elementi con lo stesso materiale, scegliere un materiale da Elementi per materiale e premere Seleziona.

-    Per selezionare tutti gli elementi dello stesso tipo, scegliere un tipo da Elementi per tipo e premere Seleziona.

Mostra tutto: Mostra tutti gli elementi nel modello.

Mostra solo selezione: Mostra solo gli elementi selezionati.

Nascondi selezione: Nasconde gli elementi selezionati

box-rotate16 Ruota ingombro: Ruota il modello evitando la rigenerazione grafica di ogni elemento. Da utilizzare in PC datati.

Sposta: Sposta il modello.

select32 Zoom rettangolo: esegue lo zoom per il rettangolo selezionato.

Viste: Cambia la vista del modello. Scegliere fra:

estrudi 3D: Mostra l’intero modello in vista assonometrica;

piano1 XY: Mostra il modello nel piano XY;

piano2 XZ: Mostra il modello nel piano XZ;

piano3 YZ: Mostra il modello nel piano YZ;

viewNodes16 Mostra nodi: Attiva/disattiva la visibilità dei nodi nel modello

extrude16 Estrudi: Attiva/disattiva la vista estrusa del modello

arrow-16-DOWN Mostra carichi: Mostra i carichi applicati alla struttura in base al loro tipo. Per mostrare un tipo di carichi presenti, selezionare dal menu a tendina un tipo fra puntuale, trave, area o volume.

Nella barra di stato selezionare il caso di carico desiderato.

Controlli vista: Mediante questo comando è possibile controllare alcune opzioni legate alla vista del modello.

-    Apri partizioni: abilita il supporto per l’importazione di modelli partizionati in formato ADAPTIC. Il supporto a questo comando è sperimentale e permette l’importazione di modelli suddivisi in parti per calcolo parallelo;

-    Mostra settaggi visualizza le impostazioni grafiche del viewport (punto di vista, ecc.);

-    Numero dei nodi visualizza il numero per ogni nodo nel modello;

-    Masse nodali attiva la visualizzazione delle masse nodali con un simbolo grafico;

-    Numero degli elementi visualizza il numero di ogni elemento nel modello;

-    Valori nei diagrammi visualizza i valori sui diagrammi di sollecitazione delle travi e nelle altre viste risultati;

-    Valori per i carichi visualizza i valori dei carichi applicati;

-    Vincoli interni mostra i link o i piani rigidi del modello;

-    Dati vincoli mostra una stringa a descrizione dei vincoli immessi (0 dof libero, 1 dof vincolato)

-    Mostra in formato decimale permette la visualizzazione di carichi e risultati nel viewport nel formato decimale specificato (es. “0.000”)

-    Mostra indeformata sovrappone l’indeformata a fil di ferro alla vista corrente;

-    Mostra DXF importato permette la sovrapposizione di un file DXF precedentemente importato per ricalcare il modello.

Nel riquadro Valori nei diagrammi è possibile specificare quali valori vengano riportati nel viewport se la vista valori è attiva. È possibile attivare o disattivare le 5 stazioni di output di ogni elemento trave.

recent Dati nel modello: Questo comando apre la visualizzazione tabellare di Nodi, Elementi e Carichi nel modello.

Da questa maschera è inoltre possibile modificare l’assegnazione di carichi e di vincoli modificando la tabella visualizzata e premendo infine su Salva modifiche.

modelTree Vista ad albero: Mostra le principali caratteristiche del modello corrente (materiali, sezioni e carichi applicati).


2.6. Menu Disegna

node Nodo: Inserire nodi nel modello previa selezione del piano di lavoro.

node Nodo da coordinate: Inserisce nodi per coordinate. Per inserire un nodo per coordinate, inserire i valori nella maschera seguente e cliccare su Aggiungi. È possibile inserire nodi fino a che non viene premuto il pulsante Chiudi.

Immagine che contiene testo, schermata, Carattere, numero Descrizione generata automaticamente

Asta: Inserisce un elemento asta fra 2 nodi. L’elemento reagisce solo a trazione/compressione.

Trave: Inserisce un elemento trave fra 2 nodi. Per inserire un elemento trave, scegliere una sezione e un materiale dalla maschera Selezione proprietà. Selezionare nel viewport i nodi da collegare e premere Applica nella finestra Seleziona nodi. Per specificare manualmente l’ordine dei nodi selezionati, togliere la spunta da Crea l’elemento automaticamente e utilizzare i comandi a lato della lista nodi per editarla. Infine premere applica per creare l’elemento.

Trave3: Inserisce un elemento trave a 3 nodi. I nodi devono essere allineati.

tria16 Triangolo: Crea un elemento triangolare piano a 3 nodi.

tria16 Triangolo6: Crea un elemento triangolare piano a 6 nodi.

*    AVVISO: gli elementi Triangolo 6 sono scomposti in elementi a 3 nodi durante il calcolo con i l solutore di default.

quad16 Quad: Crea un elemento quadrangolare piano a 4 nodi.

quad16 Quad8: Crea un elemento quadrangolare piano a 8 nodi.

*    AVVISO: gli elementi Quad8 sono scomposti in elementi a 4 nodi durante il calcolo con i l solutore di default.

tetra16 Tetra: Crea un tetraedro a 4 nodi.

tetra16 Tetra10: Crea un tetraedro di secondo ordine a 8 nodi.

wedge16 Wedge: Crea un prima a 6 nodi.

wedge16 Wedge15: Crea un prima a 15 nodi.

solid16 Cubo: Crea un esaedro a 8 nodi.

solid16 Cubo16: Crea un esaedro a 16 nodi.

solid16 Cubo20: Crea un esaedro a 20 nodi.

spring16 Molla: Crea un elemento molla a 2 nodi.

*    AVVISO: Pe creare un elemento molla devono essere specificate e assegnate le proprietà dal comando Assegna/Proprietà molla.

Gestore griglie: Gestisce tutte le griglie a supporto della creazione di nodi. Per ogni intersezione di griglia, è disponibile uno snap.

Immagine che contiene Rettangolo, schermata, Policromia, Blu elettrico Descrizione generata automaticamente Controllo viste: Crea e gestisce le viste salvate.

Immagine che contiene testo, schermata, smartphone Descrizione generata automaticamente


2.7. Menu Assegna

2.7. constraint Menu Assegna

arrow-16-DOWN Carichi

autoLoad Carichi automatici: Assegna automaticamente alcuni tipi di carichi (peso proprio, vento, ecc.) per tutti gli elementi del modello

Con Assegna pesi propri vengono inseriti i carichi distribuiti di peso proprio SOLO per gli elementi che hanno già assegnati materiale e sezione.

Il comando Assegna nel riquadro Carichi da vento assegna automaticamente i carichi da vento per gli elementi trave nella direzione scelta. Il carico viene calcolato a partire da una funzione definita e applicato per ogni direzione per la superficie laterale dell’elemento maggiore fra i lati della sezione considerata.

Immagine che contiene testo, schermata, numero, Carattere Descrizione generata automaticamente

concentrato Carico puntuale: Applica un carico concentrato ai nodi selezionati. Per inserire un carico concentrato:

-    Selezionare uno o più nodi;

-    Inserire il valore in Valore di carico;

-    Selezionare la direzione globale desiderata nel pannello Direzione;

-    selezionare il caso di carico;

-    premere Applica per applicare il carico.

Per utilizzare una funzione predefinita per assegnare i carichi, selezionare una funzione dal menu Scegli funzione e specificare un valore dal quale leggere la funzione nel riquadro per X. È possibile anche specificare un moltiplicatore per il valore ottenuto.

Infine, l’opzione Temperatura permette di assegnare una temperatura nodale all’interno di un’analisi Termica.

Immagine che contiene testo, schermata, numero, Carattere Descrizione generata automaticamente

distrib Carico distribuito: Inserisce un carico distribuito per unità di linea:

-    Inserire il valore desiderato in Carico uniforme specificando il segno corretto secondo le coordinate globali del modello;

-    Selezionare la Direzione del carico;

-    Selezionare il Caso di carico appropriato;

-    Selezionare Applica per applicare i carichi agli elementi monodimensionali selezionati.

Per utilizzare una funzione predefinita per assegnare i carichi, selezionare una funzione dal menu Scegli funzione e specificare un valore dal quale leggere la funzione nel riquadro per X. È possibile anche specificare un moltiplicatore per il valore ottenuto.

Per rimuovere un carico distribuito da uno o più elementi per il caso di carico selezionato, selezionare gli elementi e premere il pulsante Rimuovi.

Attraverso il pannello Carico non uniforme è possibile inserire carichi distribuiti multi-lineari per punti, specificando la distanza appropriata fra i valori immessi in unità di misura del modello. Una volta immessa la Posizione e il valore del carico nella casella in alto alla maschera, premere il pulsante +.

*    AVVISO: Le unità di misura utilizzate devono essere consistenti con le scelte iniziali [Forza/Lunghezza].

*    AVVISO: A partire dalla versione 1.3 sono supportati i carichi non uniformi anche nel solutore di default. Sono supportati infiniti carichi lineari a tratti sulla stessa trave.

*    AVVISO: Eventuali Tratti rigidi presenti su travi aventi carichi non uniformi devono trovarsi prima e/o dopo l’inizio e la fine del carico, rispettivamente, altrimenti non saranno applicati.

*    AVVISO: gli elementi Trave3, per ragioni di compatibilità con altri solutori opzionali, non supportano carichi non uniformi. Possono essere usati elementi Trave senza perdere accuratezza.

temperature Temperatura: Assegna un carico termico strutturale, che provoca una dilatazione termica negli elementi caricati. Gli elementi trave supportano il gradiente uniforme e quello lineare, nelle due direzioni x e y della sezione trasversale. Gli elementi piani supportano solo il gradiente uniforme. Infine, non è possibile applicare il carico termico a elementi solidi.

edge Carico su lato: Assegna un carico uniforme su un lato di un elemento piano. Può essere utilizzato sia per assegnare forze per unità di lunghezza (opzione Forza in Tipo di carico), sia per assegnare una temperatura sul bordo (opzione Temperatura). Questa ultima opzione funziona solamente con casi di carico termici. Dopo aver selezionato gli elementi, dal riquadro Seleziona lati è possibile vedere i lati specificati evidenziati.

Il pulsante Applica su percorso nodi selezionati permette l’applicazione del carico su una linea congiungente i nodi selezionati dall’utente, utilizzando automaticamente il lato corretto.

È possibile assegnare anche un valore finale diverso al carico sul lato tramite l’opzione Carico non uniforme.

floor Carico di piano: Assegna un carico di piano su una superficie triangolare contornata da elementi Line o quadrangolare selezionando 3 o 4 nodi. Scegliere il tipo di piano fra:

-   Piano a 3 lati – centroide: per caricare un piano triangolare distribuendo il carico su tutti i lati;

-   Piano a 4 lati – centroide: per caricare un piano quadrangolare distribuendo il carico su tutti i lati;

-   Piano a 4 lati orientato: per caricare un piano quadrangolare su 2 o più lati tenendo conto della direzione del carico (es. per orditura dei solai);

-   Piano a 4 lati a 2 vie: per caricare un piano quadrangolare su tutti i lati secondo le aree di influenza.

Nel riquadro Imposta carico possono essere specificati i casi di carico di destinazione e i relativi valori.

Nel riquadro Direzione del carico è possibile forzare la direzione dei carichi applicati. L’impostazione di default Normale al piano applica carichi normali al piano tenendo in considerazione la sua orientazione oraria o antioraria. Questa impostazione viene sovrascritta se viene specificata un’altra direzione.

Per disegnare il piano una volta selezionato il carico di piano desiderato, premere Disegna piano.

*    AVVISO: i carichi immessi in questa maschera devono avere la dimensione F/L2.

*    AVVISO: gli elementi di bordo del piano possono essere solamente di tipo Line.

*    AVVISO: il verso di disegno del piano determina il segno del carico. Nel riferimento globale, disegnare i piani in senso antiorario per mantenere il segno imposto nella tabella Imposta carico.

surfaceLoad Pressione: Applica un carico per unità di superficie a elementi piani.

Sono supportati anche i carichi non uniformi limitatamente ad una variazione bi-lineare tramite il box Carico non uniforme.

volumeLoad Carico di volume: Permette di applicare un carico per unità di volume ad un elemento solido.

loadsGenerica Spostamento imposto: Applica uno spostamento imposto ai nodi selezionati.

Immagine che contiene testo, schermata, Carattere, numero Descrizione generata automaticamente

iniTemperature Temperatura iniziale: Permette l’assegnazione della temperatura iniziale del modello.

AVVISO: Il comando influenza solo le analisi termiche. Non sortisce effetti per i carichi da distorsione termica.

prestress Precarico: Applica un precarico (solo positivo, cioè in trazione) agli elementi monodimensionali (travi e aste) selezionati. Un valore positivo di precarico positivo rappresenta un elemento in trazione (es. cavi, funi).

AVVISO: Il carico viene visualizzato come una distorsione termica uniforme sull’elemento. Il valore della distorsione avrà segno opposto a quello del precarico assegnato.

masse Massa puntuale: Applica una massa nodale ai nodi selezionati.

Immagine che contiene testo, schermata, numero, schermo Descrizione generata automaticamente

AVVISO: Le unità di misura utilizzate devono essere consistenti con le scelte iniziali.

AVVISO: È opportuno specificare sempre la stessa massa nodale per tutti i gradi di libertà traslazionali.

Masse da carichi: Assegna masse al modello partendo dai valori dei carichi immessi nel caso di carico selezionato. I check in “Imposta masse” attivano o disattivano la massa nella direzione corrispondente.

Il riquadro “Assegna masse da caso di carico” serve per l’assegnazione delle masse nelle direzioni specificate sopra senza che siano cambiate al variare dei carichi.

material Materiale: Assegna un materiale agli elementi selezionati.

sect Sezione: Assegna una sezione agli elementi selezionati.

rotation Rotazione assi locali: Nel riquadro Travi, ruota la sezione degli elementi selezionati specificando un angolo di rotazione antiorario.

Nel riquadro Elementi piani, ruota gli assi locali degli elementi piani selezionati modificando la connettività.

Il comando Inverti connettività serve per invertire gli assi Z degli elementi piani.

AVVISO: Con mesh non regolari (es. triangolari), è opportuno rettificare tutti gli assi locali per poter leggere i risultati in termini di tensioni e deformazioni in modo consistente.

Immagine che contiene testo, schermata, numero, Carattere Descrizione generata automaticamente

vinc Vincoli: Assegna i vincoli specificati ai nodi selezionati, specificandoli nel sistema di coordinate globali.

Nel viewport, sono applicate le seguenti convenzioni grafiche:

    [image] x, y e z bloccati (appoggio)

    [image] tutti bloccati (incastro)

    [image] x, y, z e ry, rz bloccati (incastro nel piano XZ, appoggio nel piano YZ)

    [image] y e z bloccati, carrello nel piano xz

    [image] x, y, z e rx bloccati

    [image] solo ry bloccato

    [image] rx e ry bloccati

    [image] tutti gli altri tipi di vincolo.

constraint Vincoli interni: Assegna vincoli interni (ad es. piano rigido o link master-slave) ai nodi selezionati. Con il preset Piano rigido è possibile creare automaticamente piani rigidi selezionando tutti i nodi di un piano.

Immagine che contiene testo, schermata, schermo, software Descrizione generata automaticamente

AVVISO: Il nodo master va opportunamente vincolato per evitare labilità nel modello. La procedura propone sempre la scrittura automatica del vincolo da applicare.

gruppi Gruppi: Assegna, modifica o crea un gruppo per i nodi e gli elementi selezionati. È possibile anche creare una section cut all’interno di elementi piani selezionando i nodi interessati.

endRelease End release: Assegna end release agli elementi trave. Specificando un valore compreso fra 0 (completamente rilasciato) e 1 (incastro completo) nella casella a fianco della spunta, si ottiene un end release parziale sulle sollecitazioni risultanti da un’analisi elastica lineare. Il fattore di riduzione r viene applicato alle rigidezze della trave nella forma r/(1-r).

Il flag “Inserisci rigidezze” permette l’assegnazione diretta di una rigidezza per il grado di libertà selezionato al posto della percentuale di forza o momento desiderati.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

endOffset Tratti rigidi: Assegna uno o più tratti rigidi di lunghezza richiesta alle estremità di una trave.

AVVISO: I carichi ospitati nella trave con tratti rigidi non sono modificati in virtù del tratto rigido. Come risultato, i carichi distribuiti potrebbero diminuire sensibilmente come intensità complessiva in ragione della minor lunghezza di applicazione.

elemProps Proprietà elemento: Assegna proprietà personalizzate ai singoli elementi. Per i nomi utilizzati in fase di verifica e per quelli riservati consultare il Capitolo 4.
In aggiunta, da questa maschera è possibile assegnare un offset di sezione a livello di elemento dal riquadro Offset di sezione travi.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

hinges Cerniere: Assegna cerniere plastiche alle travi. Dopo aver inserito il nome della cerniera, premere Aggiungi. A questo punto possono essere settati i GdL della cerniera, inserendo le proprietà elencate sotto. Premere Modifica per salvare la cerniera.

Nel riquadro Opzioni cerniere possono essere definiti i casi di carico da considerare al momento del ricalcolo delle proprietà delle cerniere.

I dati richiesti per una cerniera plastica di tipo Bilineare Simmetrica sono:

-    Fy: resistenza al limite elastico

-    cKpl: coefficiente di rigidezza del ramo plastico Kpl=cKpl * Kel;

-    m: duttilità della cerniera;

-    Fres/Fy: resistenza residua in percentuale di Fy.

I dati richiesti per una cerniera plastica di tipo Bilineare Asimmetrica sono:

-    Fy+: resistenza al limite elastico

-    cKpl+: coefficiente di rigidezza del ramo plastico Kpl=cKpl * Kel;

-    m+: duttilità della cerniera;

-    Fres/Fy+: resistenza residua in percentuale di Fy+

-    Tutti i dati precedenti seguiti dal segno “-”: per la parte negativa del legame.

Le cerniere inserite con Proprietà utente sono definite inserendo tutti i dati sopraesposti.

Selezionando NVM dal menu a tendina GdL è possibile assegnare una cerniera con dominio a taglio e a momento. Il calcolo delle proprietà della cerniera viene svolto all’assegnazione ad una trave del modello sulla base del tipo di verifica scelta dal menu a tendina Tipo cerniera. Le cerniere NVM hanno sempre una legge bilineare asimmetrica.

Lo stato delle cerniere può essere visto nei risultati Diagrammi travi, con la seguente convenzione:

member Membratura: Assegna uno o più elementi ad una membratura. L’assegnazione di una membratura ha effetto nella verifica.

Immagine che contiene testo, schermata, schermo, numero Descrizione generata automaticamente

rebar Armature: Assegna armature agli elementi trave. Selezionando la sezione di interesse da riquadro Sezioni di travi, l’eventuale armatura definita in Modifica/Sezioni/Calcolo viene mostrata ed è possibile applicarla agli elementi aventi tale sezione.

La tabella del riquadro Armature assegnate mostra le assegnazioni di barre longitudinali e staffe, anche per gli eventuali conci di trave definiti attraverso le caselle Inizio e Fine.

Il riquadro Posizione barre permette la definizione e la modifica delle armature longitudinali e trasversali. Le staffe sono definite nel sotto-riquadro Armatura a taglio. Posizionamento veloce barre permette l’inserimento veloce di schermi di armatura noti per le sezioni semplici.

Sviluppo trave visualizza la sezione longitudinale della trave, evidenziando il concio selezionato.

AVVISO: le unità di misura utilizzate nella maschera sono quelle del modello, eccetto che per i diametri delle barre nei menu a tendina, che di default sono visualizzati in mm.

spring16 Proprietà molle: Aggiunge, modifica e assegna dei set di proprietà (rigidezze elastiche) delle molle lineari. È possibile anche specificare e assegnare molle distribuite per gli elementi trave di fondazione dal riquadro Proprietà suolo elastico in direzione Z, utilizzando il pulsante Aggiungi molla dopo aver settato il Modulo di Winkler e la Larghezza trave.

È possibile assegnare proprietà non lineari per GdL traslazionali (x, y, z) o rotazionali (rx, ry, rz), sia secondo gli assi globali che locali come specificato nelle opzioni all’angolo superiore destro della maschera. Cliccando sulle caselle NL, i menu a tendina mostreranno i legami non lineari disponibili. Cliccare su un’opzione del menu a tendina per settarne le proprietà.

Il comando Assegna come molla nodale a nodi selezionati connette il nodo ad una molla vincolata al terreno. È utile ad esempio per assegnare delle molle rappresentanti la risposta del terreno a singoli nodi (es. pilastri).

Il comando Assegna molle ai nodi coincidenti sel. permette l’assegnazione di molle a lunghezza zero ai nodi sovrapposti selezionati.

AVVISO: per procedere all’assegnazione di proprietà non lineari, è necessario aggiungere prima un set di proprietà delle molle. Una volta settate le proprietà non lineari, cliccare su Modifica proprietà.

I modelli non lineari disponibili in NextFEM Designer sono:

-    Gap: la molla gap ("salto”) è particolarmente utile per rappresentare il contatto (ad esempio, un gap con apertura nulla). Questo modello lavora solo in compressione con la rigidezza definita dall’utente.
I dati richiesti per il gap sono:

o    closure: massima chiusura del gap;

o    Kclosure: rigidezza del ramo in compressione.

-    Gancio: questo legame reagisce solo a trazione. I dati richiesti sono:

o    opening: spostamento dopo il quale la rigidezza a trazione non è più nulla;

o    Kopening: rigidezza a trazione

-    Bilineare Plastico: mantiene il comportamento lineare elastico fino alla forza Fy, poi inizia il campo plastico. Una volta raggiunto lo spostamento ultimo Uu, la molla si rompe, mantenendo una forza residua Fres. Questo modello ha comportamento simmetrico.

Immagine che contiene testo, mappa Descrizione generata con affidabilità molto elevata

I dati richiesti per il modello Bilineare Plastico sono:

o    Kel: rigidezza elastica assegnata alla molla;

o    Fy: resistenza al limite elastico;

o    cKpl: coefficiente per impostare la pendenza del ramo plastico Kpl=cKpl * Kel;

o    Uu: spostamento ultimo;

o    Fres: resistenza residua dopo il collasso.

-    Bilineare Asimmetrico: questo modello non lineare è particolarmente adatto alla modellazione di elementi a comportamento non simmetrico. La legge ciclica è asimmetrica.

Immagine che contiene testo, mappa Descrizione generata con affidabilità molto elevata

I dati richiesti per il legame Bilineare Asimmetrico sono:

o    Kel+: rigidezza elastica assegnata alla molla;

o    Fy+: resistenza al limite elastico;

o    cKpl+: coefficiente per impostare la pendenza del ramo plastico Kpl=cKpl * Kel;

o    Uu+: spostamento ultimo;

o    Fres+: resistenza residua dopo il collasso;

o    Tutte le quantità precedenti seguite da “-” : le stesse proprietà per la parte in compressione.

-    Trilineare Plastico: dopo aver raggiunto il campo plastico, la curva scheletro è caratterizzata da un ramo di hardening che porta a Fmax, seguito da uno di hardening/softening che porta al collasso in Uu. Questa legge può avere comportamento non simmetrico.

I dati richiesti per il legame Trilineare Plastico sono:

o    Kel+: rigidezza elastica assegnata alla molla;

o    Fy+: resistenza al limite elastico;

o    Kp1+: rigidezza del ramo plastico;

o    Fmax: massima resistenza raggiungibile;

o    Kp2+: pendenza del secondo ramo plastico;

o    Uu+: spostamento ultimo;

o    Fres+: resistenza residua dopo il collasso;

o    Tutte le quantità precedenti (eccetto Fmax) seguite da “-” : le stesse proprietà per la parte in compressione;

o    Fmin: massima resistenza raggiungibile in compressione.

-    Pivot rule: questo modello segue le regole definite in Dowell RK, Frieder S, Wilson LE. Pivot hysteresis model for reinforced concrete members. Struct J 1998;95(5):607–17. Questa legge isteretica può essere asimmetrica. La definizione dei fulcri è definita dai parametri alpha e beta

Con riferimento ai settaggi del legame Trilineare Plastico, i parametri aggiuntivi sono:

o    alpha1: imposta il fulcro per lo scarico da una forza di trazione a zero;

o    beta1: imposta il fulcro per l’inversione del carico da zero a una forza negativa. Deve essere impostato fra 0 e 1;

o    alpha2: imposta il fulcro per lo scarico da una forza di compressione a zero;

o    beta2: imposta il fulcro per l’inversione del carico da zero ad una forza positiva. Deve essere impostato fra 0 e 1.

Immagine che contiene testo, mappa Descrizione generata con affidabilità molto elevata

-    Tomazevic-Lutman: rappresenta un comportamento trilineare così come definito in Tomazevic M, Lutman M. Seismic behavior of masonry walls – modeling of hysteretic rules. J Struct Eng 1996:1048–54. È determinato dai parametri alpha e beta, che rappresentano rispettivamente il degrado di rigidezza e di resistenza. Questo modello è adatto ai GdL taglianti nei pannelli murari. Il ciclo ha comportamento simmetrico.

Immagine che contiene testo, mappa Descrizione generata con affidabilità molto elevata

I dati richiesti dal modello Tomazevic-Lutman sono:

· Kel: rigidezza elastica assegnata alla molla;

· Fy: resistenza al limite elastico (cracking);

· Kpl1: pendenza del primo ramo plastico;

· Fmax: resistenza massima raggiungibile;

· Kpl2: pendenza del secondo ramo plastico di hardening/softening;

· cF: coefficiente per settare la percentuale di scarico in forza dalla curva scheletro;

· alpha: coefficiente di degrado lineare di rigidezza (Kult=alpha*Kel);

· beta: coefficiente di degrado di resistenza basato sull’energia dissipata in un ciclo (0.06 di default);

· Uu: spostamento ultimo.

-    Ring-shape: questo modello rappresenta in ciclo poco dissipativo e può essere utilizzato, per esempio, per i gradi di libertà flessionali nei pannelli murari. La curva scheletro può essere bilineare se Kpl2 è impostato a zero. Questo modello ha un comportamento simmetrico.

Immagine che contiene testo, mappa Descrizione generata con affidabilità molto elevata

I dati richiesti dal modello Ring-shape sono:

· Kel: rigidezza elastica assegnata alla molla;

· Fy: resistenza al limite elastico (cracking);

· Kpl1: pendenza del primo ramo plastico;

· Fmax: resistenza massima raggiungibile;

· cC: coefficiente per settare la pendenza del percorso di scarico;

· cF: coefficiente per settare la percentuale di scarico in forza dalla curva scheletro;

· alpha: coefficiente di degrado lineare di rigidezza (Kult=alpha*Kel);

· cD: punto di passaggio per il percorso di scarico – distanza dal limite elastico nella curva scheletro;

· Uu: spostamento ultimo;

· Kpl2: pendenza del secondo ramo plastico di hardening/softening.

-    Slip-type: comportamento trilineare utilizzabile per le connessioni a taglio nelle strutture in legno (chiodi, viti, angolari, ecc.). Questo modello è basato su Rinaldin G., Fragiacomo M. A Component Model for Cyclic Behaviour of Wooden Structures. Materials and joints in Timber structures: recent developments of technology, RILEM Bookseries, Vol. 9, pp. 519-530, 2014, DOI: 10.1007/978-94-007-7811-5_48, ISBN: 978-94-007-7811-5. Il ciclo ha comportamento simmetrico.

Immagine che contiene testo, mappa Descrizione generata con affidabilità molto elevata

I dati richiesti per il modello Slip-type sono:

· Kel: rigidezza elastica assegnata alla molla;

· Fy: resistenza al limite elastico;

· Kpl1: pendenza del primo ramo plastico, deve essere diversa da 0;

· Fmax: resistenza massima raggiungibile;

· Kpl2: pendenza del secondo ramo plastico di hardening/softening, deve essere diversa da 0;

· cKunload: coefficiente per impostare la rigidezza di scarico del primo ramo del percorso di scarico (verde) e di ricarico (blu), moltiplicando la rigidezza elastica per questo coefficiente;

· cFreload: coefficiente per impostare il limite inferiore dell’ultimo ramo di ricarico (blu) e di ricarico (verde) in percentuale del livello di forza raggiunto in curva scheletro. Il parametro è compreso fra 0 e 1;

· cFunload: coefficiente per impostare il limite inferiore del primo ramo di ricarico (blu) e di ricarico (verde) in percentuale del livello di forza raggiunto in curva scheletro. Il parametro è compreso fra 0 e 1;

· Uu: spostamento ultimo;

· alpha: parametro esponenziale di degrado di resistenza basato sull’energia dissipata;

· beta: parametro esponenziale di degrado di resistenza basato sullo spostamento massimo raggiunto;

· gamma: parametro lineare di degrado di resistenza;

· cKreload: coefficiente per impostare la rigidezza di ricarico dell’ultimo ramo del percorso di scarico (verde) e di ricarico (blu), moltiplicando la rigidezza elastica per questo coefficiente.

-    Unsymm Slip-type: questo modello è adatto alla modellazione di connessioni hold-down nelle strutture in legno. È basato su Rinaldin G., Fragiacomo M. A Component Model for Cyclic Behaviour of Wooden Structures. Materials and joints in Timber structures: recent developments of technology, RILEM Bookseries, Vol. 9, pp. 519-530, 2014, DOI: 10.1007/978-94-007-7811-5_48, ISBN: 978-94-007-7811-5. Il ciclo ha comportamento simmetrico.

Immagine che contiene testo, mappa Descrizione generata con affidabilità molto elevata

I dati richiesti per il modello Unsymmetrical Slip-type sono:

· Kel: rigidezza elastica assegnata alla molla;

· Fy: resistenza al limite elastico;

· Kpl1: pendenza del primo ramo plastico, deve essere diversa da 0;

· Fmax: resistenza massima raggiungibile;

· Kpl2: pendenza del secondo ramo plastico di hardening/softening, deve essere diversa da 0;

· cKunload: coefficiente per impostare la rigidezza di scarico del primo ramo del percorso di scarico (verde) e di ricarico (blu), moltiplicando la rigidezza elastica per questo coefficiente;

· cFreload: coefficiente per impostare il limite inferiore dell’ultimo ramo di ricarico (blu) e di ricarico (verde) in percentuale del livello di forza raggiunto in curva scheletro. Il parametro è compreso fra 0 e 1;

· cFunload: coefficiente per impostare il limite inferiore del primo ramo di ricarico (blu) e di ricarico (verde) in percentuale del livello di forza raggiunto in curva scheletro. Il parametro è compreso fra 0 e 1;

· Uu: spostamento ultimo;

· Fmin: resistenza massima di contatto in compressione;

· Kneg: coefficiente di rigidezza per il ramo di contatto, moltiplica la rigidezza elastica;

· cFend: coefficiente per impostare il valore di forza alla fine dell’ultimo ramo di scarico (verde), moltiplica la resistenza al limite elastico;

· cFinit: coefficiente per impostare il valore di forza all’inizio del primo ramo di ricarico (verde), moltiplica la resistenza al limite elastico;

· alpha: parametro esponenziale di degrado di resistenza basato sull’energia dissipata;

· beta: parametro esponenziale di degrado di resistenza basato sullo spostamento massimo raggiunto;

· gamma: parametro lineare di degrado di resistenza;

· cKreload: coefficiente per impostare la rigidezza di ricarico dell’ultimo ramo del percorso di scarico (verde) e di ricarico (blu), moltiplicando la rigidezza elastica per questo coefficiente.

-    Smorzatore: rappresenta uno smorzatore non lineare secondo il modello alla Kelvin-Voigt (smorzatore e molla in parallelo). Questo modello è adatto per analisi dinamiche, e fornisce una risposta definita come segue:

in cui la rigidezza è

I parametri necessari sono:

· Kr: rigidezza di ritorno dello smorzatore;

· C: smorzamento;

· a: esponente della velocità;

· K0: rigidezza iniziale;

· F0: forza di precarico, sotto la quale lo smorzatore è inattivo.

-    AMD: rappresenta uno smorzatore lineare (eccetto i limiti Fmax, Vmax e Dmax) alla Maxwell (smorzatore e molla in serie). Se Fmax è diverso da zero, lo smorzatore limita la forza fornita comportandosi in modo elastico-perfettamente plastico. Vmax e Dmax possono essere utilizzati per rappresentare un Active Mass Damper con limiti in velocità e spostamento. I parametri richiesti sono:

· K: rigidezza in parallelo del damper

· G: smorzamento

· m: massa del damper

· a: esponente della velocità;

· Fmax: forza massima del damper;

· Dmax: spostamento massimo del damper;

· Vmax: velocità massima del damper;

Per questo elemento sono disponibili delle variabili di stato consultabili dalla maschera Estrai dati, alla voce “Stazioni/Punti”. Ciascuna contiene:

v s1: velocità al passo

v s2: forza al passo

v s3: energia dissipata dal damper

v s4: accelerazione rel. massa

v s5: velocità rel. massa

v s6: spostamento rel. massa.

-    VRM: simula una ampia classe di cicli di isteresi complessi come descritto in Vaiana N, Rosati L (2023) Classification and unified phenomenological modeling of complex uniaxial rate-independent hysteretic responses. Mech Syst Sig Process 182: 109539 ed in Vaiana N, Rosati L (2023) Analytical and differential reformulations of the Vaiana-Rosati model for complex rate-independent mechanical hysteresis phenomena. Mech Syst Sig Process 199: 110448.

I dati richiesti dal modello Vaiana-Rosati sono:

· kb+: coefficiente angolare della retta limite superiore [image] (Fig. a);

· f0+: ordinata del punto [image] (Fig. a);

· alfa+: parametro che regola la curvatura della curva di carico [image] (Fig. a);

· beta1+: parametro che trasforma [image] in una curva senza punto di flesso regolandone la curvatura (Fig. b);

· beta2+: parametro che trasforma [image] in una curva senza punto di flesso regolandone la curvatura (Fig. b);

· gamma1+: parametro che trasforma [image] in una curva con punto di flesso [image] regolando la distanza tra [image] e [image] (Fig. c);

· gamma2+: parametro che trasforma [image] in una curva con punto di flesso [image] regolando la pendenza di [image] (Fig. c);

· gamma3+: ascissa del punto di flesso [image] (Fig. c);

· umax: spostamento ultimo positivo;

· Tutti i parametri precedenti seguiti da “-” : le stesse proprietà per la fase di scarico;

· umin: spostamento ultimo negativo.

AVVISO: per l’uso in OpenSees delle molle non lineari, consultare www.nextfem.it/it/opensees-ita/ per installare il solver OpenSees. Impostare le opzioni desiderate anche nei riquadri nella maschera Opzioni, tab Misc.


2.8. Menu Strumenti

arrow-16 Lancia: Questo comando permette di lanciare l’analisi.

Lancia selezionati: Questo comando permette di lanciare le analisi selezionate. Per uscire dalla maschera seguente senza eseguire nulla, premere OK impostando ogni riga a No.

cloud2 Login nel cloud: Questo comando permette di lanciare analisi nel cloud NextFEM. Per effettuare il login, immettere Username e Password ottenuti mediante la registrazione sul sito ufficiale di NextFEM.

Immagine che contiene testo, schermata, Carattere, numero Descrizione generata automaticamente

Una volta connessi, sarà possibile lanciare l’analisi desiderata sul modello aperto selezionando il caso di carico da calcolare e premendo il pulsante Invia.

Una volta che l’analisi è stata lanciata, è possibile richiedere i risultati attraverso il pulsante Ottieni risultati. Selezionare Pulisci risultati locali/precedenti se il modello aperto non corrisponde a quello richiesto al cloud.

query2 Query: Interroga nodi ed elementi mostrando le loro proprietà. Selezionando 2 nodi consecutivi è possibile misurare la distanza che li separa.

screen16 Screenshot: Copia negli appunti uno screenshot del viewport corrente.

wizard Impostazione guidata modello: Permette la definizione guidata di un nuovo modello tramite l’inserimento di materiali, sezioni, casi di carico, masse.

frameGen Generatore di telai: Il comando permette la generazione automatica di un modello a telaio spaziale regolare. I dati di input necessari sono:

-    Il numero di campate in X e Y, il numero di piano e le rispettive luci

-    Il materiale e la sezione trasversale da associare alle travi principali, secondarie e colonne

-    OPZIONALE: i carichi da assegnare scegliendo l’orditura dei solai. Devono essere già stati definiti dei casi di carico per procedere all’assegnazione dei carichi.

sectFromModel Sezione da modello: Permette di creare una sezione da un modello in cui è stata svolta l’analisi termica nel piano XY. Il comando chiede successivamente alcuni parametri per la scelta delle funzioni per la verifica al fuoco (curva d’incendio, curve di degrado dei materiali, ecc.).

Aggiungi plinto: Aggiunge un plinto modellato a shell su suolo elastico al nodo selezionato. I vincoli del nodo sono sovrascritti con un vincolo compatibile con il suolo elastico (X, Y e RZ). Il comando chiede in input le dimensioni in pianta del plinto, lo spessore e il materiale del plinto, la tipologia di suolo elastico che deve essere già definita.

options32 Opzioni: Permette di cambiare le opzioni di visualizzazione, nonché la scelta del solutore di default.

Immagine che contiene testo, schermata, numero, Carattere Descrizione generata automaticamente

Immagine che contiene testo Descrizione generata automaticamente

AVVISO: OpenSees e CalculiX non sono completamente supportati, e non sono distribuiti da NextFEM né inclusi nell’installer.

L’opzione Salva risultati nel file NXF permette di salvare i risultati di un’analisi nel file del modello. L’opzione funziona solo con il solutore OOFEM integrato.

L’opzione Salva autom. il modello ogni permette di salvare automaticamente il modello su cui si sta lavorando ogni n minuti, secondo il valore specificato.

Opzioni per OOFEM
Selezionare l’opzione Considera deformazione tagliante negli elementi beam per considerare il contributo alla Timoshenko nelle travi.
L’opzione Integrazione ridotta per le shell a 4 nodi forza l’integrazione ridotta per gli elementi quad nel solver di default.
L’opzione Includi curvature e deformazioni nei risultati shell permette di visualizzare curvature e deformazioni per gli elementi shell in vista risultati. L’attivazione di questa opzione potrebbe rallentare l’analisi e aumentare il peso del modello.
L’opzione Solutore permette la scelta del solutore di default:
- Standard: è il solutore base, permette l’identificazione delle labilità nel modello;
- Solver DSS: Direct Sparse Solver ottimizzato per la risoluzione veloce di modelli pesanti minimizzando l’impiego di memoria RAM. Questo solutore non permette l’identificazione delle eventuali labilità;
- Solver SPOOLES: SParse Object Oriented Linear Equations Solver ottimizzato per la risoluzione veloce di modelli pesanti. Questo solutore non permette l’identificazione delle eventuali labilità.
Percorso per file temp. mostra la cartella temporanea di lavoro del solver.

Opzioni per ADAPTIC
L’opzione Leggi velocità e accelerazioni nodali abilita la lettura dai file NUM di ADAPTIC di velocità e accelerazioni per ogni nodo, se presenti.

Opzioni BIM
L’opzione Dimensione mesh IfcWall permette di specificare la dimensione della mesh degli elementi quad utilizzati per l’importazione di IfcWall in file IFC o IFCxml.

Opzioni generali
Permette il settaggio della tolleranza per l’unione di nodi coincidenti (merge) e imposta il simbolo del separatore per gli export in formato CSV.


2.9. Plugins

2.9. plugin Plugins

Questa sezione del menu contiene i collegamenti per avviare tutti i plugin caricati all’avvio del programma. I plugin sono solo in lingua inglese, e costituiscono programmi completamente indipendenti da Designer. Per maggiori informazioni: www.nextfem.it/dev/

Sono inclusi alcuni plugin nell’installazione di default di NextFEM Designer, come ad esempio:

Floor modeler per trasformare un piano di carico in un piano costituito da shell caricate su una faccia;

Custom report compiler per modificare automaticamente un file in formato DocX con tabelle e screenshot dal modello;

Parametric solver per svolgere facilmente analisi parametriche.


2.10. Menu Risultati e Verifiche

view32 Mostra risultati: Mostra i risultati delle analisi. Selezionare dalla barra di stato il tipo e la componente da visualizzare.

I risultati disponibili variano a seconda del tipo di analisi e sono:

-    Diagrammi travi per visualizzare i diagrammi delle travi

-    Stress travi per visualizzare un contour degli stress generalizzati delle travi

-    Deformazioni travi per visualizzare un contour delle deformazioni delle travi

-    Deflessioni travi per visualizzare un contour delle deflessioni delle travi

-    Press. terreno travi per visualizzare in contour delle pressioni sul terreno delle travi con molle di sottofondo

-    Spostamenti nodi per visualizzare la deformata e relativo contour in spostamento del modello

-    Velocità nodi per visualizzare la deformata e relativo contour in velocità del modello

-    Accelerazioni nodi per visualizzare la deformata e relativo contour in accelerazione del modello

-    Reazioni nodali per visualizzare le reazioni dei vincoli esterni del modello come vettori

-    Forze aree per visualizzare le forze per unità di lunghezza di elementi piani

-    Stress aree per visualizzare gli stress in elementi piani

-    Deformazioni aree per visualizzare le deformazioni in elementi piani

-    Forze solidi per visualizzare le forze in elementi di volume

-    Stress solidi per visualizzare gli stress in elementi di volume

-    Deformazioni solidi per visualizzare le deformazioni in elementi di volume

-    Dati nodali per visualizzare i dati relativi al nodo (rapporti di verifica, valori personalizzati, ecc.)

-    Dati elementi per visualizzare i dati relativi all’elemento (rapporti di verifica, valori personalizzati, ecc.)

-    Temperatura aree per visualizzare la mappa termica di elementi piani

-    Temperatura solidi per visualizzare la mappa termica di elementi solidi (non ancora disponibile).

Animazione: Visualizza l’animazione delle deformate attraverso il tempo oppure esporta un video sul risultato selezionato.

extrData Estrai dati: Estrae i dati dall’analisi in formato tabellare.

Per estrarre i risultati seguire la procedura seguente:

-    Selezionare un caso di carico da Seleziona caso di carico;

-    Selezionare un tempo da Seleziona tempo o modo;

-    Selezionare un tipo di dato da Seleziona il tipo di dati;

-    Selezionare l’elemento o il nodo desiderato da Numero;

-    (opzionale) se si richiede un dato da un elemento, selezionare il punto di integrazione per cui si richiede il valore.

Per esportare i dati visualizzati in formato tabellare CSV premere il pulsante Esporta in CSV. Il comando Esporta tutto in CSV permette di esportare il tipo di dato selezionato in Seleziona il tipo di dati per tutti gli elementi o nodi.

Il riquadro Operazioni sui valori permette di svolgere automaticamente delle operazioni semplici (somma, somma dei valori assoluti, valore assoluto) sui dati richiesti.

Il riquadro Filtra per consente di visualizzare i dati filtrati per materiale, sezione, ecc.

report Stampa report: Produce un report in formato PDF, RTF o DocX. Selezionare le voci desiderate per includerle nel report.

Imposta limiti del contour: Permette di settare i limiti della vista a gamma di colori corrente a dei valori limite scelti dall’utente. La maschera contiene anche dei comandi per tracciare delle isocurve nella vista corrente per gli elementi shell (temperatura, stress o forze).

*    AVVISO: I limiti per i colori del contour sono associati agli estremi della banda di colori. Qualsiasi valore che eccede questi limiti sarà associato al colore del limite più vicino (rosso o blu).

delete Cancella risultati salvati: Permette la cancellazione dei risultati salvati nel file del modello NXF.

delete Cancella le verifiche salvate: Permette la cancellazione delle verifiche salvate nel modello NXF.

Somma carichi e masse: produce un report sugli scarichi in direzione Z per ogni caso di carico di base, riportando anche la sommatoria delle masse presenti.

AVVISO: nei casi di carico da vento, il valore restituito è la massima somma fra le direzioni X, Y e Z globali, calcolata sulle reazioni. Nei rimanenti casi vengono sommati i carichi applicati.

Computo metrico: il programma mostra una maschera con le somme e i volumi distinti dei materiali, distinti anche per sezione.

Più stazioni di output: Il comando permette di visualizzare diagrammi continui aumentando il numero di stazioni visualizzate.

AVVISO: Le stazioni aggiuntive non sono salvate nel file. Il comando si resetta al salvataggio del modello o all’apertura.

verifiche16 Verifiche: Permette di eseguire controlli personalizzati su nodi o elementi. Si rimanda al paragrafo dedicato per maggiori informazioni. Per eseguire una verifica su nodi o elementi:

-   [image] Scegliere un set di dati di verifica dal menu a tendina “sulle seguenti quantità”

-   [image] Scegliere un caso di carico dal menu “per il caso di carico” o selezionare TUTTI;

-   [image] Impostare le formule di verifica dalla tendina “Set di verifiche” o scrivere le formule di verifica nel riquadro di testo;

-   [image] Premere il pulsante Esegui verifiche.

I risultati sono visualizzati nell’area di output, in formato tabellare e testuale se richiesto tramite il check “Salva log per ogni stazione”. Posso essere esportati tramite il comando Esporta tabella.

Infine, le aree “Impostazioni di verifica”, “Risultati testuali su oggetto selezionato” e “Lancia verifica” possono essere nascoste premendo il tasto grip sul relativo bordo.

smartCheck Verifiche intelligenti: permette di selezionare automaticamente la verifica appropriata sulla base del materiale dell’elemento. In aggiunta, mostra i risultanti della verifica ordinati per sezione.

Immagine che contiene testo Descrizione generata automaticamente

AVVISO: le verifiche selezionate sono corrispondenti a quelle raggiungibili dalle combinazioni di tasti CTRL+1 – 7 o tramite il pulsante “Dettagli verifiche”.

fire16 Verifica al fuoco: il comando avvia la prima fase delle verifiche al fuoco per le strutture a telaio sugli elementi trave selezionati.

Nella finestra che appare è possibile selezionare:

-   Curve di analisi e verifica: selezionare Eurocodice 2 per le strutture in c.a., Eurocodice 3 per l’acciaio, Eurocodice 9 per l’alluminio;

-   Combinazione di carico: selezionare la combinazione di carico eccezionale da utilizzare per la verifica veloce;

-   Criterio di selezione della sezione: la sezione utilizzata per la verifica deve rispondere al criterio selezionato (massimo momento My, massimo momento Mz, massimo in entrambe le direzioni Myz)

-   Lati esposti per travi: i lati considerati come esposti per l’analisi termica per gli elementi orizzontali o sub-orizzontali;

-   Lati esposti per pilastri: i lati considerati come esposti per l’analisi termica per gli elementi verticali;

-   Tempo finale di analisi in minuti: selezionare il tempo di analisi per il quale verrà condotta la verifica resistente della sezione.

L’opzione Esegui tutte le analisi permette di lanciare i file creati nella stessa cartella del modello corrente, salvando per ciascuno i risultati. L’opzione Mostra risultati visualizza l’isoterma 500°C per ogni analisi termica in una finestra separata.

Il comando restituisce una tabella contenente i rapporti domanda/capacità delle sezioni analizzate nelle colonne Check-NMM (pressoflessione) e Check-V (taglio). Nella stessa cartella del modello sono salvate le immagini relative alla verifica resistente (rappresentazione della sezione e dell’asse neutro, dominio resistente ridotto per effetto dell’incendio).

Verifica ribaltamento: esegue la verifica a ribaltamento di tutto il modello, considerandolo come corpo rigido. Il comando calcola i contributi stabilizzanti e ribaltanti di ogni carico presente (eccetto quelli termici e di distorsione termica) ed esegue la loro sommatoria.
La verifica viene svolta nei confronti di assi di rotazione orizzontali (nel piano XY) passanti per i nodi vincolati alla traslazione in Z del modello. Il programma seleziona automaticamente i 4 nodi periferici oppure accetta l’input da parte dell’utente per questi nodi. È possibile, inoltre, specificare un angolo di rotazione dell’asse nel piano XY (default 0° = asse globale X).
La verifica viene svolta automaticamente per l’asse specificato e l’asse ortogonale a questo, producendo una tabella con ogni caso di carico (sia quelli di base che le combinazioni linear add) riportante il momento di ribaltamento. Se questo è negativo, la configurazione è stabile. Se è positivo, la struttura ribalta.

AVVISO: il calcolo sul ribaltamento viene eseguito nei confronti dei soli carichi applicate come forze, concentrate o uniformemente distribuite. Le reazioni vincolari sono sempre trascurate.
AVVISO: non sono supportati i carichi distribuiti con andamento lineare. La risultante di questi è assunta sempre in mezzeria dell’elemento caricato.
AVVISO: l’algoritmo automatico di ricerca dei nodi cerca in tutti i nodi vincolati in Z e assume il loro massimo ingombro in pianta. Controllare sempre la posizione dei nodi vincolati in direzione globale Z; in caso di dubbio procedere con nodi identificati manualmente.

* Analisi cinematica muratura: esegue la verifica del cinematismo di ribaltamento di elementi Wall o MasonryWall selezionati dall’utente. La direzione di ribaltamento è fornita dall’asse Z degli elementi – per cambiarlo utilizzare il comando Assegna / Ruota assi locali / Inverti connettività. Si rimanda al tutorial sull’elemento Wall per ulteriori informazioni. Il comando richiede la licenza del modulo MasonryCheck. Vengono calcolati:

Fattore di partecipazione

Accelerazione mobilitante

Moltiplicatore di collasso

Accelerazione di attivazione del meccanismo

Con W peso proprio e d1 distanza dalla cerniera, P permanenti e d2 distanza dalla cerniera, FC Fattore di Confidenza, Ms momento stabilizzante e Mr momento ribaltante.

IDEA CheckBot: il comando permette l’esecuzione di IDEA StatiCa® Code CheckBot sugli elementi e sui nodi selezionati.

AVVISO: per funzionare correttamente, l’opzione “Cartella di installazione di StatiCa” deve essere correttamente impostata.


2.11. Menu Aiuto (?)

help16 Aiuto: Apre il manuale utente.

updates Controlla aggiornamenti: Verifica se ci sono aggiornamenti del programma. Il sotto-comando Controlla aggiornamenti facoltativi permette di scaricare aggiornamenti contenenti correzioni o modifiche minori.

language Lingua: Cambia la lingua del programma. E’ richiesto il riavvio del programma per applicare la modifica.

Licenza: Consente la gestione della licenza d’uso. E’ necessario essere connessi a Internet per gestire le licenze.
Il pulsante Richiedi licenza inoltra ai server NextFEM la richiesta della licenza sulla macchina nel quale il software è installato.
Il comando Ottieni licenze attive permette il download delle informazioni di licenza dai server NextFEM e le memorizza nel PC in uso.
Il comando Scarica licenza da questo PC disattiva la licenza nella macchina corrette al fine di permettere la riattivazione di una copia del programma in un'altra macchina.

esclamativo Informazioni su: Informazioni sul programma e sui pacchetti utilizzati.


3. Funzionalità di import/export

3.


3.1. Importazione


OpenSees

Pre-processing:

-    Nodi

-    UniaxialMaterial (partial reading)

o    elastic

o    elasticPP

o    elasticPPgap

o    ENT

o    Concrete01

o    Concrete02

o    Concrete03

o    Steel01

o    Steel02

-    NDMaterial

o    ElasticIsotropic

-    Sezioni (supporto parziale)

o    Fiber

o    PlateFiber

o    LayeredShell

-    Elementi

o    ShellMITC4

o    quad

o    bbarQuad

o    enhancedQuad

o    quadUP (both)

o    ShellDKGQ

o    ShellNLDKGQ

o    ShellNL (treated as 8-node shell)

o    ElasticBeamColumn

o    ElasticTimoshenkoBeam

o    ForceBeamColumn

o    DispBeamColumn

o    beamWithHinges

o    truss e trussf

o    corotTruss

o    rotspring2dir

o    zeroLength

o    zeroLengthND

o    zeroLengthSection

o    stdBrick

o    bbarBrick

o    Brick8N

o    brickUP

o    Brick20N

o    20_8_BrickUP

-    Fix, fixX, fixY, fixZ Commands

-    GeomTransf Commands

-    Uniform Beam Loads

-    Nodal Loads

Post-processing:

-    Displacements recorder

-    Reactions recorder

-    Modal Eigenvectors recorder

-    Custom spring data

AVVISO: L’importazione di modelli OpenSees potrebbe essere incompleta. Utilizzare sempre recoder definiti in modo più completo possibile nei GdL e negli oggetti da registrare (es. “recorder Node -file disp.out -time -nodeRange 0 124 -dof 1 2 3 4 5 6 disp”).


Midas GEN®

Pre-processing:

-    Nodes

-    Elements

o    Beam

o    Truss

o    Tension-only truss

o    Compression-only truss

o    Plate

o    Wall

o    Wall-opening

o    Elastic link

o    NL-link

-    Frame Sections

o    Rectangular

o    Circular

o    SRC (EPC only)

o    Tapered

o    H, C, L, 2C, cold-formed C, T, reversed T, box, 2L

-    Section color (see Options)

-    Thickness color

-    Plate and Wall sections (thickness)

-    Materials

-    Member assignments

-    Story

-    Constraints

-    Groups

-    Local axes

-    Surface springs

-    Frame releases and offsets

-    Static load cases

-    Load combinations

-    Distributed beam loads

-    Point loads

-    Beam rebar

-    Column rebar

-    Wall rebar

-    Meshed-slabs rebar (basic rebar only)

Post-processing:

-    Sollecitazioni travi da tabella

-    Sollecitazioni truss da tabella

-    Sollecitazioni Wall da tabella

-    Sollecitazioni elastic e geneal link da tabella

-    Spostamenti nodali da tabella

-    Forze nodali da RS.


SAP2000®

Per importare un modello dal formato SAP2000, cliccare sul comando File/Import e scegliere l’opzione SAP2000 text file (*.s2k) dal menu a tendina.

Tipi di dati supportati:

-    Joint coordinates

-    Joint local axes assignments (typical and advanced)

-    Joint restraint assignments

-    Frame section properties

-    RC columns and beams frame properties

-    Non-prismatic section properties

-    Section designer properties: box/tube and plate, shape solid rectangle, shape polygon and single reinforcing bars

-    Cable section definitions

-    Frame connectivity

-    Link connectivity

-    Cable connectivity

-    Area connectivity

-    Solid connectivity

-    General frame section properties

-    Area section properties

o    Rectangular

o    circular

-    Frame release assignments: total and partial

-    Frame section assignments

-    Frame local axes assignments

-    Area section assignments

-    Area local axes assignments

-    Basic mechanical material properties

-    Material properties for concrete data

-    Material properties for rebar data

-    Groups definition and assignment

-    Joint constraints

-    Joint loads

-    Frame distributed loads

-    Frame temperature loads

-    Cable loads

-    Load case definitions

-    Load patterns definitions

-    Modal case

-    Functions: response spectrum and time-history from file

-    Added mass assignment

-    Combinations

Post-processing:

-    Modal periods and frequencies

-    Joint displacements

-    Joint reactions

-    Frame element forces

-    Shell element forces (averaged on nodes)

-    Shell element stresses

-    Section cuts forces (analysis and design types)


OOFEM

Pre-processing:

-    Analysis type

-    Node

-    Rigidarmnode

-    Beam3D

-    Truss3D

-    quad1mindlinshell3d

-    mitc4shell

-    tr_shell01

-    tr_shell02

-    LSpace

-    LTRSpace

-    QSpace

Post-processing:

-    Node displacements

-    Node reactions

-    Element forces and moments

-    Element strains

-    Element stresses


ADAPTIC and Zeus-NL

Pre-processing:

-    Materials

-    Groups

-    Structural Nodal Coordinates (with or without repetitions)

-    Non-structural Nodes (with or without repetitions)

-    Element connectivity (with or without repetitions)

o    CBP3

o    CBP2

o    LNK3

o    JEL3

o    IN16 (partitioning supported)

o    BK20 (partitioning supported)

Post-processing features:

-    Nodal displacements

-    Nodal velocities (disable by default, check Options)

-    Nodal accelerations (disable by default, check Options)

-    Reactions

-    Frame diagrams for cbp2, cbp3, lnk3 (in global coordinates), jel3.


ABAQUS® e CalculiX

Pre-processing:

-    Nodi

-    Elementi

o    B22

o    B23

o    B31

o    B33

o    S3

o    CPS3

o    S4

o    S4R

o    CPS4

o    C3D4

o    C3D10

o    C3D8

o    C3D20

Post-processing:

-    Non disponibili


Dxf

Pre-processing:

-    Punti

-    Linee

*    AVVISO: La correttezza dei risultati non è garantita. Controllare sempre accuratamente il modello importato.


Straus7®

Pre-processing:

-    Units

-    Nodes

-    Beam

-    Beam3

-    Tri3

-    Quad4

-    Hexa8

-    Beam rotation angles

-    Restraints

-    Rigid links

-    Master-slave links

-    Masses

-    Beam sections (rectangular, round, I, angle)

-    Shell sections

-    Global distributed forces on beams

-    Local distributed forces on beams


File BIM – IFC e IFCxml

L’importazione di modelli BIM è supportata nei formati IFC e IFCxml. Durante l’importazione gli elementi IfcWall vengono meshati automaticamente con elementi quad in mesh strutturata. La dimensione della mesh può essere specificata nelle opzioni del programma. Le tolleranze nella posizione di finestre e porte non supera la metà della dimensione della mesh.

È supportata la lettura di:

-   IfcBeam (Swept Solid body, Curve2d and Mapped body representations)

-   IfcColumn (Swept Solid body, Curve2d and Mapped body representations)

-   IfcWall (Swept solid representations)

-   IfcSlab (Swept solid representations)

-   IfcFooting (Swept solid representations)

-   IfcReinforcingBar per le armature longitudinali e staffe

-   IfcStructural classes.


Modelli SAF (Structural Analysis Format)

L’importazione di modelli SAF avviene tramite file .XLSX. Le caratteristiche supportate sono:

- StructuralMaterial

- StructuralCrossSection

- StructuralPointConnection

- StructuralCurveMember

- StructuralSurfaceMember

- StructuralPointSupport

- RelConnectsStructuralMember

- RelConnectsRigidLink

- StructuralLoadCase

- StructuralLoadCombination

- StructuralPointAction

- StructuralPointMoment

- StructuralCurveAction

- StructuralCurveMoment

- ResultInternalForce1D


3.2. Export


ABAQUS®

-    Nodi

-    Elementi

o    B33

o    CPE2

o    CPS3

o    S3

o    CPE4

o    CPS4


OpenSees

-    Nodi

-    Elementi

o    elasticBeamColumn

o    ShellMITC4

o    twoNodeLink (per le molle)

o    stdBrick

o    Brick20N

-    Sezioni

o    PlateFiber

-    Isotropic Materials

o    nDMaterial ElasticIsotropic

-    Restraints

-    Nodal loads


Midas GEN®

-    Units

-    Nodi

-    Elementi

o    Beam

o    Triangular plates

o    Quadrilateral plates

-    Groups

-    Frame releases

-    Isotropic materials

-    Sections and general sections

-    Wall and plate sections

-    Restraints

-    Elastic link

-    Surface springs

-    Members

-    Constraints

-    Nodal masses

-    Loads cases

-    Concentrated loads

-    Distributed loads on beams

-    Temperature loads

-    Pressure loads

-    Load combinations

-    Subsoil springs

-    Column rebar

-    Beam rebar

-    Wall rebar


SAP2000®

-    Joints

-    Frame connectivity

-    Area connectivity

-    Solid connectivity

-    Basic material properties

-    Frame sections

-    Frame local axes

-    Frame releases

-    Area section ( [image] AVVISO: thick shells con drilling DOFs)

-    Section assignments

-    Load cases ( [image] AVVISO: Self weight impostato a zero)

-    Restraints

-    Constraints, rigid diaphragms

-    Linear links ( [image] AVVISO: non completamente supportati)

-    Concentrated masses

-    Concentrated loads

-    Distributed loads on beams

-    Temperature loads

-    Groups

-    Section cuts

-    Functions: response spectrum and time-history

-    Load patterns

-    Load cases

-    Modal loadcase

-    Buckling loadcase

-    Response spectrum analysis

-    Dynamic analysis

-    Load combinations


OOFEM

-    Analysis

o    Linear static

-    Nodi

-    Elementi

o    Beam3D

o    Truss3D

o    Tr_shell01

o    Quad1mindlinshell3d

o    Lumped mass

o    LTRSpace

o    LSpace

o    QSPace

-    Sections

-    Isotropic materials

-    Boundary conditions

-    Sets


Dxf

-    Punti

-    Linee

-    Elementi piani


File BIM – IFC e IFCxml

-   IfcBeam (Swept Solid body, Axis 2d and Mapped body representations)

-   IfcColumn (Swept Solid body, Axis 2d and Mapped body representations)

-   IfcWall solo per i setti appartenenti ad un gruppo (vedasi il comando Modifica/Mesh parete) (Swept solid representations)

-   IfcSlab (Swept solid representations)

-   IfcFooting

-   IfcReinforcingBar per le armature longitudinali e staffe.


Open Model per IDEA StatiCa

Il programma supporta l’esportazione dei modelli in acciaio verso il software IDEA StatiCa. Per l’uso con IDEA StatiCa Connection per la progettazione di un giunto in acciaio, è necessario importare l’attributo “Nodo Giunto” dal comando Modifica/Cambia tipo elemento per i nodi che ospitano i giunti.

AVVISO: la corretta esportazione di geometria e risultati non è garantita.


Modelli SAF (Structural Analysis Format)

L’esportazione di modelli SAF avviene tramite file .XLSX. Le caratteristiche supportate sono:

- StructuralMaterial

- StructuralCrossSection

- StructuralPointConnection

- StructuralCurveMember

- StructuralSurfaceMember

- StructuralPointSupport

- RelConnectsStructuralMember

- RelConnectsRigidLink

- StructuralLoadCase

- StructuralLoadCombination

- StructuralPointAction

- StructuralPointMoment

- StructuralCurveAction

- StructuralCurveMoment

- ResultInternalForce1D


4. Personalizzazione

4.


4.1. Librerie dei materiali

Le librerie dei materiali presenti nel programma possono essere ampliate scrivendo un file CSV (con separatore “;”), come nell’esempio seguente:

-    Acciaio

Name;Code;E [MPa];G [MPa];n_;fyk [MPa];ftk [MPa];Wd [kN/m^3];CheckType

S235;UNI EN 10025-2;210000;80769;0.3;235;360;78.6;0.801;1

S275;UNI EN 10025-2;210000;80769;0.3;275;430;78.6;0.801;1

-    Calcestruzzo

Name;Code;E [MPa];G [MPa];n_;fck [MPa];Wd [kN/m^3];CheckType

C8/10;NTC2008;25331;10555;0.2;8;25;2.548;3

C12/15;NTC2008;27085;11285;0.2;12;25;2.548;3

La colonna CheckType specifica le verifiche da associare per il materiale. Inserire:

    1 per Acciaio

    2 per Alluminio/Leghe di alluminio

    3 per Calcestruzzo armato

    4 per Legno

    0 per altri materiali.

Per aggiungere altri tipi di materiali, tutte le colonne riportare sono obbligatorie, eccetto Md – densità di massa, che è calcolata dal programma a partire dal peso specifico Wd.

Le colonne supportate nativamente sono:

-   E: modulo di Young

-   n_: coefficiente di Poisson

-   G: modulo di taglio

-   fk: resistenza caratteristica

-   Wd: peso specifico

-   a_T: coefficiente di dilatazione termica lineare

-   K: conducibilità termica

-   Cp: calore specifico

Il nome della proprietà può essere seguito da parentesi quadre contenenti l’unità di misura (es. “E [MPa]”).

Il file deve essere posizionato nella cartella “data” del programma e deve avere estensione*.nfm.


4.2. Librerie di sezioni

La libreria di sezioni trasversali può essere ampliata scrivendo un file CSV (con separatore “;”), come nell’esempio seguente:

Name;Code;h [mm];b [mm];tw [mm];tf [mm];r [mm];A [cm^2];Jy [cm4];Wey [cm^3];Wpy [cm^3];iy [cm];Avz [cm^2];Jz [cm^4];Wez [cm^3];Wpz [cm^3];iz [cm]

IPE A 80;UNI;78;46;3.3;4.2;5;6.375401837;64.37774091;16.50711305;18.97743881;3.177708713;3.070001837;6.852668856;2.979421242;4.692462888;1.036754887

…

Le prime 4 colonne sono obbligatorie.

Le colonne supportate nativamente sono:

-   h: altezza

-   b: base

-   d: diametro

-   t: spessore (in sezioni circolari cave)

-   tw: spessore dell’anima

-   tf: spessore dell’ala

-   A: area sezione

-   Jz: momento d’inerzia lungo l’asse orizzontale

-   Jy: momento d’inerzia lungo l’asse verticale

-   Wez: modulo di resistenza elastico secondo l’asse orizzontale

-   Wey: modulo di resistenza elastico secondo l’asse verticale

-   Wpz: modulo di resistenza plastico secondo l’asse orizzontale

-   Wpy: modulo di resistenza plastico secondo l’asse verticale

-   Avz: area a taglio secondo l’asse z locale (orizzontale)

-   Avy: area a taglio secondo l’asse y locale (verticale)

-   gap: distanza orizzontale per sezioni doppie (doppio L o doppio C)

Il nome della proprietà può essere seguito da parentesi quadre contenenti l’unità di misura (es. “h [cm]”).

La colonna Type specifica la forma della sezione. Inserire:

-   0 per sconosciuta o generica

-   1 per rettangolare

-   2 per circolare

-   3 per sezioni a C

-   4 per sezioni a T

-   5 per sezioni a doppio T o I

-   6 per sezioni a L

-   7 per sezioni scatolari

-   8 per sezioni circolari cave

-   9 per sezioni a doppio L

-   10 per sezioni a doppio C

Il file deve essere posizionato nella cartella “data” del programma e deve avere estensione*.nfs.


4.3. Librerie di sezioni per punti

Le sezioni per punti possono essere inserite in un file di testo *.nfs alla stregua del precedente, ma con i seguenti campi:

Name;Code;PointsXf1 [mm];PointsYf1 [mm];PointsXe2 [mm];PointsYe2 [mm];PointsXf3 [mm];PointsYf3 [mm];Class;OffsetX [mm];OffsetY [mm];alphaLT;alphay;alphaz;Jw [mm^4]

TestSect;custom;0,20,20,0;0,0,20,20;4,8,8,4;4,4,8,8;0;0;3;0;0;0.76;0.76;0.76;0

…

Le prime 2 colonne sono obbligatorie e il valore di Code deve essere “custom” per ogni sezione. Le serie di punti possono essere quante necessarie, seguendo questa codifica per i nomi delle coppie di colonne:

PointsXpN [units];PointsYpN [units];

in cui p è uguale a “f” per figure piene, “e” per vuoti; N è il numero progressivo della serie, unico per pieni e vuoti. Tutte le colonne in coda agli offset per il baricentro sono inserite come valori custom (es. alphaLT;alphay;alphaz;Jw).


4.4. Verifiche personalizzate

E’ possibile personalizzare le verifiche svolte dal programma mediante un semplice linguaggio di scrittura delle formule da utilizzare. Il file di testo contenente le verifiche può essere copiato nella cartella “verification” presente nella directory di installazione del programma e deve avere estensione “.nvv” (si veda ad esempio trusses.nvv).

Questi file possono essere editati con:

- Notepad++ con il settaggio per l’evidenziazione della sintassi che è presente nella cartella “verification” (file NextFEMVerifications.xml);

- Visual Studio Code con il plugin Custom Coloring per l’evidenziazione della sintassi. I settaggi per questo plugin sono contenuti in NextFEMverification_vsCode.json sempre nella cartella “verification”.

Il motore di verifica supporta l’esecuzione a blocchi di istruzioni. Ogni blocco è delimitato dagli identificatori come nell’esempio seguente e deve essere chiamato con un numero con la virgola (es 0.6).

$$0.6

# questo è un commento

execif(SecType==1,1.0)

$!

Per richiamare i blocchi sono disponibili le seguenti parole chiave:

-    exec(0.6) : esegue il blocco di codice 0.6

-    execif(condizione, 0.6): esegue il blocco 0.6 se la condizione si verifica

-    execwhile(condizione, 0.6): esegue il blocco 0.6 fino a che condizione è vera. La variabile exitdo pari a 1 all’interno del blocco provoca l’uscita dal ciclo. Massimo 10000 cicli.

Le formule possono essere scritte con i seguenti operatori:

Addizione: +

Sottrazione: -

Moltiplicazione: *

Divisione: /

Modulo: %

Esponenziazione: ^

Minore: <

Minore o uguale: <= or ≤

Maggiore: >

Maggiore o uguale: >= or ≥

Uguale (nei confronti): ==

Diverso: != or ≠

Seno: sin

Coseno: cos

Arcoseno: asin

Arcocoseno:acos

Tangente: tan

Cotangente: cot

Arcotangente: atan

Arcocotangente: acot

Logaritmo naturale: loge

Logaritmo in base 10: log10

Logaritmo in base n: logn

Radice quadrata: sqrt

Istruzione condizionale: if(var<var2,1,0)

Operatore booleano: and(cond1,cond2)

Operatore booleano: or(cond1,cond2)

Operatore booleano: not(cond)

Le seguenti keyword non possono essere utilizzate poiché riservate:

-   ID per numero nodo o elemento

-   Case_Time per indicare il caso di carico e il tempo.

Le variabili disponibili sono:

-    Gestione unità di misura

o    unitconv: converte le unità di misura. Uso: unitconv(oldUnits,newUnits,Value).
Esempio: Eps=sqrt(235/unitconv(model_S,MPa,fk))
converte fk dalle unità di misura della tensione nel modello a MPa

o    rcsect: calcola i momenti resistenti di una sezione assegnata, memorizzandoli in Mry e Mrz. Uso: rcsect(N,Myy,Mzz)

o    skipItem: se =1, salta le verifiche successive. Da utilizzarsi solo nelle verifiche eseguite per casi di carico con sviluppo temporale (es. dinamiche lineari)

o    model_L: segnaposto per le unità di lunghezza del modello

o    model_F: segnaposto per le unità di forza del modello

o    model_FL: segnaposto per le unità di forza per lunghezza del modello

o    model_T: segnaposto per le unità di temperatura del modello

o    model_M: segnaposto per le unità di massa del modello

o    model_S: segnaposto per le unità di tensione/pressione del modello

o    isVarDefined(var): controlla se una variabile è già definita (1) oppure no (0)

o    Halt: ferma l’esecuzione

o    addUtable: aggiunte una tabella utente e restituisce l’ID della tabella. Utilizzo:
addUtable(numColonne, intestazioniColonne, dati per riga incluse intestazioni righe)
Esempio: tid=addUtable(3,1,2,3,100,4,5,6,101,7,8,9,102,10,11,12,103,13,14,15)
aggiunge la seguente tabella:

 | 1 | 2 | 3
100 | 4 | 5 | 6
101 | 7 | 8 | 9
102 | 10 | 11 | 12
103 | 13 | 14 | 15

o    UtableAt: restituisce il valore in i, j di una tabella. Gli indici i e j partono da 1. Torna 0 in caso di errore o di indici non interi. Utilizzo: UtableAt(ID tabella,i,j)

o    UtableInterpValues: fornisce l’interpolazione bilineare in tabella. Utilizzo: result=UtableInterpValues(ID tabella, valore su intestazione righe, valore su intestazione colonne)
Esempio: res1=UtableInterpValues(tid,101.3,2.5) fornisce il valore 9.4.

o    addRebar: aggiunge barre longitudinali all’elemento corrente.
La funzione torna 0 in caso di errore o se il materiale di progetto indicato non è stato trovato.
Utilizzo: addRebar(zCoord, yCoord, areaBarra, ID materiale di design, iniziaA [0,1), finisceA (0,1].
Esempio: addRebarL(40,40,201.0,2,0,1)
aggiunge una barra di area 201.0 alla posizione 40, 40 dall’angolo in basso a sinistra della sezione, per l’intero elemento.

o    addStirrups: aggiunge le staffe all’elemento corrente.
La funzione torna 0 in caso di errore o se il materiale di progetto indicato non è stato trovato.
Utilizzo: addStirrups(braccia in Y, braccia in Z, area singola barra, interasse, ID materiale di design, iniziaA [0,1), finisceA (0,1] ).
Esempio: addStirrups(2, 2, 50.0, 200, 2, 0,1)
aggiunge staffe a 2 braccia nelle 2 direzioni, ognuna di area 50.0 e interasse 200, per l’intero elemento.

o    cleanRebar: pulisce tutte le barre, incluse staffe, nell’elemento corrente. Tutti i conci di definizione dell’armatura sono eliminati.

o    getBarDiam: fornisce il diametro minimo di una barra longitudinale richiesto per soddisfare una data area. L’output è in mm. Esempio: getBarDiam(2.01) # per un modello in cm, torna 16.

o    getStirrupDiam: fornisce il diametro minimo richiesto per una staffa per soddisfare una data area. L’output è in mm. Esempio: getStirrupDiam(0.5) # per un modello in cm, torna 8.

o    TranslateMomentZZ: fornisce i valori minimi e massimi del momento flettente attorno all’asse locale z per la posizione data, traslati di una quantità delta. Sintassi: TranslateMomentZZ(position, delta). L’argomento position è fornito automaticamente nel set di dati per elementi nella variabile pos. La funzione crea o sovrascrive le variabili Mzzmax e Mzzmin.

o    TranslateMomentYY: fornisce i valori minimi e massimi del momento flettente attorno all’asse locale y per la posizione data, traslati di una quantità delta. Sintassi: TranslateMomentYY(position, delta). L’argomento position è fornito automaticamente nel set di dati per elementi nella variabile pos. La funzione crea o sovrascrive le variabili Myymax e Myymin.

o    FireSectionStrength: carica la mappa termica di una sezione e la usa per calcolare la sua resistenza. È disponibile all’interno del modulo FireSafe. Il nome del file contenente i risultati dell’analisi termica della sezione deve essere memorizzato nelle proprietà dell’elemento alla voce “fireSect”. Sintassi: FireSectionStrength(station,N,Myy,Mzz). L’argomento station è la stazione di verifica, tipicamente da 1 a 5.

o    round: arrotonda un numero in virgola mobile ad un intero. Es. round(12.6) torna 13.0.

o    ceil: arrotonda per eccesso un numero in virgola mobile. Es. ceil(12.3) torna 13.0.

o    floor: arrotonda per difetto un numero in virgola mobile. Es. floor(12.6) torna 12.0.

-    Set di dati generali

o    ServType: indica se la combinazione di servizio corrente è caratteristica (rara) (1), frequente (2) o quasi permanente (3). Il valore è pari a 0 se la combinazione non è di servizio.

o    Seismic: indica se la combinazione corrente è sismica (1) oppure no (0). Il valore di 1 è sempre associato a ServType = 0.

o    time: istante di tempo corrente

-    Set di dati per elementi

o    A: Area

o    Jz: inerzia rispetto all’asse z della sezione

o    Jy: inerzia rispetto all’asse y della sezione

o    Jt: inerzia torsionale

o    D: diametro esterno sezione

o    b: base della sezione per tutte le sezioni generiche

o    h: altezza della sezione per tutte le sezioni generiche

o    tw: spessore dell’anima

o    tf1: spessore della flangia inferiore

o    tf2: spessore della flangia superiore

o    t: spessore delle sezioni per elementi piani

o    N: forza assiale di una trave nella sezione di verifica

o    Vy: Taglio lungo y di una trave nella sezione di verifica

o    Vz: Taglio lungo z di una trave nella sezione di verifica

o    Mt: Momento torcente di una trave nella sezione di verifica

o    Myy: Momento attorno all’asse y di una trave nella sezione di verifica

o    Mzz: Momento attorno all’asse z di una trave nella sezione di verifica

o    rMyIJ: rapporto fra momento Myy all’estremo I e all’estremo J della trave

o    rMzIJ: rapporto fra momento Mzz all’estremo I e all’estremo J della trave

o    MmaxY: momento massimo attorno all’asse y locale per tutto l’elemento o membratura

o    MmaxZ: momento massimo attorno all’asse z locale per tutto l’elemento o membratura

o    MminY: momento minimo attorno all’asse y locale per tutto l’elemento o membratura

o    MminZ: momento minimo attorno all’asse z locale per tutto l’elemento o membratura

o    Em: modulo di Young del materiale

o    Gm: modulo di taglio del materiale

o    NIm: coefficiente di Poisson del materiale

o    fk: resistenza caratteristica del materiale

o    WelZ: modulo resistente in direzione z

o    WelY: modulo resistente in direzione y

o    WplZ: modulo resistente plastico in direzione z

o    WplY: modulo resistente plastico in direzione y

o    iz: raggio d’inerzia per l’asse z

o    iy: raggio d’inerzia per l’asse y

o    imin: raggio d’inerzia minimo

o    SecType: 1=trave/asta, 2=piana, 0=sconosciuta

o    SecBeamType: 0=per punti, 1=rettangolare, 2=circolare, 3=a C, 4=a T, 5=doppio T, 6=a L, 7=rettangolare cava, 8=circolare cava

o    MatType: tipo di materiale. Acciaio 1, Alluminio 2, Calcestruzzo 3, Legno 4, Muratura 5, Fragile in trazione 6, sconosciuto 0.

o    dx: spostamento relativo lungo l’asse della trave

o    dy: deflessione trasversale nella direzione locale y

o    dz: deflessione trasversale nella direzione locale z

o    L0yy: luce libera d’inflessione per flessione attorno all’asse y locale

o    L0zz: luce libera d’inflessione per flessione attorno all’asse z locale

o    L0: massima luce libera di inflessione fra L0yy e L0zz

o    pos: posizione della sezione di verifica dall’origine delle trave, in unità di misura del modello

o    LvyI: luce di taglio misurata da estremo I, rapporto Myy/Vz in stazione 1

o    LvyJ: luce di taglio misurata da estremo J, rapporto Myy/Vz in stazione 5

o    LvzI: luce di taglio misurata da estremo I, rapporto Mzz/Vy in stazione 1

o    LvzJ: luce di taglio misurata da estremo J, rapporto Mzz/Vy in stazione 5

o    fxx: forza in direzione locale x (centroide elemento)

o    fyy: forza in direzione locale y (centroide elemento)

o    fxy: forza in direzione xy (centroide elemento)

o    fzz: forza in direzione locale z (centroide elemento)

o    fxz: forza in direzione xz (centroide elemento)

o    fyz: forza in direzione yz (centroide elemento)

o    mmxx: momento attorno a x locale (centroide elemento)

o    mmyy: momento attorno a y locale (centroide elemento)

o    mmxy: momento attorno a xy (centroide elemento)

o    mmzz: momento attorno a z locale (centroide elemento)

o    mmxz: momento attorno a xz locale

o    mmyz: momento attorno a yz locale

o    time: tempo al passo corrente

o    temp: temperatura media dell’elemento al passo corrente

o    isWall: se un gruppo wall è definito per l’elemento piano corrente torna 1, altrimenti 0.

o    Column: se l’elemento trave corrente è verticale torna 1, altrimenti 0. Non è definito per altri tipi di elementi.

-    Set di dati per risultati nodali

o    dx: spostamento nodale in direzione X

o    dy: spostamento nodale in direzione Y

o    dz: spostamento nodale in direzione Z

o    rx: rotazione nodale attorno a X

o    ry: rotazione nodale attorno a Y

o    rz: rotazione nodale attorno a Z

o    vx: velocità nodale in direzione X

o    vy: velocità nodale in direzione Y

o    vz: velocità nodale in direzione Z

o    vrx: velocità nodale attorno a X

o    vry: velocità nodale attorno a Y

o    vrz: velocità nodale attorno a Z

o    ax: accelerazione nodale in direzione X

o    ay: accelerazione nodale in direzione Y

o    az: accelerazione nodale in direzione Z

o    arx: accelerazione nodale attorno a X

o    ary: accelerazione nodale attorno a Y

o    arz: accelerazione nodale attorno a Z

o    Rex: reazione nodale in direzione X

o    Rey: reazione nodale in direzione Y

o    Rez: reazione nodale in direzione Z

o    Rerx: reazione nodale attorno a X

o    Rery: reazione nodale attorno a Y

o    Rerz: reazione nodale attorno a Z

o    sxx: stress nodale in direzione X

o    syy: stress nodale in direzione Y

o    sxy: stress di taglio in direzione XY

o    szz: stress nodale in direzione Z

o    sxz: stress di taglio in direzione XZ

o    syx: stress di taglio in direzione YZ

o    fxx: forza nodale in direzione X

o    fyy: forza nodale in direzione Y

o    fxy: forza nodale in direzione XY

o    fzz: forza nodale in direzione Z

o    fxz: forza nodale in direzione XZ

o    fyz: forza nodale in direzione YZ

o    mxx: momento nodale attorno a X

o    myy: momento nodale attorno a Y

o    mxy: momento nodale attorno a XY

o    mzz: momento nodale attorno a Z

o    mxz: momento nodale attorno a XZ

o    myz: momento nodale attorno a YZ

o    time: tempo al passo corrente

o    temp: temperatura nodale al passo corrente.


5. Validazione ed esempi

5.


5.1. Tutorial Uno

Questo primo tutorial mostra come modellare una trave di 5 metri di lunghezza, caricata con carichi concentrati in mezzeria nelle 3 direzioni. I risultati del programma (spostamenti e sollecitazioni) sono confrontati con un calcolo condotto manualmente.

*    AVVISO: sia la deformabilità flessionale che tagliante sono state considerate. Per abilitare questo opzioni, cliccare su Strumenti>Opzioni>Solutore e abilitare Considera deformazione tagliante negli elementi beam nel box Opzioni per OOFEM.

Per creare il modello, eseguire le seguenti operazioni:

1. Settare le Unità di misura: N per la forza e mm per la lunghezza.

2. Definire le proprietà del materiale:

o    Nome: Concrete;

o    E=30000 N/mm2;

o    =0.3

o    fk=25 N/mm

o    Peso specifico=2.5e-5 N/mm3;

o    Densità di massa=2.55e-9 N/mm2/g

3. Definire le proprietà della sezione:

o    b=300 mm (direzione z);

o    h=500mm (direzione y);

4. Definire i casi di carico: viene considerato solo un caso di carico denominato Qk1

5.

6. Inserire la geometria utilizzando Nodo per coordinate:

o    L=5000 mm;

o    Distanza dagli estremi del nodo in mezzeria=2500 mm;

7. Inserire i 2 elementi trave necessari tramite il comando Trave.

8. Assegnare le condizioni di vincolo ai nodi estremi mediante il comando Assegna/Vincoli: incastrare i nodi 1 e 3.

9. Assegnare il materiale utilizzando il comando Assegna>Materiale. Selezionare la trave e cliccare su Assegna agli elementi selezionati

10. Assegnare la sezione utilizzando il comando Assegna>Sezione. Selezionare la trave e cliccare su Assegna

11. Assegnare un carico concentrato al nodo 2 con il comando Assegna/Carichi/Carico puntuale.

o    Px=10000 N;

o    Py=10000 N;

o    Pz=-10000 N.

12. Lanciare l’analisi con il pulsante Lancia.

-    Risultati di NextFEM Designer:

o    Spostamento in direzione x: Nodo 2=0.002778mm

o    Spostamento in direzione y: Nodo 2=0.2016mm

o    Spostamento in direzione z: Nodo 2=-0.00781 mm

o    Diagramma del momento: valori da Risultati>Estrai dati

§    Mzz

§    Myy

o    Diagramma del taglio:

§    Vy

§    Vz

o    Diagramma dell’azione assiale:

-    Calcolo manuale:

o    Proprietà della sezione

o    Diagramma dei momenti:

§    Mzz

;

§    Myy

;

o    Diagramma del taglio:

§    Vy

;

§    Vz

;

o    Diagramma dell’azione assiale:

;

o    Spostamento in direzione x: Nodo 2

o    Spostamento in direzione y: Nodo 2

o    Spostamento in direzione z: Nodo 2


5.2. Tutorial Due

Il secondo tutorial consiste in una trave a mensola con carichi in direzioni y e z. I risultati del programma (spostamenti e sollecitazioni) sono confrontati con un calcolo condotto manualmente.

Solo la deformabilità flessionale delle travi viene considerata.

-    Unità: N per la forza e mm per la lunghezza.

-    Proprietà del materiale:

o    Nome: Concrete;

o    E=30000 N/mm2;

o    =0.3

o    fk=25 N/mm

o    Peso specifico =2.5e-5 N/mm3;

o    Densità di massa =2.55e-9 N/mm2/g

-    Proprietà della sezione:

o    B=300 mm (z);

o    H=500mm (y);

-    Geometria:

o    L=2500 mm;

-    Carichi:

o    Py=5000 N;

o    Pz=-10000 N.

-    Risultati del programma:

o    Spostamento in direzione x: Nodo 2=0.00mm

o    Spostamento in direzione y: Nodo 2=0.7716mm

o    Spostamento in direzione z: Nodo 2=-0.5556mm

o    Diagramma del momento: valori da Risultati>Estrai dati

§    Mzz

§    Myy

o    Diagramma del taglio:

§    Vy

§    Vz

-    Calcolo manuale:

o    Diagramma dei momenti:

§    Mzz

;

§    Myy

o    Diagramma del taglio:

§    Vy

;

§    Vz

;

o    Diagramma dell’azione assiale:

;

o    Spostamento in direzione x: Nodo 2

o    Spostamento in direzione y: Nodo 2

o    Spostamento in direzione z: Nodo 2


5.3. Tutorial Tre

Il secondo tutorial consiste in una trave a mensola con carichi in direzioni y e z modellata con elementi shell (conformi alla teoria di Mindlin-Reissner). I risultati del programma (spostamenti e sollecitazioni) sono confrontati con un calcolo condotto manualmente.

Solo la deformabilità flessionale delle travi viene considerata.

-    Unità: N per la forza e mm per la lunghezza.

-    Proprietà del materiale:

o    Nome: Concrete;

o    E=30000 N/mm2;

o    =0.3

o    fk=25 N/mm

o    Peso specifico =2.5^10-5 N/mm3;

o    Densità di massa =2.55^10-9 N/mm2/g

-    Proprietà della sezione:

o    Sezione piana di 300mm di spessore;

-    Geometria:

o    L=5000 mm;

-    Carichi:

o    Py=5000 N;

o    Pz=10000 N;

-    Dimensione della mesh: 250x250 mm

-    Risultati del programma:

o    Spostamento in direzione x: Nodo 2=0.00mm

o    Spostamento in direzione y: Nodo 2=0.6250 mm

o    Spostamento in direzione z: Nodo 2=-0.5062mm

-    Calcolo manuale (vedi tutorial Due):

o    Spostamento in direzione y:

§    Calcolo manuale: 0.77160mm

§    NextFEM designer: 0.6250mm

§    Differenza: 19%

o    Spostamento in direzione z:

§    Calcolo manuale: -0.5556mm

§    NextFEM designer: -0.5062mm

§    Differenza: 9%

La differenza rilevata è dovuta al cambio di elementi e alla dimensione della mesh.


5.4. Tutorial Quattro

Il quarto tutorial consiste in una trave a mensola con carichi distribuiti in direzioni x, y e z. I risultati del programma (spostamenti e sollecitazioni) sono confrontati con un calcolo condotto manualmente.

Solo la deformabilità flessionale delle travi viene considerata.

-    Unità: N per la forza e mm per la lunghezza.

-    Proprietà del materiale:

o    Nome: Concrete;

o    E=30000 N/mm2;

o    =0.3

o    fk=25 N/mm

o    Peso specifico =2.5^10-5 N/mm3;

o    Densità di massa =2.55^10-9 N/mm2/g

-    Section properties:

o    B=300 mm (y direction);

o    H=500mm (z direction);

-    Proprietà della sezione:

o    B=300 mm (z);

o    H=500mm (y);

-    Geometria:

o    L=5000 mm;

-    Carichi:

o    qy=1 N/mm;

o    qz=-1 N/mm;

o    qx=-1 N/mm.

-    Risultati del programma:

o    Spostamento in direzione x: Nodo 6=-0.00278mm

o    Spostamento in direzione y: Nodo 6=2.315mm

o    Spostamento in direzione z: Nodo 6=-0.8333mm

o    Diagramma del momento: valori da Risultati>Estrai dati

§    Mzz max: nodo 1: 125e9 Nmm

§    Myy max: nodo 1: 125e9 Nmm

o    Diagramma del taglio:

§    Vy

§    Vz

-    Calcolo manuale:

o    Diagramma dei momenti:

§    Mzz

;

§    Myy

;

o    Diagramma del taglio:

§    Vy

;

§    Vz

;

o    Diagramma dell’azione assiale:

;

o    Spostamento massimo in direzione x: Nodo 6

o    Spostamento massimo in direzione y: Nodo 6

o    Spostamento massimo in direzione z: Nodo 6


5.5. Tutorial Cinque

Il quinto tutorial consiste in un’analisi modale di un edificio a telaio in legno. I risultati del programma (autovalori) sono confrontati con quelli forniti da programma di calcolo SAP2000®.

Solo la deformabilità flessionale delle travi viene considerata.

-    Unità: N per la forza e mm per la lunghezza.

-    Proprietà del materiale:

o    Nome: GL24H;

o    E=9.40^10+6 kN/m2;

o    =0.3

o    Peso specifico =3.8 kN/m3;

o    Densità di massa =0 kN/m3/g

-    Proprietà della sezione:

o    B=300 mm (z);

o    H=500mm (y);

-    Geometria:

o    Lx=3 m;

o    Ly=4m;

o    Lz=2m;

-    Masse concentrate: in ogni nodo del primo impalcato

o    my=2.5 kN/g;

o    mz=-2.5 kN/g;

o    mx=-2.5 kN/g

-    Risultati del programma:

o    Primo modo:

o    Secondo modo:

o    Terzo modo:

-    Risultati da SAP2000® :

o    Primo modo:

o    Secondo modo:

o    Terzo modo:

Nessuna differenza significativa rilevata.


5.6. Tutorial Sei

Il sesto tutorial consiste in un’analisi con spettro di risposta di un edificio a telaio in legno, illustrato nel tutorial cinque.

Lo spettro utilizzato è generato secondo l’Eurocodice 8, tipo 1, dalla maschera Funzioni, su suolo A e con PGA pari a 0.35g.

L’analisi dinamica lineare con spettro di risposta viene eseguita separatamente per le direzioni X, Y e Z.

AVVISO: Tutti i risultati forniti dal programma per un caso di carico ResponseSpectrum vanno interpretati a meno del segno.


5.7. Tutorial Sette

Il sesto tutorial consiste in un’analisi di buckling di una colonna in calcestruzzo in configurazione appoggio-carrello. I risultati del programma (autovalori ovvero moltiplicatori di carico) sono confrontati con i risultati calcolati con la teoria euleriana della stabilità. La colonna è suddivisa in 5 elementi di eguale lunghezza.

Solo la deformabilità flessionale delle travi viene considerata.

-    Unità: N per la forza e mm per la lunghezza.

-    Proprietà del materiale:

o    Nome: C25/30;

o    E=3.15e+6 kN/m2;

o    =0.2

o    Peso specifico =25 kN/m3;

o    Densità di massa =2.5 kN/m3/g

-    Proprietà della sezione:

o    B=100 mm (z);

o    H=200 mm (y);

-    Geometria:

o    Ltot=3.0 m;

-    Carichi:

o    Qz=-1 kN;

-    Risultati del programma:

o    Primo modo:

o    Secondo modo:

o    Terzo modo:

o    Quarto modo:

o    Quinto modo:

-    Calcolo manuale:

o    Il carico critico è calcolato come [image] con [image] , e J della direzione di inflessione.

o    Inerzia della sezione:

o    Risultati teorici:

Flessione yy | Flessione zz

La soluzione data dal programma è in accordo coi risultati teorici.


6. Termini di licenza

CONTRATTO DI LICENZA D'USO SOFTWARE

Utilizzando i software forniti da NextFEM SRLS, si accettano i seguenti termini e condizioni. I contenuti del sito NextFEM e del software fornito, inclusi i seguenti termini di licenza, possono essere soggetti a modifiche e/o aggiornamenti in qualsiasi momento. Utilizzando i software prodotti da NextFEM SRLS o il nostro sito, si accetta l'informativa sulla privacy di NextFEM SRLS, pubblicata su https://www.nextfem.it/it/privacy-policy/ .

Art. 1 - Licenza d'uso -

1. Ai termini ed alle condizioni che seguono, NextFEM SRLS in persona del legale rappresentante in carica pro tempore (di seguito indicato anche come “Azienda” o “Licenziante”) concede in licenza d'uso al Cliente (di seguito indicato anche come “Utente” o “Licenziatario”) i software (di seguito indicati anche come “Programma” o “Programmi”), per sistema operativo Windows®, prodotti da NextFEM SRLS corredati dalla documentazione d'uso. La licenza così fornita è non esclusiva e non cedibile a qualunque titolo.

2. Il presente contratto non trasferisce al Licenziatario il codice sorgente del software licenziato né la relativa documentazione logica e/o di progetto.

Art. 2 - Durata - Risoluzione del contratto -

1. Il presente contratto ha durata annuale decorrente dalla ricezione della licenza. Al termine dell’annualità, il presente contratto si intenderà automaticamente risolto, salvo richiesta di rinnovo da comunicarsi da parte del Cliente a NextFEM SRLS inviata a mezzo email all'indirizzo licensing@nextfem.it almeno 30 giorni prima della scadenza della licenza, o salvo acquisto del rinnovo da parte del Cliente. Condizioni differenti potrebbero applicarsi per le licenze Educational.

2. È fatto salvo il diritto di NextFEM SRLS di risolvere anticipatamente il presente contratto per dolo e/o colpa grave del Cliente e/o per violazione delle norme del presente contratto, e ciò facendo mediante comunicazione scritta da inviarsi a mezzo email all'indirizzo fornito dal Cliente in sede di registrazione al sito. È fatto salvo in ogni caso il diritto del Licenziante al risarcimento di ogni danno.

Art. 3 - Consegna della licenza -

1. I software prodotti da NextFEM SRLS e disponibili gratuitamente vengono scaricati autonomamente dal Cliente dal sito nextfem.it.

2. I software prodotti da NextFEM SRLS e disponibili a pagamento vengono scaricati autonomamente dal Cliente dal sito nextfem.it. La richiesta di licenza viene evasa dal Licenziante nel termine indicativo e non vincolante di giorni 7 dalla data di ricezione del pagamento. Condizioni differenti potrebbero applicarsi per le licenze Educational.

3. In ogni caso NextFEM SRLS non risponde di eventuali danni derivanti direttamente o indirettamente da ritardi non dipendenti dalla propria volontà nel rilascio della licenza.

Art. 4 – Installazione -

1. I software prodotti da NextFEM SRLS sono auto-installanti. Esaurita positivamente la fase d'installazione, i software si considereranno accettati dal Cliente.

2. Ogni ulteriore prestazione (a mero titolo esemplificativo e non esaustivo, installazione, verifica, assistenza richiesta dal Cliente per consentire ai suoi dipendenti di utilizzare i software prodotti da NextFEM SRLS) sarà effettuata da NextFEM SRLS a seguito di richiesta del Cliente ed in ogni caso a seguito di formulazione di preventivo da parte di NextFEM SRLS e relativa accettazione da parte del Cliente.

3. E’ responsabilità esclusiva del Cliente assicurarsi che la propria dotazione informatica (hardware e software) rispetti i requisiti minimi e indispensabili per l’installazione ed il funzionamento dei software prodotti da NextFEM SRLS, quale indicata nel manuale d'uso all'uopo fornito.

Art. 5 - Utilizzazione dei programmi -

1. Il Cliente ha l'obbligo di usare i software prodotti da NextFEM SRLS per fini leciti e legali.

2. Il Cliente si impegna a non rimuovere o alterare alcun marchio, numero di serie o altre indicazioni di riserva di diritti apposti o inseriti nei software prodotti da NextFEM SRLS, e ciò anche dopo la risoluzione o cessazione a qualunque titolo del presente Contratto.

3. In conformità a quanto prescritto dagli artt. 64 ter L. 22 aprile 1941, n. 633 e ss.mm.ii. e art. 5 par. 2 Direttiva 2009/24/CE del 23.4.2009 e ss.mm.ii., è consentito al Cliente licenziatario che ha il diritto di usare una copia dei software prodotti da NextFEM SRLS di effettuare una copia di riserva di detti software e della documentazione a corredo, qualora tale copia sia necessaria per l'uso.

4. In conformità a quanto prescritto dagli art. 64 bis, lett. a) e b), 64 ter, L. 22 aprile 1941, n. 633 e ss.mm.ii. e art. 4, par. 1, lett a) e b), 5, Direttiva 2009/24/CE del 23.4.2009 e ss.mm.ii., è fatto espresso divieto al Cliente di riprodurre, in modo permanente o temporaneo, totale o parziale, i software prodotti da NextFEM SRLS e la documentazione a corredo, con qualsiasi mezzo o in qualsiasi forma, senza la previa autorizzazione di NextFEM SRLS. Nella misura in cui operazioni quali il caricamento, la visualizzazione, l'esecuzione, la trasmissione o la memorizzazione dei software predetti richiedano una riproduzione, anche tali operazioni sono soggette all'autorizzazione del titolare dei diritti. Alle stesse condizioni e con le stesse limitazioni, è parimenti fatto espresso divieto al Cliente di effettuare la traduzione, l'adattamento, la trasformazione e ogni altra modificazione dei software prodotti da NextFEM SRLS e la documentazione a corredo, nonché la riproduzione dell'opera che ne risulti, senza pregiudizio dei diritti di chi modifica il programma.

5. Gli atti di cui ai precedenti punti 2 e 3, anche nell'ipotesi in cui siano necessari per l'uso dei software predetti conformemente alla loro destinazione da parte del legittimo Licenziatario, ivi inclusa la correzione degli errori, sono soggetti all'autorizzazione del titolare del diritto.

6. In conformità a quanto prescritto dagli artt. 64 ter, co.3 L. 22 aprile 1941, n. 633 e ss.mm.ii. e art. 5 par. 3 Direttiva 2009/24/CE del 23.4.2009 e ss.mm.ii., è consentito al Cliente osservare, studiare o sottoporre a prova il funzionamento dei software prodotti da NextFEM SRLS e di cui detiene la licenza, allo scopo di determinare le idee ed i princìpi su cui è basato ogni elemento dei programmi stessi, qualora egli compia tali atti durante operazioni di caricamento, visualizzazione, esecuzione, trasmissione o memorizzazione del programma che egli ha il diritto di eseguire.

7. In conformità a quanto prescritto dall'art. 64 quater, L. 22 aprile 1941, n. 633 e ss.mm.ii. e art. 6 Direttiva 2009/24/CE del 23.4.2009 e ss.mm.ii., non è necessaria la previa autorizzazione da parte di NextFEM SRLS, qualora la riproduzione del codice del programma di elaboratore e la traduzione della sua forma ai sensi dell'art. 64-bis, lett. a) e b) L. 22 aprile 1941, n. 633 e ss.mm.ii. e art. 4, par.1, lett. a) e b) Direttiva 2009/24/CE del 23.4.2009 e ss.mm.ii., sono compiute al fine di modificare la forma del codice e siano indispensabili per ottenere le informazioni necessarie per conseguire l'interoperabilità con altri programmi di un programma per elaboratore creato autonomamente, purché siano soddisfatte le seguenti condizioni:

a) le predette attività siano eseguite dal Licenziatario o da altri che abbia il diritto di usare una copia del programma oppure, per loro conto, da chi è autorizzato a tal fine;

b) le informazioni necessarie per conseguire l'interoperabilità non siano già facilmente e rapidamente accessibili ai soggetti indicati alla lettera a);

c) le predette attività siano limitate alle parti del programma originale necessarie per conseguire l'interoperabilità.

8. Le disposizioni di cui al precedente comma 7 non consentono che le informazioni ottenute in virtù della loro applicazione:

a) siano utilizzate a fini diversi dal conseguimento dell'interoperabilità del programma creato autonomamente;

b) siano comunicate a terzi, fatta salva la necessità di consentire l'interoperabilità del programma creato autonomamente;

c) siano utilizzate per lo sviluppo, la produzione o la commercializzazione di un programma per elaboratore sostanzialmente simile nella sua forma espressiva, o per ogni altra attività che violi il diritto di autore.

9. Conformemente alla convenzione di Berna sulla tutela delle opere letterarie ed artistiche ratificata e resa esecutiva con legge 20 giugno 1978, n. 399 e ss.mm.ii., le disposizioni dell'art. 64 quater, L. 22 aprile 1941, n. 633 e ss.mm.ii e art. 6 Direttiva 2009/24/CE del 23.4.2009 e ss.mm.ii. qui richiamati non possono essere interpretate in modo da consentire che la loro applicazione arrechi indebitamente pregiudizio agli interessi legittimi del titolare dei diritti o sia in conflitto con il normale sfruttamento del programma.

Art. 6 – Proprietà - Divieto di cessione -

1. I software prodotti da NextFEM SRLS e la documentazione a corredo degli stessi rimangono di esclusiva proprietà di NextFEM SRLS. È fatto espresso divieto al Cliente di distribuire i prodotti di NextFEM SRLS o loro copie al pubblico ovvero di cederli o darli in sublicenza a terzi o in locazione, o comunque di consentirne l'uso da parte di terzi, sia a titolo gratuito che a titolo oneroso. In tali ipotesi NextFEM SRLS può revocare la licenza d’uso del programma o di un suo modulo in qualsiasi momento.

2. La presente clausola resterà in vigore anche dopo la risoluzione o cessazione a qualunque titolo del presente Contratto.

Art. 7 – Titolare dei diritti - Segreto – Modifiche -

1. I software prodotti da NextFEM SRLS, la documentazione a corredo degli stessi, il codice di programma, l'aspetto, la struttura e l'organizzazione dei file di programma, il nome del programma, il logo della società e altre forme di rappresentazione all'interno del software sono soggetti a diritto d'autore; questo, e tutti i diritti derivanti e comunque connessi al diritto d'autore sono di proprietà di NextFEM SRLS. Altri marchi appartengono ai rispettivi produttori.

2. Il Cliente si obbliga a mantenere segreto il contenuto dei software prodotti da NextFEM SRLS e della documentazione ad essi relativa e a proteggere i diritti di NextFEM SRLS e dei suoi fornitori; in particolare si obbliga a non modificare i software prodotti da NextFEM SRLS né ad incorporarli in tutto o in parte in altri programmi senza la previa autorizzazione scritta di NextFEM SRLS, fatto salvo quanto previsto dalla normativa inderogabile vigente in materia. In tali ipotesi NextFEM SRLS può revocare la licenza d’uso del programma o di un suo modulo in qualsiasi momento.

3. La presente clausola resterà in vigore anche dopo la risoluzione o cessazione a qualunque titolo del presente Contratto.

Art. 8 – Canone – Solve et repete -

1. NextFEM SRLS fornisce i software “come sono” e non è obbligata a fornire manutenzione, supporto, aggiornamenti, miglioramenti o modifiche. Condizioni diverse potrebbero applicarsi per i moduli a pagamento e per le licenze Educational..

2. Per assicurare la continuità della licenza e dell’utilizzo dei moduli a pagamento, il Cliente dovrà corrispondere a NextFEM SRLS il relativo canone annuale almeno 15 giorni prima della scadenza della licenza in essere; qualora la tempistica non dovesse essere rispettata, NextFEM SRLS non può assicurare detta continuità, e potrà verificarsi il blocco dei moduli in licenza. Per nessuna ragione il pagamento del canone annuale dei software e/o dei singoli moduli che lo compongono e/o dei servizi richiesti potranno essere ritardati o sospesi; eventuali eccezioni o contestazioni del Cliente verranno separatamente trattate e risolte.

3. NextFEM SRLS fornisce l'aggiornamento del programma per un periodo di 12 (dodici) mesi a partire dalla data di consegna, limitatamente alle funzionalità del/dei modulo/moduli a pagamento. Durante questo periodo, i malfunzionamenti incontrati nell’uso del modulo a pagamento saranno corretti per assicurarne l’effettiva funzionalità. Tale garanzia non si applica alle funzionalità del programma al di fuori di quelle dei moduli a pagamento.

Art. 9 - Garanzia e responsabilità -

1. Sia per la versione base sia per quanto riguarda i moduli a pagamento, NextFEM SRLS fornisce il Software “come è” e non è obbligata in alcun modo a fornire manutenzione, supporto, aggiornamenti, miglioramenti o modifiche. Nell’arco della durata del contratto, potranno essere rilasciati eventuali aggiornamenti del software o patch.

2. NextFEM SRLS si impegna, limitatamente alle funzionalità dei moduli a pagamento, e per un periodo di 12 mesi dall'acquisto a mantenere i Software in grado di eseguire le operazioni indicate nel manuale d'uso. Durante questo periodo, i malfunzionamenti incontrati nell’uso dei moduli a pagamento saranno corretti per assicurarne l’effettiva funzionalità. Questa garanzia non si applica alle funzionalità del programma al di fuori di quelle dei moduli a pagamento, né alle licenze Educational, come megli specificato all'art. 14 del presente contratto.

3. La garanzia è condizionata al corretto funzionamento originario dell'elaboratore, dell'hardware e dei software di sistema del Cliente, alla sussistenza dei requisiti minimi richiesti per la corretta installazione dei software, nonché alla circostanza per cui il Cliente installi gli aggiornamenti e le patch che potranno essere messi a sua disposizione dal Licenziante tramite autonomo download effettuato dal sito internet nextfem.it, nonché al corretto uso del sistema e dei software da parte del Cliente.

4. Il Cliente è il solo responsabile della scelta dei software prodotti da NextFEM SRLS e della rispondenza di questi alle proprie esigenze e finalità di utilizzazione, di qualsiasi input inserito nei software e di qualsiasi output proveniente dal programma o da sue parti, e deve verificare risultati, report di calcolo e verifiche svolte.

5. I software prodotti da NextFEM SRLS corrispondono all'attuale stato di sviluppo, pertanto NextFEM SRLS non può garantire che il loro funzionamento sia sempre corretto con tutte le applicazioni e in tutte le situazioni.

6. Sono a carico del Cliente l’installazione, l’avviamento, l’uso dei software prodotti da NextFEM SRLS e dei relativi aggiornamenti e patch, il trasferimento degli stessi su computer, i settaggi, e tutto ciò che non è espressamente previsto nel presente Contratto a carico di NextFEM SRLS.

7. La presente garanzia viene meno in ogni caso quando il vizio del software derivi da incidente, uso inidoneo e non conforme o erronea applicazione. Qualsiasi eventuale modifica apportata direttamente dal Cliente al software determinerà il venir meno della garanzia.

8. NextFEM SRLS non è responsabile né risponde ad alcun titolo dei danni diretti e/o indiretti, speciali, collaterali, accidentali e/o conseguenti, compresa la perdita di profitto, comunque subiti dal Cliente o da terzi in dipendenza dall'uso o dal mancato uso dei software, e a qualunque titolo connessi e/o conseguenti ad eventuali vizi di qualità, adeguatezza, uso e utilizzabilità dei software, che restano pertanto ad esclusivo carico del Cliente, fatto salvo quanto inderogabilmente previsto dalla legge.

9. NextFEM SRLS non è responsabile né risponde ad alcun titolo per danni diretti e/o indiretti, speciali, collaterali, accidentali e/o conseguenti, compresa la perdita di profitto, comunque subiti dal Cliente o da terzi in dipendenza dall'uso o dal mancato uso dei software, e a qualunque titolo connessi e/o conseguenti ad eventuali vizi di qualità, adeguatezza, uso e utilizzabilità dei software, causati da propri fornitori o da porzioni di programma sviluppate da terze parti. A tali porzioni di programma sviluppate da terze parti si applicano le proprie condizioni di licenza, consultabili all’interno del software NextFEM dal comando ? / Informazioni su ….

Art. 10 - Restituzione dei programmi - Cancellazione dei software -

1. Entro un mese dalla risoluzione dal presente contratto per qualsiasi ragione, il Cliente si obbliga a cancellare o distruggere le eventuali copie, anche di backup, dei software in suo possesso, dandone conferma scritta a NextFEM SRLS nel medesimo termine.

2. Quale conseguenza della risoluzione del presente contratto indicata al comma precedente, la licenza d’uso viene revocata e non sarà più utilizzabile dal Cliente a qualsiasi scopo.

Art. 11 - Assistenza e/o consulenza -

1. A richiesta del Cliente, NextFEM SRLS si dichiara disponibile a prestare, previa stipulazione di appositi separati contratti, l'assistenza e/o consulenza necessaria per la manutenzione o l'avviamento o aggiornamento o personalizzazione o implementazione dei software prodotti da NextFEM SRLS, nonché per l'eventuale addestramento del personale del Cliente incaricato del loro uso.

2. L'eventuale esistenza di altri rapporti contrattuali tra NextFEM SRLS ed il Cliente, non determina alcuna colleganza tra gli stessi che rimangono, pertanto, separati ed autonomi.

3. Le licenze d'uso fornite a titolo gratuito (es. programma di base, licenza Educational, ecc.) non sono coperte da nessun tipo di assistenza da parte di NextFEM SRLS.

4. Le licenze d'uso fornite a fronte di un pagamento da parte del Cliente possono essere accompagnate dall'assistenza via email relativa alla prima installazione fino a 7gg dall'acquisto. Ulteriore assistenza può essere fornita a pagamento per un periodo di un anno a partire dall'acquisto. L'acquisto di assistenza ed eventuali rinnovi di questa devono essere contestuali rispettivamente all'acquisto del programma e dell'eventuale rinnovo della licenza del programma. L'assistenza viene fornita esclusivamente via email e solo sull'utilizzo e sul funzionamento del programma. NextFEM SRLS non fornisce assistenza sulle scelte ingegneristiche effettuate o da effettuarsi per la progettazione di qualsivoglia struttura. Nessuna indicazione fornita tramite assistenza è sostitutiva del giudizio ingegneristico del Cliente, che rimane il solo responsabile della struttura progettata, analizzata e verificata tramite il programma, nonché dei risultati ottenuti.

Art. 12 – Comunicazioni -

1. Qualsiasi comunicazione da parte del Cliente relativa al presente contatto dovrà essere inviata mediante lettera raccomandata con ricevuta di ritorno, ovvero raccomandata a mano, all'indirizzo “NextFEM SRLS, Piazza del Foro Romano 12, 31046 Oderzo (TV)”, ovvero a mezzo posta elettronica certificata all'indirizzo nextfem@pec.nextfem.it.

2. Qualsiasi comunicazione da parte di NextFEM SRLS relativa al presente contatto verrà inviata all'indirizzo e-mail indicato dal Cliente in sede di registrazione del proprio account sul sito nextfem.it.

Art. 13 - Controversie – Legge applicabile -

1. Il presente contratto è soggetto alla legge dello Stato Italiano.

2. Per qualsiasi controversia comunque relativa al presente contratto sarà esclusivamente competente il Foro di Treviso.

Art. 14 – Licenza Educational -

1. Le licenze Educational sono distribuite per un numero predeterminato di postazioni previo accordo verbale o scritto con NextFEM SRLS. È facoltà esclusiva di NextFEM SRLS decidere il numero di licenze concesse previa concertazione con il Cliente.

2. Le licenze Educational possono essere concesse al Cliente, sia pubblico che privato, qualora sia un ente di formazione, un istituto di ricerca e sviluppo o una scuola, a titolo gratuito ed a giudizio insindacabile di NextFEM SRLS. In tal caso, le licenze Educational concesse non danno alcun diritto sull’uso del programma oltre l’arco temporale previsto accordato al Cliente, e possono essere revocate in qualsiasi momento da NextFEM SRLS senza fornire alcuna giustificazione o preavviso al Cliente.

3. Qualora sia concessa a titolo gratuito, la licenza di tipo Educational non dà diritto ad alcun rimborso per qualsiasi motivo del costo del software.

4. Qualora sia concessa a titolo gratuito, la licenza di tipo Educational non dà diritto ad alcun tipo di supporto da parte di NextFEM SRLS, nemmeno a fronte di malfunzionamenti del software, escludendo quindi le garanzie dell’art. 9 comma 2 del presente contratto.

Art. 15 – Modifica delle condizioni contrattuali -

1. Il Licenziante si riserva il diritto di modificare le condizioni del contratto di Licenza d’uso dei software prodotti da NextFEM SRLS a mezzo e-mail da inviare al Licenziatario all'indirizzo e-mail indicato in sede di registrazione del proprio account sul sito nextfem.it, salvo facoltà di recesso del Licenziatario da esercitarsi, a pena di decadenza, con lettera raccomandata con ricevuta di ritorno, ovvero raccomandata a mano, all'indirizzo “NextFEM SRLS, Piazza del Foro Romano 12, 31046 Oderzo (TV)”, ovvero a mezzo posta elettronica certificata all'indirizzo nextfem@pec.nextfem.it ed entro 14 giorni decorrenti dalla data di ricevimento della comunicazione di modifica.

Art. 16 – Disposizioni finali –

1. Qualora una delle clausole del presente Contratto fosse dichiarata nulla o inefficace in tutto o in parte, ciò non inficerà la validità delle ulteriori clausole, salvo che il Licenziante consideri in buona fede tale clausola essenziale e conseguentemente intenda procedere alla risoluzione del Contratto.

2. Per quanto non espressamente previsto dal presente contratto si applicheranno le norme del Codice Civile e del D. Lgs. 29 dicembre 1992, n. 518 e ss.mm.ii., concernente l'Attuazione della Direttiva n. 91/250 CEE del 14 maggio 1991 relativa alla tutela giuridica dei programmi per elaboratore che modifica ed integra la L. 22 aprile 1941, n. 633, nonché quest'ultima Legge e ss.mm.ii., nonché la Direttiva 2009/24/CE del Parlamento Europeo e del Consiglio del 23.5.2009 e ss.mm.ii.

Oderzo (TV), lì (data dell'accettazione delle presenti condizioni contrattuali)

NextFEM SRLS Il Cliente

Ai sensi e per gli effetti degli artt. 1341 e 1342 c.c. il Cliente approva specificamente per averli letti, compresi e conosciuti gli artt.: 2 (Durata – Risoluzione del contratto) comma 2, 3 (Consegna della licenza) comma 3, 4 (Installazione) comma 3, 6 (Proprietà - Divieto di cessione), 7 (Titolare dei diritti - Segreto – Modifiche) comma 2, 8 (Canone – Solve et repete) comma 2, 9 (Garanzia e responsabilità) commi 3,4,5,6,7,8,9, 11 (Assistenza e/o consulenza) comma 4, 13 (Controversie – Legge applicabile), Art. 14 (Licenza Educational) commi 2 e 3, Art. 15 (Modifica delle condizioni contrattuali), Art. 16 (Disposizioni finali).

Oderzo (TV), lì (data dell'accettazione delle presenti condizioni contrattuali)

Il Cliente

Questo software è copyright di NextFEM, 2014-2024.

Windows® è un marchio registrato di Microsoft Corporation. Altri marchi appartengono ai rispettivi proprietari.

NextFEM Designer usa:

OOFEM v2.4

ZedGraph Library v.5.1.5.31366

Clipper2 Library v.1.0.6

net Dxf Library v.0.9.1

Poly2Tri Library

RichTextBoxLinks Library

SlimDX Library

Jace Library

UnitConversionLib Library

DotNetZip Library v1.13.7

Triangle.NET Library Beta 4

Netgen Mesh Generator Library v.6.0

PDFSharp v.1.32

RTF Document Constructor Library

log4net Library v.1.2.15

SharpZipLib Library v.0.86.0

Esent Managed Interface v.1.9.4

xBIM Essentials v.5

xBIM Geometry v.5

XbimWebUI for xBIM toolkit

Desktop Bridge Helpers v.1.1.0

DocX Library v.1.1.0

Splicer Library v.1.0

DirectShowLib v.2.1

OpenStreetMap site

IDEA StatiCa IOM

Newtonsoft Json.NET v12.0

AutoUpdater.NET v1.1

SdxSprite TextRenderer v2.0

RibbonWinforms v5.0.1.0

glTF-CSharp-Loader v1.1.3-alpha

SpreadsheetLight v3.5

WPF-Math v0.11

Collapsible control

Tutte le licenze, compresa quella generale del programma e dei moduli a pagamento, possono essere visionate dal menu ?/Informazioni su …