NextFEM Designer - Validation on scaffold checks

NextFEM Designer

FireSafe module

Version 2.2

© NextFEM 2015-2023

Summary

Chapter 1 Introduction. 3

Supported design codes. 3

Chapter 2 Analysis description and validation. 4

Thermal analysis. 4

Origin and features of the program... 4

Validation case. 4

Automatic thermal calculation of sections. 5

Element checking. 6

Section cover – fire design. 7

Chapter 3 Verifications listing. 9

Steel elements. 9

Estimation of section class. 10

Tension/compression (Axial) 10

Shear (Shear) 11

Bending with shear interaction (Bending) 11

Biaxial bending and axial load (BuckBending_biax and TensBending_biax) 11

Aluminium alloy elements. 12

Estimation of section class. 13

Tension/compression (Axial) 14

Shear (Shear) 14

Bending with shear interaction (Bending) 14

Biaxial bending and axial load (BuckBending_biax and TensBending_biax) 14

Reinforced Concrete elements. 16

Ultimate Limit States. 17


Chapter 1Introduction

Chapter 1
Introduction

In this manual, thermal analysis and fire verifications conducted with NextFEM Designer are showed and validated.


Supported design codes

The following references have been used:

1. EN 1993-1-1: Eurocode 3 - Design of steel structures - Part 1-1: General rules and rules for buildings

2. EN 1993-1-2: Eurocode 3 - Design of steel structures - Part 1-2: General rules – Structural fire design

3. EN 1992-1-1: Eurocode 2 - Design of concrete structures - Part 1-1: General rules and rules for buildings

4. EN 1992-1-2: Eurocode 2 - Design of concrete structures - Part 1-2: General rules – Structural fire design

5. Italian Ministry of Infrastructures, D.M. 17-01-2018 (in the following, NTC2018) and Annex no. 617, 02/02/2009

6. EN 1999-1-1: Eurocode 9 - Design of aluminium structures - Part 1-1: General structural rules

7. EN 1999-1-2: Eurocode 9 - Design of aluminium structures - Part 1-2: General rules – Structural fire design


Chapter 2 Analysis description and validation

Chapter 2
Analysis description and validation

In the following paragraph, a validation for thermal analysis conducted with NextFEM Designer will be presented.


Thermal analysis

The analysis is carried out using a non-linear calculation methodology, i.e. allowing the solver to iterate as the temperature applied to the exposed side increases (by convention, the right term of equation) as a Dirichlet condition of the heat transmission equation, explained in matrix form below:

with:

T vector of nodal temperatures, [image] is its derivative with respect to time, Q thermal load vector,

C capacity matrix, that collects the contributions of the specific heat values of each element of the mesh,

K thermal conductivity matrix, that collects the contributions of the conductivity values of each element of the mesh.

In accordance with the European standard EN 1992-1-2 "Design of concrete structures - Part 1-2: General rules – Structural fire design" - April 2005 (hereinafter Eurocode 2, EC2), the characteristics of the material analysed vary as a function of time, according to the laws dictated by the standard itself. The laws of variation over time are reported normalized to unitary value for the initial temperature of 20 ° C.


Origin and features of the program

The default solver, OOFEM, is employed to perform the Finite Elements calculations. Other types of solvers can be set and used in the program, by they are not supported for this validation. OOFEM is licensed under LGPL conditions, reported in ?/About… and included in the software package. This solver is developed by Prof. Borek Patzak (University of Prague) and by the oofem.org community.


Validation case

A validation of the thermal analysis conducted with NextFEM Designer is reported. The comparison is made with figure A.18 of EC2-1-2 on a circular concrete column at t=90 minutes.

The violet line represent the isothermal curve for T=500°C.


Automatic thermal calculation of sections

The analysis can be carried-out through two simple steps:

1. obtain the thermal maps of the sections, including a quick strength estimation about the analysed section with the command Results / Fire Checking …

In the window that appears you can select:

- Fire curve: by default, the selected fire curve is ISO 834 (Standard Fire Curve);

- Load combination: select the exceptional load combination to use for quick verification;

- Section selection criterion: the section used for verification must meet the selected criterion (maximum moment My, maximum moment Mz, maximum in both directions Myz)

- Sides exposed to fire for beams: the sides considered as exposed for the thermal analysis for the horizontal or sub-horizontal elements;

- Sides exposed to fire for columns: the sides considered as exposed for the thermal analysis for vertical elements;

- Final fire analysis time in minutes: select the analysis time for which the resistant check of the section will be conducted.

The Run all analyses option allows you to launch the files created in the same folder as the current model, saving the results for each. The Show Results option displays the 500°C isotherm for each thermal analysis in a separate window.

The command returns a table containing the demand / capacity ratios of the analysed sections in the Check-NMM (pressure and bending) and Check-V (shear) columns. The images relating to the resistant verification are saved in the same folder as the model (representation of the section and neutral axis, reduced resistant domain due to the effect of fire).

By executing the “Generate models for fire analysis” command, the program will save in the folder of the current model a new NXF file for each processed section. Such file must contain results of the thermal analysis in order to be processed by subsequent structural checking.

WARNING: the checking displayed as a result by this command are computed on a single transversal section, hence they cannot replace the check on each element.

WARNING: Sections are meshed on the base of the Mesh size specified in Tools/Options. The value is in mm.


Element checking

To check elements, use one of the following verification sets, depending on the material:

- RCfireCheck for RC structures

- SteelFireCheck for steel members

- AluFireCheck for aluminium alloy members

- SteelScaffoldFireCheck for steel scaffolds.

In general, checks for shear, bending and axial stability are supplied. See Chapter 3 for a complete listing of verifications.

WARNING: Element will be checked if the NXF containing thermal analysis of the corresponding section includes results as well. Otherwise, verification will be stopped.


Section cover – fire design

NextFEM Designer allows the verification of existing structures using the procedure described above. To verify the effectiveness of fire protection of structures against the R (Resistance) requirement, you can perform the analysis by imputing the protective layer (paint, gypsum board, etc.) directly to the element section.

To select a non-structural overlay material, first select Assign/Design Materials and choose the "Fire Protectors" library.

Immagine che contiene tavolo Descrizione generata automaticamente

Then, from the Edit / Sections mask, apply the overlay with the dx key command / Section Overlay, specifying the thickness when required.

The thermal analyses conducted for that section will include the added protective layer, as in the next figure. At the same time, the non-structural coating layer has no effect in the structural analyses conducted in the main model.


Chapter 3 Verifications listing

Chapter 3
Verifications listing


Steel elements

In this chapter, all the verifications performed by NextFEM Designer for steel beams/trusses are described.

A: Area

Jz: Moment of inertia around x-axis

Jy: Moment of inertia around y-axis

Jmin: Minimum moment of inertia

Jt: Torsional Inertia

D: Diameter of circular cross sections

Di: Inner diameter of pipe cross sections

te: Thickness of pipe cross sections

b: Base for any other cross sections

h: Height for any other cross sections

tw: web thickness

tf1: thickness of bottom flange

tf2: thickness of upper flange

t: thickness for planar sections

N: Axial force

Vy: Shear force along y direction

Vz: Shear force along z direction

Mt: Twisting moment

Myy: Moment around y local axis

Mzz: Moment around z local axis

Em: material Young modulus

Gm: material shear modulus

NIm: material Poisson’s ratio

fk: material characteristic strength

WelZ: section modulus for Z axis

WelY: section modulus for Y axis

WplZ: plastic section modulus for Z axis

WplY: plastic section modulus for Y axis

iz: radius of inertia for Z axis

iy: radius of inertia for Y axis

imin: minimum radius of inertia

SecType: 1=beam, 2=planar, 0=unknown

SecBeamType: 0=unknown, 1=rectangular, 2=circular, 3=Cshape, 4=Tshape, 5=DoubleTshape, 6=Lspahe, 7=box, 8=pipe

dx: axial relative displacement along beam axis

dy: transversal deflection in local direction y

dz: transversal deflection in local direction z.

Verifications performed by NextFEM Designer for steel beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.

WARNING: all the verifications listed do not support Class 4 transversal sections.


Estimation of section class

Conservatively, each section class is estimated as the maximum section class amongst the ones related to each part of the section, considered as fully in compression.

Section type | Parte | Ratio | Class 1 | Class 2 | Class 3
Rectangular |  | / |  |  | always
Double T, T, C | web | 0.9(h-tf1)/tw | 33e | 38e | 42e
 | flange | 0.9(b/2-tw)/tf1 | 9e | 10e | 14e
Angular | web | hmax/te |  |  | 15e
 | flange | (b+h)/(2te) |  |  | 11.5e
Box | web | (h-2te)/te | 9e | 10e | 14e
 | flange | (b-2te)/te | 9e | 10e | 14e
Pipe |  | D/te | 50e2 | 70e2 | 90e2
Bar |  | / |  | always |
Generic |  | / |  |  | always

with

The column name of the program output is reported between brackets (i.e. (EulerBuckling))


Tension/compression (Axial)

In tension:

In compression (Eulerian buckling):

with [image] calculated on the base of the following buckling coefficients, determined for rolled sections only:

Section type | ay | az | aLT
Rectangular | 0.49 | 0.49 | 0.76
Double T, I | da 0.21 a 0.76 | da 0.21 a 0.76 | da 0.34 a 0.49
Angular, C, T | 0.49 | 0.49 | 0.76
Box | 0.49 | 0.49 | 0.76
Pipe | 0.49 | 0.49 | 0.76
Bar | 0.49 | 0.49 | 0.76
Generic | - | - | -


Shear (Shear)


Bending with shear interaction (Bending)

, with [image] if the shear force exceeds the 50% of plastic strength, [image] otherwise.


Biaxial bending and axial load (BuckBending_biax and TensBending_biax)

If the element is compressed:

with

If the element is tensioned:


Aluminium alloy elements

In this chapter, all the verifications performed by NextFEM Designer for aluminium beams/trusses are described. Such verification contains references to EN 1999-1-1 (Eurocode 9).

A: Area

Jz: Moment of inertia around x-axis

Jy: Moment of inertia around y-axis

Jmin: Minimum moment of inertia

Jt: Torsional Inertia

D: Diameter of circular cross sections

Di: Inner diameter of pipe cross sections

te: Thickness of pipe cross sections

b: Base for any other cross sections

h: Height for any other cross sections

tw: web thickness

tf1: thickness of bottom flange

tf2: thickness of upper flange

t: thickness for planar sections

N: Axial force

Vy: Shear force along y direction

Vz: Shear force along z direction

Mt: Twisting moment

Myy: Moment around y local axis

Mzz: Moment around z local axis

Em: material Young modulus

Gm: material shear modulus

NIm: material Poisson’s ratio

fk: material characteristic strength

WelZ: section modulus for Z axis

WelY: section modulus for Y axis

WplZ: plastic section modulus for Z axis

WplY: plastic section modulus for Y axis

iz: radius of inertia for Z axis

iy: radius of inertia for Y axis

imin: minimum radius of inertia

SecType: 1=beam, 2=planar, 0=unknown

SecBeamType: 0=unknown, 1=rectangular, 2=circular, 3=Cshape, 4=Tshape, 5=DoubleTshape, 6=Lspahe, 7=box, 8=pipe

dx: axial relative displacement along beam axis

dy: transversal deflection in local direction y

dz: transversal deflection in local direction z.

Verifications performed by NextFEM Designer for aluminium beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.

WARNING: all the verifications listed do not support Class 4 transversal sections.

WARNING: Inside the program, the material library Alloy lists the most spread aluminium alloys. Pay attention to the material names, which may include some limitations for particular section shapes:

SH - Sheet (EN 485)

ST - Strip (EN 485)

PL - Plate (EN 485)

ET - Extruded Tube (EN 755)

EP - Extruded Profiles (EN 755)

ER/B - Extruded Rod and Bar (EN 755)

DT - Drawn Tube (EN 754)

FO - Forgings (EN 586)


Estimation of section class

Conservatively, each section class is estimated as the maximum section class amongst the ones related to each part of the section, considered as fully in compression (te signifies section thickness).

Section type | Part | Ratio | Class 1 | Class 2 | Class 3
Rectangular |  | / |  |  | always
Double T, T, C | web | 0.9(h-tf1)/tw | b1 | b2 | b3
 | flange | 0.9(b/2-tw)/tf1 | b1 | b2 | b3
Angular | web | hmax/te |  |  | b3
 | flange | (b+h)/(2te) |  |  | b3
Box | web | (h-2te)/te | b1 | b2 | b3
 | flange | (b-2te)/te | b1 | b2 | b3
Pipe |  |  | b1 | b2 | b3
Bar |  | / |  | always |
Generic |  | / |  |  | always

The values b1, b2, b3 are computed automatically by considering the ratios b/e reported on the following table and multiplied by the parameter e defined as follows:

For the flanges in a section, the coefficients for the outstand parts are used; for webs and sides of a section, the coefficients for the internal parts are employed.

The design codes provide different coefficients for welded and non-welded sections. Coefficients for non-welded sections are taken by default, but it is possible to enforce the variable welded=1 before to start the checking, to force the procedure to assume all the sections as welded. To force the checking for welded material ONLY at beam ends, set the variable weldedEnds=1.

WARNING: for the welded section checking, the verification procedure uses the value of f0HAZ form the Alloy material library. In the case a custom material is used, please add the line “f0HAZ=xxx” in the textbox inside the Verification mask, with f0HAZ in MPa.

 |  | Internal part |  |  | Outstand part
 | Durability class | b1/e | b2/e | b3/e | b1/e | b2/e | b3/e
w/o welds | A | 11 | 16 | 22 | 3 | 4.5 | 6
 | B | 13 | 16.5 | 18 | 3.5 | 4.5 | 5
with welds | A | 9 | 13 | 18 | 2.5 | 4 | 5
 | B | 10 | 13.5 | 15 | 3 | 3.5 | 4

The column name of the program output is reported between brackets (i.e. (EulerBuckling)). In the following formula, f0 (or f0HAZ) is written as fyk.


Tension/compression (Axial)

In tension:

In compression (Eulerian buckling):

with [image] calculated on the base of the buckling coefficients, determined from Table 6.5 in Eurocode 9. The k parameter is always taken as 1.


Bending with shear interaction (Bending)

if the shear force does not exceed the 30% of plastic strength;

, with [image] if the shear force exceeds the 50% of plastic strength, [image] otherwise.


Reinforced Concrete elements

In this chapter, all the verifications performed by NextFEM Designer for reinforced concrete beams and walls are described.

A: Area

Jz: Moment of inertia around x-axis

Jy: Moment of inertia around y-axis

Jmin: Minimum moment of inertia

Jt: Torsional Inertia

D: Diameter of circular cross sections

Di: Inner diameter of pipe cross sections

te: Thickness of pipe cross sections

b: Base for any other cross sections

h: Height for any other cross sections

tw: web thickness

tf1: thickness of bottom flange

tf2: thickness of upper flange

t: thickness for planar sections

N: Axial force

Vy: Shear force along y direction

Vz: Shear force along z direction

Mt: Twisting moment

Myy: Moment around y local axis

Mzz: Moment around z local axis

Em: material Young modulus

Gm: material shear modulus

NIm: material Poisson’s ratio

fk: material characteristic strength

WelZ: section modulus for Z axis

WelY: section modulus for Y axis

WplZ: plastic section modulus for Z axis

WplY: plastic section modulus for Y axis

iz: radius of inertia for Z axis

iy: radius of inertia for Y axis

imin: minimum radius of inertia

SecType: 1=beam, 2=planar, 0=unknown

SecBeamType: 0=unknown, 1=rectangular, 2=circular, 3=Cshape, 4=Tshape, 5=DoubleTshape, 6=Lspahe, 7=box, 8=pipe

dx: axial relative displacement along beam axis

dy: transversal deflection in local direction y

dz: transversal deflection in local direction z

bwY: minimum section width in local direction y

bwZ: minimum section width in local direction z

ds: effective depth of the section

Astot: total area of rebar for a section

AsTens: total area of rebar in tension

fyks: characteristic strength for stirrups

fydl: design strength for longitudinal bars

rebCmin: distanza minima fra bordo e centro armatura longitudinale

isWall: equal to 1 if the section belongs to a wall, 0 otherwise

AmbCondition: environmental conditions for serviceability check (1,2,3)

mNt: ductility in tension for plastic hinges

mNc: ductility in compression for plastic hinges

mVy: ductility in shear (local direction y) for plastic hinges

mVz: ductility in shear (local direction z) for plastic hinges

mMt: torsional ductility for plastic hinges

mMy: flexural ductility (around local axis y) for plastic hinges

mMz: flexural ductility (around local axis z) for plastic hinges

NbH: maximum compressive strength for plastic hinges

MtH: elastic torsional strength for plastic hinges.

Verifications performed by NextFEM Designer for aluminium beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.


Ultimate Limit States

Stability in compression

Shear for members without shear reinforcement

For each local direction y and z:

with

Shear for members with shear reinforcement