NextFEM Designer - Validation on scaffold checks

NextFEM Designer

Validation of verifications

Version 2.0

© NextFEM 2015-2022

Summary

Chapter 1 Introduction. 5

Supported design codes. 5

Chapter 2 Analysis validation. 6

Types of analysis. 6

Static analysis. 6

Origin and features of the program... 6

Reliability of the program... 7

Tutorial One. 7

Tutorial Two. 17

Case a. 17

Case b. 23

Tutorial Three. 28

Tutorial Four 31

Tutorial Five. 35

Tutorial Six. 39

Chapter 3 Verifications for steel members. 43

Symbols. 43

Verification listing. 44

Estimation of section class. 44

Tension/compression (Axial) 44

Shear (Shear) 45

Bending with shear interaction (Bending) 45

Biaxial bending and axial load (BuckBending_biax and TensBending_biax) 45

Torsional buckling (TorsionBuckling) 45

Combined torsional buckling (TorsionBuck_comb) 46

Deflection checks. 46

Checking from pushover analysis. 47

Chapter 4 Verifications for aluminium members. 49

Symbols. 49

Verification listing. 50

Estimation of section class. 50

Tension/compression (Axial) 51

Shear (Shear) 51

Bending with shear interaction (Bending) 52

Biaxial bending and axial load (BuckBending_biax and TensBending_biax) 52

Torsional buckling (TorsionBuckling) 52

Combined torsional buckling (TorsionBuck_comb) 52

Deflection checks. 53

Chapter 5 Verifications for reinforced concrete members. 54

Symbols. 54

Verification listing. 55

Ultimate Limit States. 55

Serviceability Limit States. 56

Seismic design. 59

Geometric checks. 59

Ductility checks. 60

Shear 60

Column compression ratio (ColComprRatio) 60

Beam-column joints. 60

Capacity design. 60

Detailing for beams. 61

Detailing for columns. 61

Shear verification in the plane for sliding walls (Sliding) 62

Checking FRP reinforcements. 63

Checking from pushover analysis. 64

Chapter 6 Verifications for timber members. 66

Symbols. 66

Verification listing. 67

Ultimate Limit States. 67

Ultimate Limit States for CLT panels. 69

Serviceability Limit States. 70

Chapter 7 Verifications for thin steel profiles. 72

Symbols. 72

Verification listing. 72

Base assumptions. 73

Estimation of section class. 74

Tension/compression (Axial) 74

Shear (Shear) 75

Bending with shear interaction (Bending) 75

Biaxial bending and axial load (BuckBending_biax and TensBending_biax) 75

Torsional buckling (TorsionBuckling) 75

Combined torsional buckling (TorsionBuck_comb) 76

Deflection checks. 76

Chapter 8 Verifications for thin aluminium alloy profiles. 77

Symbols. 77

Verification listing. 77

Base assumptions. 78

Estimation of section class. 79

Tension/compression (Axial) 79

Shear (Shear) 80

Bending with shear interaction (Bending) 80

Biaxial bending and axial load (BuckBending_biax and TensBending_biax) 80

Torsional buckling (TorsionBuckling) 80

Combined torsional buckling (TorsionBuck_comb) 81

Deflection checks. 81

Chapter 9 Verifications for masonry structures. 82

Symbols. 82

Verification listing. 82

Tensile failure (TensileFailure) 83

Vertical load stability (Axial) 83

In-plane bending (InPlaneBending) 83

Out-of-plane bending (OutOfPlaneBending) 83

Sliding shear (Shear) 83

Checking from pushover analysis. 84


Chapter 1Introduction

Chapter 1
Introduction

In this manual, analysis and verifications conducted with NextFEM Designer are showed and validated.

In the second paragraph, the program validation will be presented against some cases having easy analytical solution.

In the third paragraph, relationships used for steel member checking will be presented.

Such manual applies to the linear (static and dynamic) analyses only carried out with NextFEM Designer and with its default solver (OOFEM).


Supported design codes

The following references have been used:

1. EN 1993-1-1: Eurocode 3 - Design of steel structures - Part 1-1: General rules and rules for buildings

2. Italian Ministry of Infrastructures, D.M. 17-01-2018 (in the following, NTC2018) and Annex no. 617, 02/02/2009

3. EN 1999-1-1 (Eurocode 9)

4. EN 1992-1-1 (Eurocode 2)

5. EN 1995-1-1 (Eurocode 5)

6. EN 1993-1-3 (Eurocode 3 - cold-formed design)


Chapter 2 Analysis validation

Chapter 2
Analysis validation

In the following paragraph, a validation for structural analysis conducted with NextFEM Designer will be presented.


Types of analysis


Static analysis

The analysis performed is a structural static analysis. The solution of linear system of equations in the form Ax=b, produced by the Finite Elements Method, is obtained with linear systems solvers.

Load combinations are consistent with the ones proposed by Eurocode 3, and are written in the following form:

gG1×G1 + gG2×G2 + gQ1×Qk1 + gQ2×y02×Qk2 + gQ3×y03×Qk3 + …

Partial safety factors:

- gG1 : for self-weight loads, set as default to 1.5

- gG2 : for permanent loads, set as default to 1.5

- gQi : for variable loading, set as default to 1.5

Combination factors:

- y0i : as default to 0.7 for variable loading

- y0i : as default to 0.6 for wind loads

- y0i : as default to 0.5 for snow loads (on the base of the height of the building site, < 1000m above sea level)

Such ULS (Ultimate Limit State) combinations are automatically generated by the program through the command Assign/Load combinations…/Generate combos. Please refer to the program users’ manual for further information.


Origin and features of the program

The program is composed by 2 parts:

- Pre- and post-processor, NextFEM Designer (the program seen by the user), which handles input phase and results visualization, and also load combinations generation and verifications. This program is licensed to final user with the included license, that can be obtained with the command ?/About…/Product license. NextFEM Designer is made by NextFEM, except for the packages listed in ?/About….

- The default solver, OOFEM, is employed to perform the Finite Elements calculations. Other types of solvers can be set and used in the program, by they are not supported for this validation. OOFEM is licensed under LGPL conditions, reported in ?/About… and included in the software package. This solver is developed by Prof. Borek Patzak (University of Prague) and by the oofem.org community.


Reliability of the program

This validation, including the hand calculation presented, is reported at Chapter 5 of the users’ manual of NextFEM Designer. In the following, a reduced version with a particular focus on frame structures is reported.


Tutorial One

This tutorial will show how to model a 5 metres long fixed-ended beam, loaded with concentrated loads of 10kN in directions x, y and z in the middle of its span. The results from NextFEM Designer (Frame forces and displacement) are compared with hand calculations.

* WARNING: Both flexural and shear deformations are considered. To enable this option, click on Tools>Option>Solver and check the Include shear deformations in beam elements tick under the OOFEM preferences box

The following sequence of operations are needed to create the model:

1. Set the Units: N for force and mm for length.

2. Define the Material properties:

o    Name: Concrete;

o    E=30000 N/mm2;

o    Nu=0.3

o    Fk=25 N/mm

o    Weight=2.5e-5 N/mm3;

o    Mass=2.55e-9 N/mm2/g

3. Define the Section properties:

o    b=300 mm (z direction);

o    h=500mm (y direction);

4. Define the Loads cases: Only one load case called Qk1 is considered

5. Insert the Geometric properties using Node by Coordinates:

o    L=5000 mm;

o    Distance from fixed end to loads=2500 mm;

6. Insert the beams using the Beam command.

7. Assign the boundary conditions using the Restraints command: fix all DoFs for nodes 1 and 3.

8. Assign the material using the Assign>Material command at the beams by selecting them and then click on Assign to selected elements

9. Assign the section using the Assign>Section command at the beams by selecting them and then click on Assign

10. Assign the point load to the node number 2.

o    Px=10000 N;

o    Py=10000 N;

o    Pz=-10000 N.

11. Run the analysis.

- NextFEM Designer’s Results:

o    Displacement in x direction: Node 2=0.002778mm

o    Displacement in y direction: Node 2=0.2016mm

o    Displacement in z direction: Node 2=-0.00781 mm

o    Moment Diagram: Values from Results>Extract Data

§ Mzz

§ Myy

o    Shear Diagram:

§ Vy

§ Vz

o    Normal forces Diagram:

o    Internal displacements in y direction: values from Results>Extract data

Position [mm] | Displacement [mm]
0 | 0
281.8 | 0.00778
1250 | 0.1008
2218 | 0.1938
2500 | 0.2016
2500 | 0.2016
2781.8 | 0.1938
3750 | 0.1008
4718 | 0.00778
5000 | 0

o    Internal displacements in z direction: values from Results>Extract data

Position [mm] | Displacement [mm]
0 | 0
281.8 | -0.003424
1250 | -0.03906
2218 | -0.07469
2500 | -0.07811
2500 | -0.07811
2781.8 | -0.07469
3750 | -0.03906
4718 | -0.003424
5000 | 0

- Hand Calculations:

o    Section properties

o    Moment diagram:

§ Mzz

;

§ Myy

;

o    Shear Diagram:

§ Vy

;

§ Vz

;

o    Axial force Diagram:

;

o    Displacement in x direction: Node2

o    Displacement in y direction: Node 2

o    Displacement in z direction: Node 2

o    Displacement in y direction: internal point at the coordinate x

for

for

Position [mm] | Displacement [mm]
0 | 0
281.8 | 0.00778
1250 | 0.1008
2218 | 0.1938
2500 | 0.2016
2500 | 0.2016
2781.8 | 0.1938
3750 | 0.1008
4718 | 0.00779
5000 | 0

o    Displacement in z direction: internal point at the coordinate x

for

for

Position [mm] | Displacement [mm]
0 | 0
281.8 | -0.003425
1250 | -0.03906
2218 | -0.07468
2500 | -0.07811
2500 | -0.07811
2781.8 | -0.07469
3750 | -0.03906
4718 | -0.003429
5000 | 0


Tutorial Two

The second tutorial consists in a cantilever beam loaded with points load in directions y and z. The output results of NextFEM Designer (Frame forces and displacement) are compared with hand calculations.


Case a

Only flexural deformations are considered.

- Units: N for forces and mm for lengths.

- Material Properties:

o    Name: Concrete;

o    E=30000 N/mm2;

o    Nu=0.3

o    Fk=25 N/mm

o    Weight=2.5e-5 N/mm3;

o    Mass=2.55e-9 N/mm2/g

- Section properties:

o    B=300 mm (z direction);

o    H=500mm (y direction);

- Geometric properties:

o    L=2500 mm;

- Loads:

o    Py=5000 N;

o    Pz=-10000 N.

- NextFEM Designer’s results:

o    Displacement in x direction: Node 2=0.00mm

o    Displacement in y direction: Node 2=0.7716mm

o    Displacement in z direction: Node 2=-0.5556mm

o    Moment Diagram: Values from Results>Extract Data

§ Mzz

§ Myy

o    Shear Diagram:

§ Vy

§ Vz

o    Internal displacement in y direction: values from Results>Extract data

Position [mm] | Displacement [mm]
0 | 0
281.8 | 0.01415
1250 | 0.2411
2218 | 0.6417
2500 | 0.7716

o    Internal displacement in z direction: values from Results>Extract data

Position [mm] | Displacement [mm]
0 | 0
281.8 | -0.01019
1250 | -0.1736
2218 | -0.4620
2500 | -0.5556

- Hand Calculations:

o    Moment diagram:

§ Mzz

;

§ Myy

o    Shear Diagram:

§ Vy

;

§ Vz

;

o    Axial force Diagram:

;

o    Displacement in x direction: Node 2

o    Displacement in y direction: Node 2

o    Displacement in z direction: Node 2

o    Displacement in y direction: point at coordinate x

Coordinate x [mm] | Displacement [mm]
0 | 0
281.8 | 0.01415
1250 | 0.2411
2218 | 0.6416
2500 | 0.7716

o    Displacement in z direction: point at coordinate x

Coordinate x [mm] | Displacement [mm]
0 | 0
281.8 | -0.01019
1250 | -0.1736
2218 | -0.4620
2500 | -0.5556


Case b

* Both flexural and shear deformations are considered. To enable this option, click on Tools>Option>Solver and check the Include shear deformations in beam elements tick under the OOFEM preferences box

- Units: N for forces and mm for lengths.

- Material Properties:

o    Name: Concrete;

o    E=30000 N/mm2;

o    Nu=0.3

o    Fk=25 N/mm

o    Weight=2.5e-5 N/mm3;

o    Mass=2.55e-9 N/mm2/g

- Section properties:

o    B=300 mm (z direction);

o    H=500mm (y direction);

- Geometric properties:

o    L=2500 mm;

- Loads:

o    Py=5000 N;

o    Pz=-10000 N.

- NextFEM Designer’s results:

o    Displacement in x direction: Node 2=0.00mm

o    Displacement in y direction: Node 2=0.7803mm

o    Displacement in z direction: Node 2=-0.5729mm

o    Moment Diagram: Values from Results>Extract Data

§ Mzz

§ Myy

o    Shear Diagram:

§ Vy

§ Vz

o    Internal displacement in y direction: values from Results>Extract data

Position [mm] | Displacement [mm]
0 | 0
281.8 | 0.01513
1250 | 0.2455
2218 | 0.6494
2500 | 0.7803

o    Internal displacement in z direction: values from Results>Extract data

Position [mm] | Displacement [mm]
0 | 0
281.8 | -0.01214
1250 | -0.1823
2218 | -0.4774
2500 | -0.5729

- Hand Calculations:

o    Moment diagram:

§ Mzz

;

§ Myy

o    Shear Diagram:

§ Vy

;

§ Vz

;

o    Axial force Diagram:

;

o    Displacement in x direction: Node 2

o    Displacement in y direction: Node 2

o    Displacement in y direction: point at coordinate x

Coordinate x [mm] | Displacement [mm]
0 | 0
281.8 | 0.01513
1250 | 0.2455
2218 | 0.6493
2500 | 0.7803

o    Displacement in z direction: Node 2

o    displacement in z direction: point at coordinate x

Coordinate x [mm] | Displacement [mm]
0 | 0
281.8 | -0.01214
1250 | -0.1823
2218 | -0.4773
2500 | -0.5729


Tutorial Three

The third tutorial consists in a cantilever beam loaded with points load in direction y with modelled by shell elements (Mindlin-Reissner theory). The output results of NextFEM Designer (Frame forces and displacement) are compared with hand calculations.

Only flexural deformations are considered.

- Units: N for forces and mm for lengths.

- Material Properties:

o    Name: Concrete;

o    E=30000 N/mm2;

o    Nu=0.3

o    Fk=25 N/mm

o    Weight=2.5e-5 N/mm3;

o    Mass=2.55e-9 N/mm2/g

- Section properties:

o    B=300 mm (y direction); Planar section;

- Geometric properties:

o    L=5000 mm;

- Loads:

o    Py=5000 N;

o    Pz=10000 N;

- Mesh size: 250x250 mm

- NextFEM Designer’s Results:

o    Displacement in x direction: Node 2=0.00mm

o    Displacement in y direction: Node 2=0.6250 mm

o    Displacement in z direction: Node 2=-0.5062mm

- Comparison with hand Calculations (see tutorial two):

o    Displacement in y direction

§ Hand Calculation: 0.77160mm

§ NextFEM designer: 0.6250mm

§ Percent difference 19%

o    Displacement in z direction:

§ Hand Calculation: -0.5556mm

§ NextFEM designer: -0.5062mm

§ Percent difference: 9%

Note that the difference is due to the choice of the mesh size.


Tutorial Four

The fourth tutorial consists in a cantilever beam loaded with distributed loads in directions x, y and z. The output of NextFEM Designer (Frame forces and displacement) is compared with hand calculations.

Only flexural deformations are considered.

- Units: N for forces and mm for lengths.

- Material Properties:

o    Name: Concrete;

o    E=30000 N/mm2;

o    Nu=0.3

o    Fk=25 N/mm

o    Weight=2.5e-5 N/mm3;

o    Mass=2.55e-9 N/mm2/g

- Section properties:

o    B=300 mm (y direction);

o    H=500mm (z direction);

- Geometric properties:

o    L=5000 mm;

- Loads properties:

o    qy=1 N/mm;

o    qz=-1 N/mm;

o    qx=-1 N/mm.

- NextFEM Designer’s Results:

o    Displacement in x direction: Node 6=-0.00278mm

o    Displacement in y direction: Node 6=2.315mm

o    Displacement in z direction: Node 6=-0.8333mm

o    Moment Diagram: Values from Results>Extract Data

§ Mzz max: node 1: 125000000000 Nmm

§ Myy max: node 1: 125000000000 Nmm

o    Shear Diagram:

§ Vy

§ Vz

- Hand Calculations:

o    Moment diagram:

§ Mzz

;

§ Myy

;

o    Shear Diagram:

§ Vy

;

§ Vz

;

o    Axial force diagram:

;

o    Max Displacement in x direction: Node 6

o    Max Displacement in y direction: Node 6

o    Max Displacement in z direction: Node 6


Tutorial Five

The fifth tutorial consists in a modal analysis of a 3D wooden frame-building . The output of NextFEM Designer (modes of vibration) is compared with the output of SAP2000®.

Only flexural deformations are considered.

- Units: kN for forces and m for lengths.

- Material Properties:

o    Name: GL24H;

o    E=9.40e+6 kN/m2;

o    Nu=0.3

o    Weight=3.8 kN/m3;

o    Mass=0 kN/m3/g

- Section properties:

o    B=300 mm (y direction);

o    H=500 mm (z direction);

- Geometric properties:

o    Lx=3 m;

o    Ly=4m;

o    Lz=2m;

- Mass properties: at every nodes of the 1st storey

o    my=2.5 kN/g;

o    mz=-2.5 kN/g;

o    mx=-2.5 kN/g

- NextFEM Designer’s Results:

o    First mode:

o    Second mode:

o    Third mode:

- SAP2000® results:

o    First mode:

o    Second mode:

o    Third mode:

The test model, calculated with two different programs, shows the same results.


Tutorial Six

The sixth tutorial consists in a buckling analysis of a simply supported concrete column. The output of NextFEM Designer (i.e. the eigenvalues representing the load multipliers) is compared with the results computed by the Eulerian instability theory. The column is meshed into 5 elements of equal length.

Only flexural deformations are considered.

- Units: kN for forces and m for lengths.

- Material Properties:

o    Name: C25/30;

o    E=3.15e+6 kN/m2;

o    n=0.2

o    Weight =25 kN/m3;

o    Mass =2.5 kN/m3/g

- Section properties:

o    B=100 mm (z);

o    H=200 mm (y);

- Geometric properties:

o    Ltot=3.0 m;

- Loads:

o    Qz=-1 kN;

- NextFEM Designer’s results:

o    First mode:

o    Second mode:

o    Third mode:

o    Fourth mode:

o    Fifth mode:

- Manual calculation:

o    The critical load is computed as come [image] with [image] , and the inertia J of the direction of inflection.

o    Section inertia:

o    Theoretical results:

Bending around yy | Bending around zz

NextFEM Designer’s results are in agreement with the theoretical results.


Chapter 3 Verifications for steel members

Chapter 3
Verifications for steel members

In this chapter, all the verifications performed by NextFEM Designer for steel beams/trusses are described.


Symbols

A: Area

Jz: Moment of inertia around x-axis

Jy: Moment of inertia around y-axis

Jmin: Minimum moment of inertia

Jt: Torsional Inertia

D: Diameter of circular cross sections

Di: Inner diameter of pipe cross sections

te: Thickness of pipe cross sections

b: Base for any other cross sections

h: Height for any other cross sections

tw: web thickness

tf1: thickness of bottom flange

tf2: thickness of upper flange

t: thickness for planar sections

N: Axial force

Vy: Shear force along y direction

Vz: Shear force along z direction

Mt: Twisting moment

Myy: Moment around y local axis

Mzz: Moment around z local axis

Em: material Young modulus

Gm: material shear modulus

NIm: material Poisson’s ratio

fk: material characteristic strength

WelZ: section modulus for Z axis

WelY: section modulus for Y axis

WplZ: plastic section modulus for Z axis

WplY: plastic section modulus for Y axis

iz: radius of inertia for Z axis

iy: radius of inertia for Y axis

imin: minimum radius of inertia

SecType: 1=beam, 2=planar, 0=unknown

SecBeamType: 0=unknown, 1=rectangular, 2=circular, 3=Cshape, 4=Tshape, 5=DoubleTshape, 6=Lspahe, 7=box, 8=pipe

dx: axial relative displacement along beam axis

dy: transversal deflection in local direction y

dz: transversal deflection in local direction z.


Verification listing

Verifications performed by NextFEM Designer for steel beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.

WARNING: all the verifications listed do not support Class 4 transversal sections.


Estimation of section class

Conservatively, each section class is estimated as the maximum section class amongst the ones related to each part of the section, considered as fully in compression.

Section type | Parte | Ratio | Class 1 | Class 2 | Class 3
Rectangular |  | / |  |  | always
Double T, T, C | web | 0.9(h-tf1)/tw | 33e | 38e | 42e
 | flange | 0.9(b/2-tw)/tf1 | 9e | 10e | 14e
Angular | web | hmax/te |  |  | 15e
 | flange | (b+h)/(2te) |  |  | 11.5e
Box | web | (h-2te)/te | 9e | 10e | 14e
 | flange | (b-2te)/te | 9e | 10e | 14e
Pipe |  | D/te | 50e2 | 70e2 | 90e2
Bar |  | / |  | always |
Generic |  | / |  |  | always

with

The column name of the program output is reported between brackets (i.e. (EulerBuckling))


Tension/compression (Axial)

In tension:

In compression (Eulerian buckling):

with [image] calculated on the base of the following buckling coefficients, determined for rolled sections only:

Section type | ay | az | aLT
Rectangular | 0.49 | 0.49 | 0.76
Double T, I | da 0.21 a 0.76 | da 0.21 a 0.76 | da 0.34 a 0.49
Angular, C, T | 0.49 | 0.49 | 0.76
Box | 0.49 | 0.49 | 0.76
Pipe | 0.49 | 0.49 | 0.76
Bar | 0.49 | 0.49 | 0.76
Generic | - | - | -


Shear (Shear)


Bending with shear interaction (Bending)

if the shear force does not exceed the 30% of plastic strength;

, with [image] if the shear force exceeds the 50% of plastic strength, [image] otherwise.


Biaxial bending and axial load (BuckBending_biax and TensBending_biax)

If the element is compressed:

with

If the element is tensioned:


Torsional buckling (TorsionBuckling)

WARNING: this checks is not performed for pipe sections in a scaffolding.

For torsional buckling, the second-order twisting moment (Vlasov’s contribution) is always neglected:

con

except for the following sections:

double T, I:

C-shaped: with [image] .

In evaluating the critical resisting moment, the coefficient [image] is forced to the value 1.127 if the beam has null moments at both ends. In any case, it is limited to 1.285.


Combined torsional buckling (TorsionBuck_comb)

and [image] (for rotated sections)


Deflection checks

Deflection checks (Deflection)

WARNING: defLimit is defined in the initial mask for steel checking, separately for beams and columns. By default, values are set to 1/250 for beams (defTR) and 1/300 for columns (defCOL).


Checking from pushover analysis

Non-linear static analysis (pushover) needs a global check (performed in ADRS plane by the mash Extract Data) and local verifications, carried-out for each element, for brittle (shear) and ductile (flexure) mechanism.

Firstly, for steel structures, it is necessary to globally check the structure with the command N2 Method from inside Extract Data window, at the item Base shear X/Y VS Top displX/Y. Once the performance point has been determined, and hence the displacement demand is known, the closest point of the curve will be used. In such point, local checking will be performed for brittle and ductile mechanisms, directly on data supplied by hinges.

To conduct the verifications, inside the Verification mask, select in order:

- The pushover load case

- “I and J only” as active stations

- The checking set “Steel Hinge EC3”

- The reference Limit State. Life-safety is default

- Optionally, increase the accuracy of table results, to highlight even the lowest Demand/Capacity ratios.

If the global checking has been conducted correctly, the “time/mode” menu is automatically switched to time corresponding to the selected point on pushover curve representing the displacement demand (in the picture above, t=1.2706).

For steel structures, the verifications report:

- The ratio between the shear force and the strength, for both local directions y and z;

- The ration between the hinge rotation and the allowable chord rotation related to each single element.

Limit State | Class
 | 1 | 2 or higher
OLS | 2/3 Jy | 1/6 Jy
DLS | Jy | 1/4 Jy
LLS | 6 Jy | 2 Jy
CLS | 8 Jy | 3 Jy

with

where Mel is the elastic resisting moment, Lv is the contra-flexure span, E is Young’s modulus and J the inertia in the proper direction.


Chapter 4 Verifications for aluminium members

Chapter 4
Verifications for aluminium members

In this chapter, all the verifications performed by NextFEM Designer for aluminium beams/trusses are described. Such verification contains references to EN 1999-1-1 (Eurocode 9).


Verification listing

Verifications performed by NextFEM Designer for aluminium beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.

WARNING: all the verifications listed do not support Class 4 transversal sections.

WARNING: Inside the program, the material library Alloy lists the most spread aluminium alloys. Pay attention to the material names, which may include some limitations for particular section shapes:

SH - Sheet (EN 485)

ST - Strip (EN 485)

PL - Plate (EN 485)

ET - Extruded Tube (EN 755)

EP - Extruded Profiles (EN 755)

ER/B - Extruded Rod and Bar (EN 755)

DT - Drawn Tube (EN 754)

FO - Forgings (EN 586)


Estimation of section class

Conservatively, each section class is estimated as the maximum section class amongst the ones related to each part of the section, considered as fully in compression (te signifies section thickness).

Section type | Part | Ratio | Class 1 | Class 2 | Class 3
Rectangular |  | / |  |  | always
Double T, T, C | web | 0.9(h-tf1)/tw | b1 | b2 | b3
 | flange | 0.9(b/2-tw)/tf1 | b1 | b2 | b3
Angular | web | hmax/te |  |  | b3
 | flange | (b+h)/(2te) |  |  | b3
Box | web | (h-2te)/te | b1 | b2 | b3
 | flange | (b-2te)/te | b1 | b2 | b3
Pipe |  |  | b1 | b2 | b3
Bar |  | / |  | always |
Generic |  | / |  |  | always

The values b1, b2, b3 are computed automatically by considering the ratios b/e reported on the following table and multiplied by the parameter e defined as follows:

For the flanges in a section, the coefficients for the outstand parts are used; for webs and sides of a section, the coefficients for the internal parts are employed.

The design codes provide different coefficients for welded and non-welded sections. Coefficients for non-welded sections are taken by default, but it is possible to enforce the variable welded=1 before to start the checking, to force the procedure to assume all the sections as welded. To force the checking for welded material ONLY at beam ends, set the variable weldedEnds=1.

WARNING: for the welded section checking, the verification procedure uses the value of f0HAZ form the Alloy material library. In the case a custom material is used, please add the line “f0HAZ=xxx” in the textbox inside the Verification mask, with f0HAZ in MPa.

 |  | Internal part |  |  | Outstand part
 | Durability class | b1/e | b2/e | b3/e | b1/e | b2/e | b3/e
w/o welds | A | 11 | 16 | 22 | 3 | 4.5 | 6
 | B | 13 | 16.5 | 18 | 3.5 | 4.5 | 5
with welds | A | 9 | 13 | 18 | 2.5 | 4 | 5
 | B | 10 | 13.5 | 15 | 3 | 3.5 | 4

The column name of the program output is reported between brackets (i.e. (EulerBuckling)). In the following formula, f0 (or f0HAZ) is written as fyk.


Tension/compression (Axial)

In tension:

In compression (Eulerian buckling):

with [image] calculated on the base of the buckling coefficients, determined from Table 6.5 in Eurocode 9. The k parameter is always taken as 1.


Torsional buckling (TorsionBuckling)

WARNING: this checks is not performed for pipe sections in a scaffolding.

For torsional buckling, the second-order twisting moment (Vlasov’s contribution) is always neglected:

con

except for the following sections:

double T, I:

C-shaped: with [image] .

In evaluating the critical resisting moment, the coefficient [image] is forced to the value 1.127 if the beam has null moments at both ends. In any case, it is limited to 1.285. The values for the proper instability curves are taken from 6.3.2.2 of Eurocode 9.


Chapter 5 Verifications for reinforced concrete members

Chapter 5
Verifications for reinforced concrete members

In this chapter, all the verifications performed by NextFEM Designer for reinforced concrete beams and walls are described.


Symbols

A: Area

Jz: Moment of inertia around x-axis

Jy: Moment of inertia around y-axis

Jmin: Minimum moment of inertia

Jt: Torsional Inertia

D: Diameter of circular cross sections

Di: Inner diameter of pipe cross sections

te: Thickness of pipe cross sections

b: Base for any other cross sections

h: Height for any other cross sections

tw: web thickness

tf1: thickness of bottom flange

tf2: thickness of upper flange

t: thickness for planar sections

N: Axial force

Vy: Shear force along y direction

Vz: Shear force along z direction

Mt: Twisting moment

Myy: Moment around y local axis

Mzz: Moment around z local axis

Em: material Young modulus

Gm: material shear modulus

NIm: material Poisson’s ratio

fk: material characteristic strength

WelZ: section modulus for Z axis

WelY: section modulus for Y axis

WplZ: plastic section modulus for Z axis

WplY: plastic section modulus for Y axis

iz: radius of inertia for Z axis

iy: radius of inertia for Y axis

imin: minimum radius of inertia

SecType: 1=beam, 2=planar, 0=unknown

SecBeamType: 0=unknown, 1=rectangular, 2=circular, 3=Cshape, 4=Tshape, 5=DoubleTshape, 6=Lspahe, 7=box, 8=pipe

dx: axial relative displacement along beam axis

dy: transversal deflection in local direction y

dz: transversal deflection in local direction z

bwY: minimum section width in local direction y

bwZ: minimum section width in local direction z

ds: effective depth of the section

Astot: total area of rebar for a section

AsTens: total area of rebar in tension

fyks: characteristic strength for stirrups

fydl: design strength for longitudinal bars

rebCmin: distanza minima fra bordo e centro armatura longitudinale

isWall: equal to 1 if the section belongs to a wall, 0 otherwise

AmbCondition: environmental conditions for serviceability check (1,2,3)

mNt: ductility in tension for plastic hinges

mNc: ductility in compression for plastic hinges

mVy: ductility in shear (local direction y) for plastic hinges

mVz: ductility in shear (local direction z) for plastic hinges

mMt: torsional ductility for plastic hinges

mMy: flexural ductility (around local axis y) for plastic hinges

mMz: flexural ductility (around local axis z) for plastic hinges

NbH: maximum compressive strength for plastic hinges

MtH: elastic torsional strength for plastic hinges.


Verification listing

Verifications performed by NextFEM Designer for aluminium beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.

WARNING: all the verifications cover static combinations only. Seismic verifications of reinforced concrete members are not yet supported.


Ultimate Limit States

Stability in compression

Shear for members without shear reinforcement

For each local direction y and z:

with

Shear for members with shear reinforcement

Torsion

The value of [image] is assumed as the minimum between the 2 local directions y and z.

Shear and torsion

The ratio for shear forces is the maximum between the 2 local directions y and z.


Serviceability Limit States

Cracking

Given the exposure class of concrete, the variable AmbCondition can be set as 1 for normal conditions (X0, XC1), 2 for aggressive conditions (XC2, XC3, XC3) and 3 for extremely aggressive environmental conditions.

Environmental condition is needed for cracking control. The verification is performed without direct calculation using the following tables.

The maximum diameter values obtained in this way are corrected on the base of their material and their stress state using the following relationships.

The computed quantities are:

While the final value used for verification is

.

Deflection control

Beams limit deflection can be chosen by the user by setting the value defTR.

Checking is performed as follows:

Stress limitation

Stress control check for steel and concrete, for Characteristic and Quasi-Permanent combinations, are performed as follows:

Member detailing

Rebar area

The total compression and tension rebar areas are checked against the limit of [image] . Such control has a Boolean result.


Seismic design

Seismic checks are performed when the set name “EC8_Concrete” is selected. Such checking set contains all the verifications performed for static combinations and adds further prescriptions for seismic design of structures.

User has to set:

- The ductility class: H=1, M=2. M is default;

- For ductility checks: the behaviour factor q0, the corner period Tc of the design spectrum, the fundamental period of the structure T1.


Geometric checks

For beams:

For columns:

For walls:


Ductility checks

The ductility check is performed for sections of beams and columns inside the critical length. Ductility demand is evaluated as follows:

Since the check is performed inside critical regions, such values are amplified by 1.5, as required by EC8-1-1 5.2.3.4 (4).


Shear

Inside critical regions, [image] . Shear force is recalculated as per capacity design.


Column compression ratio (ColComprRatio)

with crc = 0.55 for ductility class H, 0.65 otherwise.


Beam-column joints


Capacity design

Bending:

Shear:

For beams, design shear force is evaluated as per the following scheme.

For walls, translation of Mz moment is performed for a length equal to hcr (critical height) and shear is amplified by q0.


Detailing for beams

Longitudinal reinforcements (RebarArea)

Hoops diameters (StirrupDiam)

Hoops spacing (StirrupSpac)

depending on ductility class “H” or “M”


Detailing for columns

Longitudinal reinforcements (RebarArea)

Longitudinal rebars spacing (RebarDist)

Hoops diameters (StirrupDiam)

depending on ductility class “H” or “M”

Hoops spacing (StirrupSpac)

depending on ductility class “H” or “M”


Shear verification in the plane for sliding walls (Sliding)

The resistance is the minimum between:


Checking FRP reinforcements

The verifications of the sections in c.a. reinforced with carbon fiber polymers (FRP) tapes are described below. The calculation procedure refers to the following Italian standards:

- CNR-DT 200 R1 / 2013 - Instructions for the Design, Execution and Control of Static Consolidation Interventions through the use of Fiber-reinforced Composites - Materials, reinforced concrete structures and of c.a.p., masonry structures;

- Guidelines for the Design, Execution and Testing of Reinforcement Interventions of reinforced concrete structures and masonry through FRP - Document approved on July 24, 2009 by the General Assembly of the Superior Council LL PP.

With reference to the CNR-DT200, the resistance of the FRP tape at the ultimate limit state is assumed to be the minimum between:

- Resistance due to detachment of ends, evaluated with the expression:

in which the specific fracture energy is evaluated as:

- Resistance for intermediate detachment, evaluated as:

also assuming an ultimate deformation equal to the minimum between the maximum declared by the manufacturer (multiplied by) and:

In output, the program reports the maximum tension that can be absorbed by the tape, the fracture energy and the minimum anchor length, obtained from the relationship:

in which [image] and [image] .


Checking from pushover analysis

Non-linear static analysis (pushover) needs a global check (performed in ADRS plane by the mash Extract Data) and local verifications, carried-out for each element, for brittle (shear) and ductile (flexure) mechanism.

Firstly, for RC structures, it is necessary to globally check the structure with the command N2 Method from inside Extract Data window, at the item Base shear X/Y VS Top displX/Y. Once the performance point has been determined, and hence the displacement demand is known, the closest point of the curve will be used. In such point, local checking will be performed for brittle and ductile mechanisms, directly on data supplied by hinges.

To conduct the verifications, inside the Verification mask, select in order:

- The pushover load case

- “I and J only” as active stations

- The checking set “EC8_RC_hinge”

- The reference Limit State. Life-safety is default

- Optionally, increase the accuracy of table results, to highlight even the lowest Demand/Capacity ratios.

If the global checking has been conducted correctly, the “time/mode” menu is automatically switched to time corresponding to the selected point on pushover curve representing the displacement demand (in the picture above, t=1.2706).

For RC structures, the verifications report:

- The ratio between the shear force and the strength, for both local directions y and z;

- The ration between the hinge rotation and the allowable chord rotation related to each single element.


Chapter 6 Verifications for timber members

Chapter 6
Verifications for timber members

In this chapter, all the verifications performed by NextFEM Designer for timber beams are described.


Symbols

A: Area

Jz: Moment of inertia around x-axis

Jy: Moment of inertia around y-axis

Jmin: Minimum moment of inertia

Jt: Torsional Inertia

D: Diameter of circular cross sections

Di: Inner diameter of pipe cross sections

te: Thickness of pipe cross sections

b: Base for any other cross sections

h: Height for any other cross sections

tw: web thickness

tf1: thickness of bottom flange

tf2: thickness of upper flange

t: thickness for planar sections

N: Axial force

Vy: Shear force along y direction

Vz: Shear force along z direction

Mt: Twisting moment

Myy: Moment around y local axis

Mzz: Moment around z local axis

Em: material Young modulus

Gm: material shear modulus

NIm: material Poisson’s ratio

fk: material characteristic strength

WelZ: section modulus for Z axis

WelY: section modulus for Y axis

WplZ: plastic section modulus for Z axis

WplY: plastic section modulus for Y axis

iz: radius of inertia for Z axis

iy: radius of inertia for Y axis

imin: minimum radius of inertia

SecType: 1=beam, 2=planar, 0=unknown

SecBeamType: 0=unknown, 1=rectangular, 2=circular, 3=Cshape, 4=Tshape, 5=DoubleTshape, 6=Lspahe, 7=box, 8=pipe

dx: axial relative displacement along beam axis

dy: transversal deflection in local direction y

dz: transversal deflection in local direction z

fc0k: axial compressive strenght parallel to fibres

fc90k: axial compressive strength normal to fibres

ft0k: axial tensile strenght parallel to fibres

fmk: bending strenght

E0mean: mean elastic modulus parallel to fibres

E005: 5% fractile of elastic modulus parallel to fibres

E90mean: mean elastic modulus normal to fibres

Gmean: mean shear modulus


Verification listing

Verifications performed by NextFEM Designer for wooden beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.

* WARNING: all the verifications cover only beams – walls are not supported.

* WARNING: only beams or columns with rectangular or circular sections are covered. All the other section types are not supported.


Ultimate Limit States

Tension

Compression

Bending

with km equal to 0.7 for rectangular sections, 1 otherwise.

Shear

For rectangular sections – less conservative direction

being kcr the reduction coefficient for section width (default 0.67).

For circular sections – shear resultant

Torsion

For rectangular sections:

with

For circular sections

Combined tension and bending

Combined compression and bending

Stability

For columns:

Given

If

For beams:

Given


Ultimate Limit States for CLT panels

Verifications are based on these basic quantities:

Local axes are set by the section cut used for checking.

The shear resistance for gluing is chosen by user [image] - recommended value is 2.5MPa. The rolling shear strength for CLT is assumed as:

Axial (with additional check from Teilprojekt-15 (5-45))

Compression normal to fibres

Shear-torsion

Shear – out of plane

Torsion for gluing

Rolling Shear

Stability

Stability check is carried-out in the same way as for timber columns.


Serviceability Limit States

Strength checks for serviceability limit states are the same as those listed for ultimate limit states.

Deformability checks for serviceability limit states are differentiated in the basis of the service combination type.
For characteristic combinations, the total deflection is calculated including viscous effects, as per the following relationship:

In which [image] is the deflection due to permanent loads, [image] due to principal variable loads, [image] due to i-th secondary loadcase in the service combination taken into account.

For the other service combinations, deflection is performed against the specified limit and reported just for completeness under the column “_Deflection”, which is not involved in checking ratio envelopes.

Deflection checks (Deflection)

WARNING: defLimit is defined in the initial mask for steel checking, separately for beams and columns. By default, values are set to 1/250 for beams (defTR) and 1/300 for columns (defCOL).


Chapter 7 Verifications for thin steel profiles

Chapter 7
Verifications for thin steel profiles

In this chapter, all the verifications performed by NextFEM Designer for thin profiles (cold-formed profiles) as per Eurocode 3 part 1-3 are described.


Symbols

A: Area

Jz: Moment of inertia around x-axis

Jy: Moment of inertia around y-axis

Jmin: Minimum moment of inertia

Jt: Torsional Inertia

D: Diameter of circular cross sections

Di: Inner diameter of pipe cross sections

te: Thickness of pipe cross sections

b: Base for any other cross sections

h: Height for any other cross sections

tw: web thickness

tf1: thickness of bottom flange

tf2: thickness of upper flange

t: thickness for planar sections

N: Axial force

Vy: Shear force along y direction

Vz: Shear force along z direction

Mt: Twisting moment

Myy: Moment around y local axis

Mzz: Moment around z local axis

Em: material Young modulus

Gm: material shear modulus

NIm: material Poisson’s ratio

fk: material characteristic strength

WelZ: section modulus for Z axis

WelY: section modulus for Y axis

WplZ: plastic section modulus for Z axis

WplY: plastic section modulus for Y axis

iz: radius of inertia for Z axis

iy: radius of inertia for Y axis

imin: minimum radius of inertia

SecType: 1=beam, 2=planar, 0=unknown

SecBeamType: 0=unknown, 1=rectangular, 2=circular, 3=Cshape, 4=Tshape, 5=DoubleTshape, 6=Lspahe, 7=box, 8=pipe

dx: axial relative displacement along beam axis

dy: transversal deflection in local direction y

dz: transversal deflection in local direction z


Verification listing

Verifications performed by NextFEM Designer for steel beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.

WARNING: all the verifications listed refer to transversal sections of Class 3 or 4. Plastic capacity, typically considered in Class 1 or 2 sections, are not taken into account for such profiles.


Base assumptions

Thin sections are represented by a series of points describing their piecewise middle line. Such kind of sections can be defined by adding a property set called “Cold formed” in the Properties tab of section properties. Requested data are the thickness tw and the radius of curvature rc.

As an alternative, an existing section can be converted to thin profile by the command in the Section window right click/Convert to/Cold-formed profile.

Section that can be converted are:

- C

- L

- Double C

- Double L

- Omega

- Omega with negative d parameter, alias C with reinforced flanges

- Boxed.


Estimation of section class

Conservatively, each section class is estimated as the maximum section class amongst the ones related to each part of the section, considered as fully compressed. Each single edge is evaluated separately, distinguishing between internal and external parts. The profile class is the maximum amongst all edges.

Part | Ratio | Class 1 | Class 2 | Class 3 | Class 4
external | beff/tw | 9e | 10e | 14e | /
internal | beff/tw | 33e | 38e | 42e | /

with

Effective lengths beff for each segment are calculated assuming each edge in compression, while warping coefficients are taken as 0.43 for external parts and 4 for internal parts.

The strength of material is always taken as the base one (noted with fyb in EC3-1-3).

Partial safety coefficients are taken, without user modification, as:

The column name of the program output is reported between brackets (i.e. (Axial))


Tension/compression (Axial)

In tension:

In compression (Eulerian buckling):

with [image] calculated on the base of the following buckling coefficients:

Type of section | ay | az | aLT
all | 0.49 | 0.49 | 0.76


Shear (Shear)

For web:

For flanges: with [image] as reduced shear strength.


Torsional buckling (TorsionBuckling)

For torsional buckling, the second-order twisting moment is a function of warping constant:

In evaluating the critical resisting moment, the coefficient [image] is forced to the value 1.127 if the beam has null moments at both ends. In any case, it is limited to 1.285.


Chapter 8 Verifications for thin aluminium alloy profiles

Chapter 8
Verifications for thin aluminium alloy profiles

In this chapter, all the verifications performed by NextFEM Designer for thin profiles (cold-formed profiles) as per Eurocode 9 part 1-4 are described.


Verification listing

Verifications performed by NextFEM Designer for beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.

WARNING: all the verifications listed refer to transversal sections of Class 3 or 4. Plastic capacity, typically considered in Class 1 or 2 sections, are not taken into account for such profiles.


Estimation of section class

Conservatively, each section class is estimated as the maximum section class amongst the ones related to each part of the section, considered as fully compressed. Each single edge is evaluated separately, distinguishing between internal and external parts. The profile class is the maximum amongst all edges.

Part | Ratio | Class 1 | Class 2 | Class 3 | Class 4
external | beff/tw | b1 | b2 | b3 | /
internal | beff/tw | b1 | b2 | b3 | /

The values b1, b2, b3 are computed automatically by considering the ratios b/e reported on the following table and multiplied by the parameter e defined as follows:

Effective lengths beff for each segment are calculated assuming each edge in compression, while warping coefficients are taken as 0.43 for external parts and 4 for internal parts.

The strength of material is always taken as the base one (noted with fo or foHAZ in EC9-1-4, denoted in the following as fyk).

Partial safety coefficients are taken, without user modification, as:

The column name in the output table is reported between brackets (i.e. (Axial))


Deflection checks

Deflection checks (Deflection)

WARNING: defLimit is defined in the initial mask for checking, separately for beams and columns. By default, values are set to 1/250 for beams (defTR) and 1/300 for columns (defCOL).


Chapter 9 Verifications for masonry structures

Chapter 9
Verifications for masonry structures

In this chapter, all the verifications performed by NextFEM Designer for masonry structures as per Eurocode 6 part 1-1 and Eurocode 8 part 3 are described.


Symbols

A: Area

Jz: Moment of inertia around x-axis

Jy: Moment of inertia around y-axis

Jmin: Minimum moment of inertia

Jt: Torsional Inertia

D: Diameter of circular cross sections

Di: Inner diameter of pipe cross sections

te: Thickness of pipe cross sections

b: Base for any other cross sections

h: Height for any other cross sections

tw: web thickness

tf1: thickness of bottom flange

tf2: thickness of upper flange

t: thickness for planar sections

N: Axial force

Vy: Shear force along y direction

Vz: Shear force along z direction

Mt: Twisting moment

Myy: Moment around y local axis

Mzz: Moment around z local axis

Em: material Young modulus

Gm: material shear modulus

NIm: material Poisson’s ratio

fk: material characteristic strength

WelZ: section modulus for Z axis

WelY: section modulus for Y axis

WplZ: plastic section modulus for Z axis

WplY: plastic section modulus for Y axis

iz: radius of inertia for Z axis

iy: radius of inertia for Y axis

imin: minimum radius of inertia

t: wall thickness

bm: wall length


Verification listing

Verifications performed by NextFEM Designer for beams/trusses are described afterwards. Each of them is expresses in terms of usage ratios of the checked section/element:

with [image] design force

is the design strength, equal to

is the material characteristic strength

is the partial safety factor the material.


Tensile failure (TensileFailure)


Vertical load stability (Axial)

with [image] a reduction factor evaluated as follows:

- for half-span station:

- for other stations: , as described in EC6 §6.1.2


In-plane bending (InPlaneBending)

as in EC8-3 C.4.2.1


Out-of-plane bending (OutOfPlaneBending)

as in EC8-3 C.4.2.1


Sliding shear (Shear)

with [image] and compressed length [image] :

For spandrels:


Checking from pushover analysis

Non-linear static analysis (pushover) needs a global check (performed in ADRS plane by the mash Extract Data).

For masonry structures, it is necessary to globally check the structure with the command N2 Method from inside Extract Data window, at the item Base shear X/Y VS Top displX/Y. Once the performance point has been determined, and hence the displacement demand is known, the closest point of the curve will be used.

Non-linear capacity can be calculated in NextFEM Designer by 2 approaches:

- By using plastic hinges at both ends of piers and spandrels;

- My means of masonryWall macroelements, available only for bi-dimensional modelling of panels.

Plastic hinges are defined by means of the following quantities:

Local DoF | Corresponding action | Strength | Ductility
1 | N (tension) | ftd * A | 1
1 | N (compression) | Nrd from stability | 1.5
2 | Vy | in-plane Vrd | 2.5
3 | Vz | bm*t*fvd0 | 2.5
4 | Mt | fvd0*Wt | /
5 | Myy | out-of-plane Mrd | 5
6 | Mzz | in-plane Mrd | 5

For cyclic analyses, plastic hinges follows a peak-oriented behaviour and keep the strength level of the cracking (it means resisting shear is not updated with axial load dynamically after elastic limit).

The masonryWall macroelement determines the strength as in the following:

- for piers, as the minimum between rocking (bending), sliding and diagonal cracking shear (for the latter, Turnsek-Cacovic formulation is adopted), evaluated at each increment as a function of the concurrent axial load. To esclude a mechanism, set to zero the corresponding strength in the material properties (fk, fvo and t0, ftu, respectively);

- for spandrels, the maximum between the pure shear strength (bm*t*fv0) and the diagonal cracking shear evaluated at each increment as a function of the concurrent axial load.

They exhibit in-plane and out-of-plane non-linear behaviour:

- Ultimate displacement by default is 0.005 L for shear mechanisms; it can be changed by adding the value “Du” as custom material property;

- Ultimate rotation by default is 0.01 for rocking mechanism; it can be changed by adding the value “Ru” as custom material property.

The usage of this macroelement is advised for pushover, cyclic and dynamic analyses.